summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-06-29 21:34:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-06-29 21:53:16 +0200
commit90dcb49e4a26fea8ce4698b7f5a20bc1469157d8 (patch)
tree24197e3d20cd3c4cc16ef81fe9120d0a0bcd27fb /kde-frameworks/kio
parentkde-frameworks/plasma: Drop 5.95.0-r3 (diff)
downloadgentoo-90dcb49e4a26fea8ce4698b7f5a20bc1469157d8.tar.gz
gentoo-90dcb49e4a26fea8ce4698b7f5a20bc1469157d8.tar.bz2
gentoo-90dcb49e4a26fea8ce4698b7f5a20bc1469157d8.zip
kde-frameworks/kio: filewidgets: update location text after selected
...files are renamed. Upstream commit 6d47b5869d4b328614e5e95e97ef66d97009295e KDE-bug: https://bugs.kde.org/show_bug.cgi?id=455327 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kio')
-rw-r--r--kde-frameworks/kio/files/kio-5.95.0-filewidgets-update-filename-after-rename.patch76
-rw-r--r--kde-frameworks/kio/kio-5.95.0-r1.ebuild96
2 files changed, 172 insertions, 0 deletions
diff --git a/kde-frameworks/kio/files/kio-5.95.0-filewidgets-update-filename-after-rename.patch b/kde-frameworks/kio/files/kio-5.95.0-filewidgets-update-filename-after-rename.patch
new file mode 100644
index 000000000000..5cf7b9f2fb45
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.95.0-filewidgets-update-filename-after-rename.patch
@@ -0,0 +1,76 @@
+From 6d47b5869d4b328614e5e95e97ef66d97009295e Mon Sep 17 00:00:00 2001
+From: Fushan Wen <qydwhotmail@gmail.com>
+Date: Wed, 15 Jun 2022 22:03:27 +0800
+Subject: [PATCH] filewidgets: update location text after selected files are
+ renamed
+
+Before this commit, the location text is not updated after the selected
+files are renamed.
+
+BUG: 455327
+---
+ src/filewidgets/kdiroperator.cpp | 3 ++-
+ src/filewidgets/kdiroperator.h | 9 +++++++++
+ src/filewidgets/kfilewidget.cpp | 4 ++++
+ 3 files changed, 15 insertions(+), 1 deletion(-)
+
+diff --git a/src/filewidgets/kdiroperator.cpp b/src/filewidgets/kdiroperator.cpp
+index c7a1c9350..adacfda60 100644
+--- a/src/filewidgets/kdiroperator.cpp
++++ b/src/filewidgets/kdiroperator.cpp
+@@ -889,8 +889,9 @@ void KDirOperator::renameSelected()
+ }
+
+ KIO::RenameFileDialog *dialog = new KIO::RenameFileDialog(items, this);
+- connect(dialog, &KIO::RenameFileDialog::renamingFinished, this, [this]() {
++ connect(dialog, &KIO::RenameFileDialog::renamingFinished, this, [this](const QList<QUrl> &urls) {
+ d->assureVisibleSelection();
++ Q_EMIT renamingFinished(urls);
+ });
+
+ dialog->open();
+diff --git a/src/filewidgets/kdiroperator.h b/src/filewidgets/kdiroperator.h
+index cb9668fb7..a15e90765 100644
+--- a/src/filewidgets/kdiroperator.h
++++ b/src/filewidgets/kdiroperator.h
+@@ -824,6 +824,7 @@ public Q_SLOTS:
+ /**
+ * Initiates a rename operation on the currently selected files/directories,
+ * prompting the user to choose a new name(s) for the currently selected items
++ * @see renamingFinished
+ * @since 5.67
+ */
+ void renameSelected();
+@@ -991,6 +992,14 @@ Q_SIGNALS:
+ */
+ void keyEnterReturnPressed();
+
++ /**
++ * Emitted when renaming selected files has finished.
++ *
++ * @param urls URL list of the renamed files
++ * @since 5.96
++ */
++ void renamingFinished(const QList<QUrl> &urls);
++
+ private:
+ friend class KDirOperatorPrivate;
+ std::unique_ptr<KDirOperatorPrivate> d;
+diff --git a/src/filewidgets/kfilewidget.cpp b/src/filewidgets/kfilewidget.cpp
+index 943c0cd93..d0825dfaa 100644
+--- a/src/filewidgets/kfilewidget.cpp
++++ b/src/filewidgets/kfilewidget.cpp
+@@ -1185,6 +1185,10 @@ void KFileWidgetPrivate::initDirOpWidgets()
+ q->connect(m_ops, &KDirOperator::keyEnterReturnPressed, q, [this]() {
+ slotViewKeyEnterReturnPressed();
+ });
++ q->connect(m_ops, &KDirOperator::renamingFinished, q, [this](const QList<QUrl> &urls) {
++ // Update file names in location text field after renaming selected files
++ q->setSelectedUrls(urls);
++ });
+
+ m_ops->dirLister()->setAutoErrorHandlingEnabled(false);
+ q->connect(m_ops->dirLister(), &KDirLister::jobError, q, [this](KIO::Job *job) {
+--
+GitLab
+
diff --git a/kde-frameworks/kio/kio-5.95.0-r1.ebuild b/kde-frameworks/kio/kio-5.95.0-r1.ebuild
new file mode 100644
index 000000000000..8b7697b65a88
--- /dev/null
+++ b/kde-frameworks/kio/kio-5.95.0-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org xdg-utils
+
+DESCRIPTION="Framework providing transparent file and data management"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="acl +handbook kerberos +kwallet X"
+
+# tests hang
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5[ssl]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ =kde-frameworks/kauth-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kbookmarks-${PVCUT}*:5
+ =kde-frameworks/kcodecs-${PVCUT}*:5
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kcrash-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/kguiaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kitemviews-${PVCUT}*:5
+ =kde-frameworks/kjobwidgets-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/ktextwidgets-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ =kde-frameworks/solid-${PVCUT}*:5
+ acl? (
+ sys-apps/attr
+ virtual/acl
+ )
+ handbook? ( =kde-frameworks/kdoctools-${PVCUT}*:5 )
+ kerberos? ( virtual/krb5 )
+ kwallet? ( =kde-frameworks/kwallet-${PVCUT}*:5 )
+ X? ( >=dev-qt/qtx11extras-${QTMIN}:5 )
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ test? ( sys-libs/zlib )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libX11
+ x11-libs/libXrender
+ )
+"
+PDEPEND=">=kde-frameworks/kded-${PVCUT}:5"
+
+PATCHES=( "${FILESDIR}/${P}-filewidgets-update-filename-after-rename.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DKIO_NO_PUBLIC_QTCONCURRENT=ON
+ $(cmake_use_find_package acl ACL)
+ $(cmake_use_find_package handbook KF5DocTools)
+ $(cmake_use_find_package kerberos GSSAPI)
+ $(cmake_use_find_package kwallet KF5Wallet)
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ ecm_pkg_postrm
+ xdg_desktop_database_update
+}