summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-13 16:43:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-15 07:36:12 +0200
commit75dd10c7d9dc7f20e73445bf31cce819ae962cb2 (patch)
tree683855d5c9ea0c6c30bc35bff7803a4990b31290 /kde-frameworks/kpackage/kpackage-5.60.0.ebuild
parentkde5.eclass: kde-frameworks/kdewebkit moved to portingAids (diff)
downloadgentoo-75dd10c7d9dc7f20e73445bf31cce819ae962cb2.tar.gz
gentoo-75dd10c7d9dc7f20e73445bf31cce819ae962cb2.tar.bz2
gentoo-75dd10c7d9dc7f20e73445bf31cce819ae962cb2.zip
kde-frameworks: Add KDE Frameworks 5.60.0
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kpackage/kpackage-5.60.0.ebuild')
-rw-r--r--kde-frameworks/kpackage/kpackage-5.60.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-frameworks/kpackage/kpackage-5.60.0.ebuild b/kde-frameworks/kpackage/kpackage-5.60.0.ebuild
new file mode 100644
index 000000000000..bcf035400b5a
--- /dev/null
+++ b/kde-frameworks/kpackage/kpackage-5.60.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Framework to install and load packages of non binary content"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="man"
+
+BDEPEND="
+ man? ( $(add_frameworks_dep kdoctools) )
+"
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ #bug 650214
+ local myctestargs=( -E "(plasma-plasmoidpackagetest)" )
+ kde5_src_test
+}