summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-11 12:50:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-11 13:26:17 +0100
commite8116aa13928bb4db16c9bc98858434ad92b6ec7 (patch)
treee4cc968f946b1e06a9cba2e8c260ce8637263270 /kde-frameworks/kpackage/kpackage-5.66.0.ebuild
parentgnome-base/gnome-keyring: remove old (diff)
downloadgentoo-e8116aa13928bb4db16c9bc98858434ad92b6ec7.tar.gz
gentoo-e8116aa13928bb4db16c9bc98858434ad92b6ec7.tar.bz2
gentoo-e8116aa13928bb4db16c9bc98858434ad92b6ec7.zip
kde-frameworks: Add KDE Frameworks 5.66.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kpackage/kpackage-5.66.0.ebuild')
-rw-r--r--kde-frameworks/kpackage/kpackage-5.66.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-frameworks/kpackage/kpackage-5.66.0.ebuild b/kde-frameworks/kpackage/kpackage-5.66.0.ebuild
new file mode 100644
index 000000000000..f31b5661c86e
--- /dev/null
+++ b/kde-frameworks/kpackage/kpackage-5.66.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+inherit ecm kde.org
+
+DESCRIPTION="Framework to install and load packages of non binary content"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="man"
+
+BDEPEND="
+ man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )
+"
+DEPEND="
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package man KF5DocTools)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ #bug 650214
+ local myctestargs=( -E "(plasma-plasmoidpackagetest)" )
+ ecm_src_test
+}