summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-21 21:10:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-23 15:48:42 +0200
commitf8c1a09a694200d16d53b18fba8dce1930f50a84 (patch)
tree0192834b7d62f2b3a92ad9ab52b2ae6503d83959 /kde-frameworks/plasma
parentkde-plasma: Add KDE Plasma 5.19.2 (diff)
downloadgentoo-f8c1a09a694200d16d53b18fba8dce1930f50a84.tar.gz
gentoo-f8c1a09a694200d16d53b18fba8dce1930f50a84.tar.bz2
gentoo-f8c1a09a694200d16d53b18fba8dce1930f50a84.zip
kde-frameworks/plasma: plasma-nm [1/2]: Fix password is asked twice
See also: https://mail.kde.org/pipermail/distributions/2020-June/000367.html KDE-Bug: https://bugs.kde.org/show_bug.cgi?id=423093 Upstream commit 7f9e189d87c040a952533713ff48d32872e0eadd "Add property to access the ExpandableListItem loader's item" Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/plasma')
-rw-r--r--kde-frameworks/plasma/files/plasma-5.71.0-access-expandedView.item.patch29
-rw-r--r--kde-frameworks/plasma/plasma-5.71.0-r1.ebuild78
2 files changed, 107 insertions, 0 deletions
diff --git a/kde-frameworks/plasma/files/plasma-5.71.0-access-expandedView.item.patch b/kde-frameworks/plasma/files/plasma-5.71.0-access-expandedView.item.patch
new file mode 100644
index 000000000000..ba1b35afbdeb
--- /dev/null
+++ b/kde-frameworks/plasma/files/plasma-5.71.0-access-expandedView.item.patch
@@ -0,0 +1,29 @@
+From 7f9e189d87c040a952533713ff48d32872e0eadd Mon Sep 17 00:00:00 2001
+From: Nate Graham <nate@kde.org>
+Date: Sun, 7 Jun 2020 08:46:39 -0600
+Subject: [PATCH] Add property to access the ExpandableListItem loader's item
+
+---
+ .../plasmaextracomponents/qml/ExpandableListItem.qml | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/src/declarativeimports/plasmaextracomponents/qml/ExpandableListItem.qml b/src/declarativeimports/plasmaextracomponents/qml/ExpandableListItem.qml
+index d9d0662ee..ed21ab8e4 100644
+--- a/src/declarativeimports/plasmaextracomponents/qml/ExpandableListItem.qml
++++ b/src/declarativeimports/plasmaextracomponents/qml/ExpandableListItem.qml
+@@ -261,6 +261,12 @@ Item {
+ */
+ property var customExpandedViewContent: actionsListComponent
+
++ /*
++ * The actual instance of the custom view content, if loaded
++ * @since 5.72
++ */
++ property alias customExpandedViewContentItem: expandedView.item
++
+ /*
+ * isBusy: bool
+ * Whether or not to display a busy indicator on the list item. Set to true
+--
+2.27.0
+
diff --git a/kde-frameworks/plasma/plasma-5.71.0-r1.ebuild b/kde-frameworks/plasma/plasma-5.71.0-r1.ebuild
new file mode 100644
index 000000000000..1a711a9450d2
--- /dev/null
+++ b/kde-frameworks/plasma/plasma-5.71.0-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_ORG_NAME="${PN}-framework"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Plasma framework"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="gles2-only wayland X"
+
+BDEPEND="
+ >=kde-frameworks/kdoctools-${PVCUT}:5
+"
+RDEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=]
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kactivities-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdeclarative-${PVCUT}*:5
+ =kde-frameworks/kglobalaccel-${PVCUT}*:5
+ =kde-frameworks/kguiaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ !gles2-only? ( virtual/opengl )
+ wayland? (
+ =kde-frameworks/kwayland-${PVCUT}*:5
+ media-libs/mesa[egl]
+ )
+ X? (
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libX11
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+RESTRICT+=" test"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-access-expandedView.item.patch # KDE-bug #423093
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package !gles2-only OpenGL)
+ $(cmake_use_find_package wayland EGL)
+ $(cmake_use_find_package wayland KF5Wayland)
+ $(cmake_use_find_package X X11)
+ $(cmake_use_find_package X XCB)
+ )
+
+ ecm_src_configure
+}