summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-11 14:55:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-11 17:36:50 +0200
commit9469c9b2f4cf5cb621ce729730c3b83094966f80 (patch)
tree849fb729d90a723eb00ad0690b96cd678d691366 /kde-frameworks/prison
parentkde-frameworks/oxygen-icons: 5.72.0 version bump (diff)
downloadgentoo-9469c9b2f4cf5cb621ce729730c3b83094966f80.tar.gz
gentoo-9469c9b2f4cf5cb621ce729730c3b83094966f80.tar.bz2
gentoo-9469c9b2f4cf5cb621ce729730c3b83094966f80.zip
kde-frameworks/prison: 5.72.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/prison')
-rw-r--r--kde-frameworks/prison/Manifest1
-rw-r--r--kde-frameworks/prison/prison-5.72.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/kde-frameworks/prison/Manifest b/kde-frameworks/prison/Manifest
index 03c585512dd8..bab84ebc981e 100644
--- a/kde-frameworks/prison/Manifest
+++ b/kde-frameworks/prison/Manifest
@@ -1,2 +1,3 @@
DIST prison-5.70.0.tar.xz 41004 BLAKE2B 949e7f5c6f185eb2ea07ac62d5cfaaa5b12089a88004f99996948d9a2cecfe5fd0126a6232c788035c1874c771e54c4f666d6767e0b43c4ffef7a9ca6dbd6cf4 SHA512 aa6275b7f45f10c1199efc375e990119505f1cb839871fbe4e642a01478daa62fd49ba6737dac73f8adfc67b77b43f99b9be7a4c557b12efa5e7c3fef813f16a
DIST prison-5.71.0.tar.xz 40964 BLAKE2B 89117d5b1fb3f86faab99e538a5f5c128daf0593d82e36426debd0e4d20e7cb03d1615a48bab1d31125c851c0031a49774062500ab80a2fe5ffe1be4a26e755e SHA512 fc82066f704a0576bc50698ecf7ba7146bc0f77151ac8f596ebc48145db9c05dd57ab8b0eff398d3d3f55c922c5d2d7c8bb96817b42ec8981dba7a23414efac9
+DIST prison-5.72.0.tar.xz 41216 BLAKE2B b2e43482bab525dc36d502b9778952644cdecff1a60498456f596dea0caeda96348996e0d8ed240d1b74f07e6335527902d2fda066a77b1b104dd90d8aa1d9e3 SHA512 5f3021a23f4724de77bcbe942b023561dadcf39966d170ebb04885aced86fe6196b88bf5ed7f3cee1235d8fb5d2d1bef6c9e5b46eaa3e646ec44acd38a070f7d
diff --git a/kde-frameworks/prison/prison-5.72.0.ebuild b/kde-frameworks/prison/prison-5.72.0.ebuild
new file mode 100644
index 000000000000..9a2b0ebc07db
--- /dev/null
+++ b/kde-frameworks/prison/prison-5.72.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+QTMIN=5.14.2
+inherit ecm kde.org
+
+DESCRIPTION="QRCode and data matrix barcode library"
+HOMEPAGE="https://invent.kde.org/frameworks/prison"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="qml"
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ media-gfx/qrencode:=
+ media-libs/libdmtx
+ qml? ( >=dev-qt/qtdeclarative-${QTMIN}:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt5Quick)
+ )
+
+ ecm_src_configure
+}