summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-10 11:32:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-10 12:37:30 +0100
commit8adea4ad9cbf6c966431c0d9224b5d459059f9cd (patch)
treeff9de58067cb9165ba809d8c51dbbc8dc4475668 /kde-frameworks/sonnet/sonnet-5.41.0.ebuild
parentnet-libs/*: Update Manifest hashes (diff)
downloadgentoo-8adea4ad9cbf6c966431c0d9224b5d459059f9cd.tar.gz
gentoo-8adea4ad9cbf6c966431c0d9224b5d459059f9cd.tar.bz2
gentoo-8adea4ad9cbf6c966431c0d9224b5d459059f9cd.zip
kde-frameworks: Add KDE Frameworks 5.41.0
Package-Manager: Portage-2.3.17, Repoman-2.3.6
Diffstat (limited to 'kde-frameworks/sonnet/sonnet-5.41.0.ebuild')
-rw-r--r--kde-frameworks/sonnet/sonnet-5.41.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/sonnet-5.41.0.ebuild b/kde-frameworks/sonnet/sonnet-5.41.0.ebuild
new file mode 100644
index 000000000000..7d13e6f89d8c
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.41.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+RDEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package aspell ASPELL)
+ $(cmake-utils_use_find_package hunspell HUNSPELL)
+ )
+
+ kde5_src_configure
+}