summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-08 11:05:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-08 12:54:50 +0200
commit30ba0c6fbfd5f220b7a35a5a0fe27273dc408d0d (patch)
tree95ca17ef3ecc2dffa267182f77e2a75a4ee94335 /kde-frameworks/syntax-highlighting
parentkde-frameworks/sonnet: 5.73.0 version bump (diff)
downloadgentoo-30ba0c6fbfd5f220b7a35a5a0fe27273dc408d0d.tar.gz
gentoo-30ba0c6fbfd5f220b7a35a5a0fe27273dc408d0d.tar.bz2
gentoo-30ba0c6fbfd5f220b7a35a5a0fe27273dc408d0d.zip
kde-frameworks/syntax-highlighting: 5.73.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/syntax-highlighting')
-rw-r--r--kde-frameworks/syntax-highlighting/Manifest1
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.73.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/Manifest b/kde-frameworks/syntax-highlighting/Manifest
index 2a8dd460b9e5..643c8a5c304f 100644
--- a/kde-frameworks/syntax-highlighting/Manifest
+++ b/kde-frameworks/syntax-highlighting/Manifest
@@ -1,2 +1,3 @@
DIST syntax-highlighting-5.70.0.tar.xz 1606544 BLAKE2B 573a16979e9d2adff8562312c7681acbfbfaac906cf5eef2b1c8ae4131a555b89e4900d0d0e63b1a2fab3ac535e7c2daf0d847637d16d9eed9f4a07b30554c53 SHA512 59a05fd274cb11b893351cc10747600e03ced88cdc738eee26689e9a2a97b07db05805c0b0dcadbf02809254bd170b04f27b8372abb26b769bc6e962c615b9e0
DIST syntax-highlighting-5.72.0.tar.xz 1621628 BLAKE2B 5638451e11244cf0a82602c3d062f60e87a70ed2444bda6248d3d1ecddc96a3d26ea21a957fcede8eb18847477637220f7682c67792d04707ede98dffc852839 SHA512 cbeb375a0c5af7646848f6d2df112f5ded5cb8614ab8054fae4133ff5420624879bb3db57928d5528731f100497ccb30b348555444eded5a87b95be49e747c23
+DIST syntax-highlighting-5.73.0.tar.xz 1765768 BLAKE2B 82dddddc46f2e70b4c4dc036dae88dda0355e877e89552d86f16c241b1fa669d32cd7a8d6c4cdf54d523f510df23ce10b2e45ed341dcb8380e17f0d750ec259e SHA512 e283fb750266053d5c452caeba53e8126203c8cec14ea5458ef979e8cc79ad9f161fab9728ad36703dae15edd71aaec2c1f3263c06b8c97aab85e458c3df2dea
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.73.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.73.0.ebuild
new file mode 100644
index 000000000000..352f17f8e6fa
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.73.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+QTMIN=5.14.2
+inherit ecm kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-lang/perl
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}