summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-05-30 09:55:18 +0200
committerJohannes Huber <johu@gentoo.org>2016-05-30 09:55:56 +0200
commit335d95a59f805d1bd9874b2936f3e62515cc3893 (patch)
treeeaf2fb41d57f5b6851e741bd9e7d73f9f54cdbce /kde-frameworks
parentdev-libs/expat-2.1.1-r1: add alpha keyword (diff)
downloadgentoo-335d95a59f805d1bd9874b2936f3e62515cc3893.tar.gz
gentoo-335d95a59f805d1bd9874b2936f3e62515cc3893.tar.bz2
gentoo-335d95a59f805d1bd9874b2936f3e62515cc3893.zip
kde-frameworks/kf-env: Version bump 4
EAPI 6. Increase required xdg-utils. Gentoo-bug: 578848 Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kf-env/kf-env-4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-frameworks/kf-env/kf-env-4.ebuild b/kde-frameworks/kf-env/kf-env-4.ebuild
new file mode 100644
index 00000000000..780bc11c61a
--- /dev/null
+++ b/kde-frameworks/kf-env/kf-env-4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Environment setting required for all KDE Frameworks apps to run"
+HOMEPAGE="https://community.kde.org/Frameworks"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-misc/xdg-utils-1.1.1-r1"
+
+S=${WORKDIR}
+
+src_install() {
+ einfo "Installing environment file..."
+
+ # higher number to be sure not to kill kde4 env
+ local envfile="${T}/78kf"
+
+ echo "CONFIG_PROTECT=${EPREFIX}/usr/share/config" >> ${envfile}
+ doenvd ${envfile}
+}