summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-09-28 22:11:02 +0200
committerMichael Palimaka <kensington@gentoo.org>2016-09-29 21:39:06 +1000
commit9e03422ea373c87e67f7ad2920681a9283c1ebfc (patch)
treec55de92a8b0f81bd1df757204247221c82e9771e /kde-frameworks
parentkde-frameworks/baloo: Drop old (diff)
downloadgentoo-9e03422ea373c87e67f7ad2920681a9283c1ebfc.tar.gz
gentoo-9e03422ea373c87e67f7ad2920681a9283c1ebfc.tar.bz2
gentoo-9e03422ea373c87e67f7ad2920681a9283c1ebfc.zip
kde-frameworks/kio: Fix ABI break and limitation to TLS 1.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kio/files/kio-5.26.0-fix-abi-break.patch64
-rw-r--r--kde-frameworks/kio/files/kio-5.26.0-secureprotocols.patch26
-rw-r--r--kde-frameworks/kio/kio-5.26.0-r2.ebuild86
3 files changed, 176 insertions, 0 deletions
diff --git a/kde-frameworks/kio/files/kio-5.26.0-fix-abi-break.patch b/kde-frameworks/kio/files/kio-5.26.0-fix-abi-break.patch
new file mode 100644
index 00000000000..0cbe72eef97
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.26.0-fix-abi-break.patch
@@ -0,0 +1,64 @@
+From: José Manuel Santamaría Lema <panfaust@gmail.com>
+Date: Wed, 28 Sep 2016 07:53:08 +0000
+Subject: Fix ABI break in kio
+X-Git-Url: http://quickgit.kde.org/?p=kio.git&a=commitdiff&h=89f8bcf00fc2fc17527d7bb4e0e2aea51f8776cb
+---
+Fix ABI break in kio
+
+From the binary compatibility page "Do's and Don'ts":
+https://community.kde.org/Policies/Binary_Compatibility_Issues_With_C%2B%2B#The_Do.27s_and_Don.27ts
+You cannot...
+[...]
+For existing functions of any type:
+[...]
+inline it (this includes moving a member function's body to the class definition, even without the inline keyword).
+
+REVIEW: 129032
+---
+
+
+--- a/src/widgets/kpropertiesdialog.cpp
++++ b/src/widgets/kpropertiesdialog.cpp
+@@ -500,6 +500,11 @@
+ KPreviewPropsPlugin::supports( _items )*/;
+ }
+
++void KPropertiesDialog::slotOk()
++{
++ accept();
++}
++
+ void KPropertiesDialog::accept()
+ {
+ QList<KPropertiesDialogPlugin *>::const_iterator pageListIt;
+@@ -541,6 +546,11 @@
+ deleteLater(); // somewhat like Qt::WA_DeleteOnClose would do.
+ KPageDialog::accept();
+ } // else, keep dialog open for user to fix the problem.
++}
++
++void KPropertiesDialog::slotCancel()
++{
++ reject();
+ }
+
+ void KPropertiesDialog::reject()
+
+--- a/src/widgets/kpropertiesdialog.h
++++ b/src/widgets/kpropertiesdialog.h
+@@ -341,12 +341,12 @@
+ * Called when the user presses 'Ok'.
+ * @deprecated since 5.25, use accept()
+ */
+- KIOWIDGETS_DEPRECATED virtual void slotOk() { accept(); }
++ KIOWIDGETS_DEPRECATED virtual void slotOk();
+ /**
+ * Called when the user presses 'Cancel'.
+ * @deprecated since 5.25, use reject()
+ */
+- KIOWIDGETS_DEPRECATED virtual void slotCancel() { reject(); }
++ KIOWIDGETS_DEPRECATED virtual void slotCancel();
+
+ /**
+ * Called when the user presses 'Ok'.
+
diff --git a/kde-frameworks/kio/files/kio-5.26.0-secureprotocols.patch b/kde-frameworks/kio/files/kio-5.26.0-secureprotocols.patch
new file mode 100644
index 00000000000..d7b42841c57
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.26.0-secureprotocols.patch
@@ -0,0 +1,26 @@
+From: Andrius Štikonas <andrius@stikonas.eu>
+Date: Mon, 26 Sep 2016 17:15:02 +0000
+Subject: Fix kio using only tls1.0.
+X-Git-Url: http://quickgit.kde.org/?p=kio.git&a=commitdiff&h=8196a735bebc6fd5eaf9d293bd565c00ef98516b
+---
+Fix kio using only tls1.0.
+
+Now kio should use QSsl::SslProtocol::SecureProtocols which will deprecate
+unsafe TLS versions when they are no longer safe.
+
+REVIEW: 129031
+---
+
+
+--- a/src/core/tcpslavebase.cpp
++++ b/src/core/tcpslavebase.cpp
+@@ -492,7 +492,7 @@
+ if (d->usingSSL) {
+ return false;
+ }
+- return d->startTLSInternal(KTcpSocket::TlsV1) & ResultOk;
++ return d->startTLSInternal(KTcpSocket::SecureProtocols) & ResultOk;
+ }
+
+ TCPSlaveBase::SslResult TCPSlaveBase::TcpSlaveBasePrivate::startTLSInternal(KTcpSocket::SslVersion version,
+
diff --git a/kde-frameworks/kio/kio-5.26.0-r2.ebuild b/kde-frameworks/kio/kio-5.26.0-r2.ebuild
new file mode 100644
index 00000000000..90abbd05549
--- /dev/null
+++ b/kde-frameworks/kio/kio-5.26.0-r2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework providing transparent file and data management"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="acl +handbook kerberos +kwallet X"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork 'ssl')
+ $(add_qt_dep qtscript)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/libxml2
+ dev-libs/libxslt
+ acl? (
+ sys-apps/attr
+ virtual/acl
+ )
+ kerberos? ( virtual/krb5 )
+ kwallet? ( $(add_frameworks_dep kwallet) )
+ X? ( $(add_qt_dep qtx11extras) )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_qt_dep qtconcurrent)
+ handbook? ( $(add_frameworks_dep kdoctools) )
+ test? ( sys-libs/zlib )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-proto/xproto
+ )
+"
+PDEPEND="
+ $(add_frameworks_dep kded)
+"
+RDEPEND="${COMMON_DEPEND}"
+
+# tests hang
+RESTRICT+=" test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-desktop-launch.patch"
+ "${FILESDIR}/${P}-fix-abi-break.patch"
+ "${FILESDIR}/${P}-secureprotocols.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package acl ACL)
+ $(cmake-utils_use_find_package handbook KF5DocTools)
+ $(cmake-utils_use_find_package kerberos GSSAPI)
+ $(cmake-utils_use_find_package kwallet KF5Wallet)
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}