summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-09-25 22:41:53 +0200
committerMichael Palimaka <kensington@gentoo.org>2016-09-28 19:49:45 +1000
commita6d4f3a58e776ceb93484ce8122419f2eb57998a (patch)
tree42476f1cb29ee2cf24715fe087a3ca82a72d2530 /kde-frameworks
parentdev-libs/kirigami: new package (diff)
downloadgentoo-a6d4f3a58e776ceb93484ce8122419f2eb57998a.tar.gz
gentoo-a6d4f3a58e776ceb93484ce8122419f2eb57998a.tar.bz2
gentoo-a6d4f3a58e776ceb93484ce8122419f2eb57998a.zip
kde-frameworks/kwallet: Add missing boost header
Fixes build error with GpgME-1.7.0 (which was ported away from boost). Gentoo-bug: 595096 Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kwallet/files/kwallet-5.26.0-missing-boost-header.patch22
-rw-r--r--kde-frameworks/kwallet/kwallet-5.26.0.ebuild2
2 files changed, 24 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/files/kwallet-5.26.0-missing-boost-header.patch b/kde-frameworks/kwallet/files/kwallet-5.26.0-missing-boost-header.patch
new file mode 100644
index 000000000000..8bf16f0d1d50
--- /dev/null
+++ b/kde-frameworks/kwallet/files/kwallet-5.26.0-missing-boost-header.patch
@@ -0,0 +1,22 @@
+commit 0ae542bfa6e266ead736d6cca5f979dac75e24f2
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun Sep 25 14:56:55 2016 +0200
+
+ Add missing boost header
+
+ Fixes build error with GpgME-1.7.0 (which was ported away from boost).
+
+ REVIEW: 129012
+
+diff --git a/src/runtime/kwalletd/kwalletwizard.cpp b/src/runtime/kwalletd/kwalletwizard.cpp
+index bf36f3b..cd52e54 100644
+--- a/src/runtime/kwalletd/kwalletwizard.cpp
++++ b/src/runtime/kwalletd/kwalletwizard.cpp
+@@ -39,6 +39,7 @@
+ #include <QDebug>
+ #include <kmessagebox.h>
+ #include <gpgme.h>
++#include <boost/shared_ptr.hpp>
+ #endif
+
+ class PageIntro : public QWizardPage
diff --git a/kde-frameworks/kwallet/kwallet-5.26.0.ebuild b/kde-frameworks/kwallet/kwallet-5.26.0.ebuild
index a9f81521a862..b9a585092f3c 100644
--- a/kde-frameworks/kwallet/kwallet-5.26.0.ebuild
+++ b/kde-frameworks/kwallet/kwallet-5.26.0.ebuild
@@ -35,6 +35,8 @@ DEPEND="${RDEPEND}
man? ( $(add_frameworks_dep kdoctools) )
"
+PATCHES=( "${FILESDIR}/${P}-missing-boost-header.patch" )
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package gpg Gpgme)