summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-04-15 05:52:17 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-04-15 05:52:28 +1000
commit30bef4b1ddfc0a1da0e73c1be3765ab729b197fd (patch)
tree37f60a08f529c37e2691a64394963e20419cf445 /kde-misc/kdeconnect
parentprofiles: mask kde-misc/kdeconnect[telepathy] due to unreleased dependencies (diff)
downloadgentoo-30bef4b1ddfc0a1da0e73c1be3765ab729b197fd.tar.gz
gentoo-30bef4b1ddfc0a1da0e73c1be3765ab729b197fd.tar.bz2
gentoo-30bef4b1ddfc0a1da0e73c1be3765ab729b197fd.zip
kde-misc/kdeconnect: version bump
Imported from kde overlay. Gentoo-bug: 578518 Package-Manager: portage-2.2.28
Diffstat (limited to 'kde-misc/kdeconnect')
-rw-r--r--kde-misc/kdeconnect/Manifest1
-rw-r--r--kde-misc/kdeconnect/kdeconnect-0.9g.ebuild81
-rw-r--r--kde-misc/kdeconnect/metadata.xml5
3 files changed, 87 insertions, 0 deletions
diff --git a/kde-misc/kdeconnect/Manifest b/kde-misc/kdeconnect/Manifest
index e6b042e24d60..847072eaf2cf 100644
--- a/kde-misc/kdeconnect/Manifest
+++ b/kde-misc/kdeconnect/Manifest
@@ -1 +1,2 @@
DIST kdeconnect-kde-0.8.tar.xz 141916 SHA256 c33611c076a327a67f9974ffa5662f2c093dda6ad14024e434027f9f19d9a0ab SHA512 7c7c460648960dde501596c85282eddd4d9add3b1be291b6d22a75f316cce6cdee0015d81b275eaa7c66758dcf16fa21da1be9b79f12b68c76bad343eef7250e WHIRLPOOL 0d302b4c6005100db9bc44ca590ee330bc6f432af02bfd1d2f27b367f38b6d4993828a3726c2bf3acaafcaa00c1724a9592ee8a652152f6b811923c351d3f499
+DIST kdeconnect-kde-0.9g.tar.xz 183632 SHA256 4033754057bbc993b1d4350959afbe1d17a4f1e56dd60c6df6abca5a321ee1b8 SHA512 39c857d139563806d0805409dce3f2bec3d776d23b3228ff72f3878717eed4558990e1b0b4055728b7643956e73994329960caea9e348dccfb6645a7b0f68445 WHIRLPOOL 9c41faff4f6b171af9e74a867c7b665b82e29d28a743cb4aef3ce44beb5463c09567a82be89fe3472748b99608444790b79725248b4c24b9d7cd677930061452
diff --git a/kde-misc/kdeconnect/kdeconnect-0.9g.ebuild b/kde-misc/kdeconnect/kdeconnect-0.9g.ebuild
new file mode 100644
index 000000000000..c7df8c330ca8
--- /dev/null
+++ b/kde-misc/kdeconnect/kdeconnect-0.9g.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+KDE_TEST="true"
+KMNAME="${PN}-kde"
+inherit kde5
+
+DESCRIPTION="Adds communication between KDE and your smartphone"
+HOMEPAGE="https://www.kde.org/ https://community.kde.org/KDEConnect"
+SRC_URI="mirror://kde/unstable/${PN}/0.9/src/${KMNAME}-${PV}.tar.xz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64"
+IUSE="app +telepathy wayland"
+
+DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ >=app-crypt/qca-2.1.0:2[qt5,openssl]
+ x11-libs/libfakekey
+ x11-libs/libX11
+ x11-libs/libXtst
+ app? ( $(add_frameworks_dep kdeclarative) )
+ telepathy? ( >=net-libs/telepathy-qt-0.9.7[qt5] )
+ wayland? ( $(add_plasma_dep kwayland) )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep plasma-workspace)
+ wayland? ( $(add_plasma_dep kwin) )
+ !kde-misc/kdeconnect:4
+"
+
+src_prepare() {
+ sed \
+ -e 's#${LIBEXEC_INSTALL_DIR}#@KDE_INSTALL_FULL_LIBEXECDIR@#' \
+ -i daemon/kdeconnectd.desktop.cmake || die
+
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DEXPERIMENTALAPP_ENABLED=$(usex app)
+ $(cmake-utils_use_find_package telepathy TelepathyQt5)
+ $(cmake-utils_use_find_package telepathy TelepathyQt5Service)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst(){
+ kde5_pkg_postinst
+
+ elog
+ elog "Optional dependency:"
+ elog "sys-fs/sshfs (for 'remote filesystem browser' plugin)"
+ elog
+ elog "The Android .apk file is available via"
+ elog "https://play.google.com/store/apps/details?id=org.kde.kdeconnect_tp"
+ elog
+}
diff --git a/kde-misc/kdeconnect/metadata.xml b/kde-misc/kdeconnect/metadata.xml
index 2fdbf33d963d..67aab7086880 100644
--- a/kde-misc/kdeconnect/metadata.xml
+++ b/kde-misc/kdeconnect/metadata.xml
@@ -5,4 +5,9 @@
<email>kde@gentoo.org</email>
<name>Gentoo KDE Project</name>
</maintainer>
+ <use>
+ <flag name="app">Enable experimental kcapp frontend</flag>
+ <flag name="telepathy">Enable <pkg>net-libs/telepathy-qt</pkg> support to receive text messages and respond to them</flag>
+ <flag name="wayland">Enable kwin_wayland support for mousepad plugin using <pkg>kde-frameworks/kwayland</pkg></flag>
+ </use>
</pkgmetadata>