summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-03-12 21:16:03 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-03-14 03:42:06 +1100
commit150a0a585939170c0c402e16ad778842a0df0dc1 (patch)
tree8a783f3f8fd28705ae945aa1aa7dcce8ffb5fca1 /kde-misc/kdirstat
parentkde5.eclass: Don't remove CMakeLists.txt in po directory (diff)
downloadgentoo-150a0a585939170c0c402e16ad778842a0df0dc1.tar.gz
gentoo-150a0a585939170c0c402e16ad778842a0df0dc1.tar.bz2
gentoo-150a0a585939170c0c402e16ad778842a0df0dc1.zip
kde-misc/kdirstat: force handbook optional, EAPI=6
Package-Manager: portage-2.2.27
Diffstat (limited to 'kde-misc/kdirstat')
-rw-r--r--kde-misc/kdirstat/kdirstat-3.0-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/kde-misc/kdirstat/kdirstat-3.0-r1.ebuild b/kde-misc/kdirstat/kdirstat-3.0-r1.ebuild
new file mode 100644
index 000000000000..ab99e5ff66bf
--- /dev/null
+++ b/kde-misc/kdirstat/kdirstat-3.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Nice KDE replacement to the du command"
+HOMEPAGE="https://bitbucket.org/jeromerobert/k4dirstat/"
+SRC_URI="https://bitbucket.org/jeromerobert/k4dirstat/get/k4dirstat-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ sys-libs/zlib
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-misc/kdirstat:4
+"
+
+DOCS=( AUTHORS CREDITS TODO )
+
+src_unpack() {
+ # tarball contains git revision hash, which we don't want in the ebuild.
+ default
+ mv "${WORKDIR}"/*k4dirstat-* "${S}" || die
+}