summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-02-20 17:58:57 +0100
committerJohannes Huber <johu@gentoo.org>2017-02-20 18:01:59 +0100
commitc2950d97dd61e21f526d6c388772fc634afa8156 (patch)
tree781467c9e70a1cbee354cd1e4833611a387db20c /kde-misc
parentkde-misc/serverstatuswidget: Remove last-rited pkg (diff)
downloadgentoo-c2950d97dd61e21f526d6c388772fc634afa8156.tar.gz
gentoo-c2950d97dd61e21f526d6c388772fc634afa8156.tar.bz2
gentoo-c2950d97dd61e21f526d6c388772fc634afa8156.zip
kde-misc/smooth-tasks: Remove last-rited pkg
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/smooth-tasks/Manifest1
-rw-r--r--kde-misc/smooth-tasks/files/smooth-tasks-0_p20120130-kde48.patch176
-rw-r--r--kde-misc/smooth-tasks/metadata.xml11
-rw-r--r--kde-misc/smooth-tasks/smooth-tasks-0_p20120130.ebuild29
4 files changed, 0 insertions, 217 deletions
diff --git a/kde-misc/smooth-tasks/Manifest b/kde-misc/smooth-tasks/Manifest
deleted file mode 100644
index e06a91f90143..000000000000
--- a/kde-misc/smooth-tasks/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST smooth-tasks-0_p20120130.tar.xz 268104 SHA256 3819147acc0b1dd05e4a2ea4c3bff38bc44aaa4a4605cbcad3d029d575fc4867 SHA512 b6cc2a3c27ace0399533d983e43ec188e6e988a5b2a2bf51061197d6450df23b7f0e3c8b78a141454ba65de93f3cce7cc7b4c2c5735018335a2f397634993c66 WHIRLPOOL 482a2076ecfa3b215383b32f253bc77ae5e50bfca67939dcb7f9b2070e3d9dd063ea7dd272d81f4dfab30dad087188fd3ca1f58c91e5fcf68a00a3c71baaac70
diff --git a/kde-misc/smooth-tasks/files/smooth-tasks-0_p20120130-kde48.patch b/kde-misc/smooth-tasks/files/smooth-tasks-0_p20120130-kde48.patch
deleted file mode 100644
index c754ba1c2fe5..000000000000
--- a/kde-misc/smooth-tasks/files/smooth-tasks-0_p20120130-kde48.patch
+++ /dev/null
@@ -1,176 +0,0 @@
-diff -u src/smooth-tasks-fork/applet/SmoothTasks/PlasmaToolTip.cpp src/smooth-tasks-fork/applet/SmoothTasksX/PlasmaToolTip.cpp
---- src/smooth-tasks-fork/applet/SmoothTasks/PlasmaToolTip.cpp 2011-12-24 03:13:55.604361299 +0100
-+++ src/smooth-tasks-fork/applet/SmoothTasksX/PlasmaToolTip.cpp 2011-12-24 03:11:00.000000000 +0100
-@@ -91,7 +91,7 @@
- }
-
- Plasma::ToolTipContent data;
-- TaskManager::TaskPtr taskPtr(task->task());
-+ TaskManager::Task* taskPtr(task->task());
- QList<WId> windows;
- int desktop = -1;
-
-diff -u src/smooth-tasks-fork/applet/SmoothTasks/SmoothToolTip.cpp src/smooth-tasks-fork/applet/SmoothTasksX/SmoothToolTip.cpp
---- src/smooth-tasks-fork/applet/SmoothTasks/SmoothToolTip.cpp 2011-12-24 03:13:55.605361287 +0100
-+++ src/smooth-tasks-fork/applet/SmoothTasksX/SmoothToolTip.cpp 2011-12-24 03:10:24.000000000 +0100
-@@ -474,7 +474,7 @@
- foreach (WindowPreview *preview, m_previews) {
- preview->show();
-
-- TaskManager::TaskPtr task = preview->task()->task();
-+ TaskManager::Task* task = preview->task()->task();
-
- if (task && preview->task()->type() != Task::StartupItem && preview->task()->type() != Task::LauncherItem) {
- winIds.append(task->window());
-diff -u src/smooth-tasks-fork/applet/SmoothTasks/Task.cpp src/smooth-tasks-fork/applet/SmoothTasksX/Task.cpp
---- src/smooth-tasks-fork/applet/SmoothTasks/Task.cpp 2011-12-24 03:13:55.606361275 +0100
-+++ src/smooth-tasks-fork/applet/SmoothTasksX/Task.cpp 2011-12-24 03:07:21.000000000 +0100
-@@ -118,8 +118,8 @@
- }
-
- QString Task::text() const {
-- TaskManager::TaskPtr task;
-- TaskManager::StartupPtr startup;
-+ TaskManager::Task *task;
-+ TaskManager::Startup *startup;
-
- switch (type()) {
- case StartupItem:
-@@ -186,12 +186,23 @@
- return m_task ? m_task->task()->desktop() : -1;
- }
-
--TaskManager::TaskPtr Task::task() const {
-- return m_task ? m_task->task() : TaskManager::TaskPtr();
--}
--
--TaskManager::StartupPtr Task::startup() const {
-- return m_task ? m_task->startup() : TaskManager::StartupPtr();
-+TaskManager::Task* Task::task() const {
-+ if (m_task) {
-+ return m_task->task();
-+ } else {
-+ TaskManager::Task *task;
-+ return task;
-+ }
-+ //return m_task ? m_task->task() : ::TaskManager::Task task;
-+}
-+
-+TaskManager::Startup* Task::startup() const {
-+ if (m_task) {
-+ return m_task->startup();
-+ } else {
-+ TaskManager::Startup* startup;
-+ return startup;
-+ }
- }
-
- int Task::taskCount() const {
-@@ -309,7 +320,7 @@
- void Task::setWindowTask(TaskManager::TaskItem* taskItem) {
- m_type = TaskItem;
- if (m_task && m_task->task()) {
-- disconnect(m_task->task().constData(), 0, this, 0);
-+ disconnect(m_task->task(), 0, this, 0);
- }
-
- m_task = taskItem;
-diff -u src/smooth-tasks-fork/applet/SmoothTasks/Task.h src/smooth-tasks-fork/applet/SmoothTasksX/Task.h
---- src/smooth-tasks-fork/applet/SmoothTasks/Task.h 2011-12-24 03:13:55.607361262 +0100
-+++ src/smooth-tasks-fork/applet/SmoothTasksX/Task.h 2011-12-24 02:34:23.000000000 +0100
-@@ -78,12 +78,12 @@
- QString text() const;
- QString description() const;
- int desktop() const;
-- TaskManager::TaskPtr task() const;
-+ TaskManager::Task *task() const;
- TaskManager::AbstractGroupableItem *abstractItem() { return m_abstractItem; }
- TaskManager::GroupPtr group() const { return m_group; }
-- TaskManager::TaskItem *taskItem() const { return m_task; }
-+ TaskManager::TaskItem *taskItem() const { return m_task; }
- TaskManager::LauncherItem *launcherItem() const { return m_launcher; }
-- TaskManager::StartupPtr startup() const;
-+ TaskManager::Startup *startup() const;
- TaskFlags flags() const { return m_flags; }
- ItemType type() const { return m_type; }
- void addMimeData(QMimeData* mimeData);
-Only in src/smooth-tasks-fork/applet/SmoothTasksX: .Task.h.kate-swp
-diff -u src/smooth-tasks-fork/applet/SmoothTasks/TaskItem.cpp src/smooth-tasks-fork/applet/SmoothTasksX/TaskItem.cpp
---- src/smooth-tasks-fork/applet/SmoothTasks/TaskItem.cpp 2011-12-24 03:13:55.610361223 +0100
-+++ src/smooth-tasks-fork/applet/SmoothTasksX/TaskItem.cpp 2011-12-24 03:09:11.000000000 +0100
-@@ -375,7 +375,7 @@
-
- void TaskItem::publishIconGeometry() {
- QRect iconRect(iconGeometry());
-- TaskManager::TaskPtr task;
-+ TaskManager::Task *task;
- TaskManager::GroupPtr group;
-
- switch (m_task->type()) {
-@@ -465,7 +465,7 @@
- }
-
- void TaskItem::mouseReleaseEvent(QGraphicsSceneMouseEvent *event) {
-- TaskManager::TaskPtr task;
-+ TaskManager::Task* task;
-
- switch (event->button()) {
- case Qt::LeftButton:
-@@ -626,7 +626,7 @@
- }
-
- void TaskItem::activate() {
-- TaskManager::TaskPtr task;
-+ TaskManager::Task* task;
-
- switch (m_task->type()) {
- case Task::TaskItem:
-Common subdirectories: src/smooth-tasks-fork/applet/SmoothTasks/Ui and src/smooth-tasks-fork/applet/SmoothTasksX/Ui
-diff -u src/smooth-tasks-fork/applet/SmoothTasks/WindowPreview.cpp src/smooth-tasks-fork/applet/SmoothTasksX/WindowPreview.cpp
---- src/smooth-tasks-fork/applet/SmoothTasks/WindowPreview.cpp 2011-12-24 03:13:55.619361111 +0100
-+++ src/smooth-tasks-fork/applet/SmoothTasksX/WindowPreview.cpp 2011-12-24 03:12:49.000000000 +0100
-@@ -117,7 +117,7 @@
- if (m_toolTip->previewsAvailable()) {
- // determine preview size:
- WId wid = 0;
-- TaskManager::TaskPtr task = m_task->task();
-+ TaskManager::Task* task = m_task->task();
-
- if (task) {
- wid = task->window();
-@@ -297,7 +297,7 @@
- }
-
- void WindowPreview::highlightTask() {
-- TaskManager::TaskPtr task = m_task->task();
-+ TaskManager::Task* task = m_task->task();
-
- if (task) {
- m_toolTip->highlightTask(task->window());
-@@ -325,7 +325,7 @@
- m_toolTip->hide();
-
- if(m_task->type() != Task::LauncherItem) {
-- TaskManager::TaskPtr task = m_task->task();
-+ TaskManager::Task* task = m_task->task();
- if (task) {
- task->activate();
- }
-@@ -336,7 +336,7 @@
- }
-
- void WindowPreview::activateForDrop() {
-- TaskManager::TaskPtr task = m_task->task();
-+ TaskManager::Task* task = m_task->task();
- if (task) {
- if (task->isMinimized()) {
- task->restore();
-@@ -347,7 +347,7 @@
- }
-
- void WindowPreview::closeTask() {
-- TaskManager::TaskPtr task = m_task->task();
-+ TaskManager::Task* task = m_task->task();
- if (task) {
- task->close();
- }
diff --git a/kde-misc/smooth-tasks/metadata.xml b/kde-misc/smooth-tasks/metadata.xml
deleted file mode 100644
index adeaac2286a5..000000000000
--- a/kde-misc/smooth-tasks/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>kde@gentoo.org</email>
- <name>Gentoo KDE Project</name>
- </maintainer>
- <upstream>
- <remote-id type="bitbucket">flupp/smooth-tasks-fork</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/kde-misc/smooth-tasks/smooth-tasks-0_p20120130.ebuild b/kde-misc/smooth-tasks/smooth-tasks-0_p20120130.ebuild
deleted file mode 100644
index 1908e9c5ab32..000000000000
--- a/kde-misc/smooth-tasks/smooth-tasks-0_p20120130.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-KDE_MINIMAL="4.8"
-KDE_LINGUAS="cs de fr hu pl ru zh_CN"
-inherit kde4-base
-
-DESCRIPTION="Alternate taskbar KDE plasmoid, similar to Windows 7"
-HOMEPAGE="https://bitbucket.org/flupp/smooth-tasks-fork"
-SRC_URI="https://dev.gentoo.org/~johu/distfiles/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="4"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-DEPEND="
- kde-plasma/libtaskmanager:4
-"
-RDEPEND="${DEPEND}
- kde-plasma/plasma-workspace:4
-"
-
-PATCHES=( "${FILESDIR}/${P}-kde48.patch" )
-
-S="${WORKDIR}/${PN}"