summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-09-01 01:21:53 +1000
committerMichael Palimaka <kensington@gentoo.org>2015-09-01 01:22:22 +1000
commite304c8b200a1b64e0547febeafa1686ed0834b39 (patch)
treef5a68b605391756d77ff6ae9d452570b02a90832 /kde-misc
parentnet-misc/clusterssh: fix ebuild source module version and naming thx to Kent ... (diff)
downloadgentoo-e304c8b200a1b64e0547febeafa1686ed0834b39.tar.gz
gentoo-e304c8b200a1b64e0547febeafa1686ed0834b39.tar.bz2
gentoo-e304c8b200a1b64e0547febeafa1686ed0834b39.zip
kde-misc/kde-gtk-config: improve kde-base/kdelibs-4.14.11 compatibility patch
Gentoo-bug: 559108 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/kde-gtk-config/files/kde-gtk-config-2.2.1-kdelibs-4.14.11.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/kde-misc/kde-gtk-config/files/kde-gtk-config-2.2.1-kdelibs-4.14.11.patch b/kde-misc/kde-gtk-config/files/kde-gtk-config-2.2.1-kdelibs-4.14.11.patch
index ca20682104f..86c8b4c3258 100644
--- a/kde-misc/kde-gtk-config/files/kde-gtk-config-2.2.1-kdelibs-4.14.11.patch
+++ b/kde-misc/kde-gtk-config/files/kde-gtk-config-2.2.1-kdelibs-4.14.11.patch
@@ -50,3 +50,30 @@ index 9821cbf..18ee2d5 100644
--
2.4.6
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -47,6 +47,4 @@
+ add_subdirectory(gtkproxies)
+ add_subdirectory(gtk3proxies)
+ add_subdirectory(icons)
+-find_package(Msgfmt REQUIRED)
+-find_package(Gettext REQUIRED)
+ add_subdirectory( po )
+
+--- a/po/CMakeLists.txt
++++ b/po/CMakeLists.txt
+@@ -0,0 +1,14 @@
++# The pofiles macro creates in some versions same name targets
++# which since cmake 2.8 leads to target clashes.
++# Hence force the old policy for all po directories.
++# http://public.kitware.com/Bug/view.php?id=12952
++cmake_policy(SET CMP0002 OLD)
++
++find_package(Gettext REQUIRED)
++if (NOT GETTEXT_MSGMERGE_EXECUTABLE)
++MESSAGE(FATAL_ERROR "Please install msgmerge binary")
++endif (NOT GETTEXT_MSGMERGE_EXECUTABLE)
++if (NOT GETTEXT_MSGFMT_EXECUTABLE)
++MESSAGE(FATAL_ERROR "Please install msgmerge binary")
++endif (NOT GETTEXT_MSGFMT_EXECUTABLE)
++