summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-04 13:19:53 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-04 14:25:46 +0200
commite152ffd98793f16b489bbba958bbdc549f3b64b1 (patch)
treedec57cba5f4c711e2b59aa2cb05f5b665d8e558a /kde-plasma/kinfocenter
parentapp-i18n/ibus-table: new upstream release (diff)
downloadgentoo-e152ffd98793f16b489bbba958bbdc549f3b64b1.tar.gz
gentoo-e152ffd98793f16b489bbba958bbdc549f3b64b1.tar.bz2
gentoo-e152ffd98793f16b489bbba958bbdc549f3b64b1.zip
kde-plasma: Add KDE Plasma 5.13.5
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.13.5.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index 859e22e4a7b6..8cee66e4484d 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -2,3 +2,4 @@ DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26
DIST kinfocenter-5.12.5.tar.xz 1270224 BLAKE2B 5c2b0148f82862d32393804bd98ca99ec71f476d4103f015f159420223bb695b8d237673aa94c12d9be4147b36c52d9cbbd0d8f0e69208f6afcb18363283a50f SHA512 f8178452b2611473733ec707be1683234bcd22bac381d6d8fa47e695653c5d2983dab37dd24dea19024cd4a68e4736bb08a3b197c8a6932a45c927ee7a61638d
DIST kinfocenter-5.12.6.tar.xz 1276012 BLAKE2B 633f47373b7439ae48720c97debedd1e134c07d3a7b9028b0d7aa13e952c8945e2499c9c9d4582d25b275cdff57ceb8727ad0f58e7ffac063efcab66664f0490 SHA512 521d588d73bb32fa2020b8c4faacbdaa86e65fca421829566fb9a21a15750f6d9c912c2d948f8a11ffcd304d51d5f062c79147fc8703c345fd4a1153dc937ff6
DIST kinfocenter-5.13.4.tar.xz 1288580 BLAKE2B 6ee51648c4802a192995f430a2ea2f2653b79acf5d3a8219f08caeddea4a677cba03ab93353e488db0f751d20744f97a9a42a5852d48bfd0d2540c4ffd0c6b9e SHA512 d871a2c4bbd20b2ce2d23887aeccfd999b6df549afb5cc6188d8b719600482623c6b049ce06190458251482be0834f1ab9a02b7c773b06594ea3fc7aaf0df01c
+DIST kinfocenter-5.13.5.tar.xz 1286000 BLAKE2B d8e9278f3c7214e13403970e86ac72f5cad3ed2506752c297860d91f26e986b6bce806a7498b78e4517b8d6c8a0ff31e2d2b6f0117babb93839dc8c923cf6bbd SHA512 a54b3ef5df1855f3002965f70c2e627ddc0b1e69eaa36461da1018b9ffd6e033ca61c4890a358ddc22f6f9e66cab5cdbaa1ff5386dda29fe87248f8af5567e50
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.13.5.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.13.5.ebuild
new file mode 100644
index 000000000000..7a0e2a4a61bc
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.13.5.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="A utility that provides information about a computer system"
+HOMEPAGE="https://www.kde.org/applications/system/kinfocenter/"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gles2 ieee1394 +opengl +pci wayland"
+
+REQUIRED_USE="wayland? ( || ( gles2 opengl ) )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ x11-libs/libX11
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ $(add_qt_dep qtgui 'gles2=')
+ media-libs/mesa[gles2?]
+ !gles2? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ wayland? (
+ $(add_frameworks_dep kwayland)
+ media-libs/mesa[egl]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep plasma)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-apps/kcontrol:4
+ !kde-misc/about-distro
+ !kde-plasma/kinfocenter:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package ieee1394 RAW1394)
+ $(cmake-utils_use_find_package pci PCIUTILS)
+ $(cmake-utils_use_find_package wayland EGL)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ if has_version "dev-qt/qtgui[gles2]"; then
+ mycmakeargs+=( $(cmake-utils_use_find_package gles2 OpenGLES) )
+ else
+ mycmakeargs+=( $(cmake-utils_use_find_package opengl OpenGL) )
+ fi
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if ! has_version "net-fs/nfs-utils"; then
+ elog "Installing net-fs/nfs-utils will enable the NFS information module."
+ fi
+ if ! has_version "net-fs/samba"; then
+ elog "Installing net-fs/samba will enable the Samba status information module."
+ fi
+}