summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2016-09-14 00:45:58 +0200
committerHanno <hanno@gentoo.org>2016-09-14 00:45:58 +0200
commit5f034c30288a6df8ba711d4b1909dd84b5336755 (patch)
tree9031a31add37f7853c1f87de8f9386bffb30e68d /lxde-base
parentlxde-base/lxtask: Remove old versions and patches (diff)
downloadgentoo-5f034c30288a6df8ba711d4b1909dd84b5336755.tar.gz
gentoo-5f034c30288a6df8ba711d4b1909dd84b5336755.tar.bz2
gentoo-5f034c30288a6df8ba711d4b1909dd84b5336755.zip
lxde-base/lxtask: version bump to 0.1.7
Add patch to fix compilation with -fno-common. Package-Manager: portage-2.3.0
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxtask/Manifest1
-rw-r--r--lxde-base/lxtask/files/lxtask-0.1.7-fix-no-common.patch73
-rw-r--r--lxde-base/lxtask/lxtask-0.1.7.ebuild30
3 files changed, 104 insertions, 0 deletions
diff --git a/lxde-base/lxtask/Manifest b/lxde-base/lxtask/Manifest
index a5bd7589f51e..3fe834577ed5 100644
--- a/lxde-base/lxtask/Manifest
+++ b/lxde-base/lxtask/Manifest
@@ -1 +1,2 @@
DIST lxtask-0.1.6.tar.xz 135480 SHA256 f78d6a9953dfbedfa00f69b3e908e326398cd40f541bc8a6a08f5f0a06894345 SHA512 e3c139cea8260b1f1af9c3fb524beefedaac440eef6bc1efdeac73ecdbe4d44dcd277160e64306b681ddbd9eb0f5bc5077957a492f7a06ffcd0c844aad88f827 WHIRLPOOL 9aa64ea0b6d6bc108cfa18f5b3dd7c2bb63ac48287a00a8825e715ce2fb90e6058e06187456397759b71fc2e0969ef4863b9b005e2d39659abe1c674c48dcd3e
+DIST lxtask-0.1.7.tar.xz 137152 SHA256 f0b65a6b145856000383badafd14ab7944fd98e95c9efdc03474a5a7ff8630fe SHA512 eb5c6af2d0953d09d62b53efda1f88140cc6d5734ef98effd9a72b896e397d0c29ff4263b93c12fd23fcb0ec129b31eb769b0a8c769ae92ed9fc1d2f2689a4ef WHIRLPOOL fdb4cbad73aa232dcf918f3f245f7a3185273f18b39161ab27629fbf46aafa097d8574f454d3b1419269fe1a2119c8b1605de18460794538a7ab8ad4645c8cb3
diff --git a/lxde-base/lxtask/files/lxtask-0.1.7-fix-no-common.patch b/lxde-base/lxtask/files/lxtask-0.1.7-fix-no-common.patch
new file mode 100644
index 000000000000..d986741b2111
--- /dev/null
+++ b/lxde-base/lxtask/files/lxtask-0.1.7-fix-no-common.patch
@@ -0,0 +1,73 @@
+diff -Naur a/src/interface.c b/src/interface.c
+--- a/src/interface.c 2016-02-21 01:06:17.000000000 +0100
++++ b/src/interface.c 2016-09-13 19:37:28.038350050 +0200
+@@ -26,6 +26,18 @@
+ #include <glib/gi18n.h>
+ #include "interface.h"
+
++GtkTreeStore *list_store;
++GtkTreeSelection *selection;
++GtkWidget *treeview;
++GtkWidget *mainmenu;
++GtkWidget *taskpopup;
++GtkWidget *cpu_usage_progress_bar;
++GtkWidget *mem_usage_progress_bar;
++GtkWidget *cpu_usage_progress_bar_box;
++GtkWidget *mem_usage_progress_bar_box;
++
++GtkTreeViewColumn *column;
++
+ #define GLADE_HOOKUP_OBJECT(component,widget,name) \
+ g_object_set_data_full (G_OBJECT (component), name, \
+ gtk_widget_ref (widget), (GDestroyNotify) gtk_widget_unref)
+diff -Naur a/src/interface.h b/src/interface.h
+--- a/src/interface.h 2014-09-16 14:27:52.000000000 +0200
++++ b/src/interface.h 2016-09-13 19:32:22.816372893 +0200
+@@ -38,16 +38,15 @@
+ #include "callbacks.h"
+ #include "types.h"
+
+-GtkTreeStore *list_store;
+-GtkTreeSelection *selection;
+-GtkWidget *treeview;
+-GtkWidget *mainmenu;
+-GtkWidget *taskpopup;
+-GtkWidget *priopopup;
+-GtkWidget *cpu_usage_progress_bar;
+-GtkWidget *mem_usage_progress_bar;
+-GtkWidget *cpu_usage_progress_bar_box;
+-GtkWidget *mem_usage_progress_bar_box;
++extern GtkTreeStore *list_store;
++extern GtkTreeSelection *selection;
++extern GtkWidget *treeview;
++extern GtkWidget *mainmenu;
++extern GtkWidget *taskpopup;
++extern GtkWidget *cpu_usage_progress_bar;
++extern GtkWidget *mem_usage_progress_bar;
++extern GtkWidget *cpu_usage_progress_bar_box;
++extern GtkWidget *mem_usage_progress_bar_box;
+
+ enum {
+ COLUMN_NAME = 0,
+@@ -61,7 +60,7 @@
+ COLUMN_PPID
+ };
+
+-GtkTreeViewColumn *column;
++extern GtkTreeViewColumn *column;
+
+ void change_list_store_view(void);
+ void create_list_store(void);
+diff -Naur a/src/types.h b/src/types.h
+--- a/src/types.h 2014-09-16 14:27:52.000000000 +0200
++++ b/src/types.h 2016-09-13 19:25:51.014402217 +0200
+@@ -77,9 +77,6 @@
+ extern gint win_width;
+ extern gint win_height;
+
+-const gchar *custom_signal_0;
+-const gchar *custom_signal_1;
+-
+ extern int page_size;
+
+ #endif
diff --git a/lxde-base/lxtask/lxtask-0.1.7.ebuild b/lxde-base/lxtask/lxtask-0.1.7.ebuild
new file mode 100644
index 000000000000..a91695e33aac
--- /dev/null
+++ b/lxde-base/lxtask/lxtask-0.1.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+DESCRIPTION="LXDE Task manager"
+HOMEPAGE="http://lxde.sf.net/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86 ~arm-linux ~x86-linux"
+SLOT="0"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0"
+
+# Upstream report:
+# https://sourceforge.net/p/lxde/patches/535/
+PATCHES=( "${FILESDIR}/lxtask-0.1.7-fix-no-common.patch" )
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README
+}