summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /lxqt-base/lxqt-admin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'lxqt-base/lxqt-admin')
-rw-r--r--lxqt-base/lxqt-admin/Manifest2
-rw-r--r--lxqt-base/lxqt-admin/lxqt-admin-0.8.0.ebuild41
-rw-r--r--lxqt-base/lxqt-admin/lxqt-admin-0.9.0.ebuild35
-rw-r--r--lxqt-base/lxqt-admin/metadata.xml9
4 files changed, 87 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-admin/Manifest b/lxqt-base/lxqt-admin/Manifest
new file mode 100644
index 000000000000..5e2184daae39
--- /dev/null
+++ b/lxqt-base/lxqt-admin/Manifest
@@ -0,0 +1,2 @@
+DIST lxqt-admin-0.8.0.tar.xz 19216 SHA256 f2c17f9a9f3628db53b6cfeee64de8500b35b13c37bc4bc8d12302f856362a8e SHA512 aace62c3c0e69e098afd3ddf2af1ec98e185018c4ae9a15718484032857bc6f4fa792dee42c2c4079420fbac91bedaaf8dc9fa89730d0c03029bf0b767be5461 WHIRLPOOL cf72acb4a649cc990b1fba8ad9ea421db007ee3f97ecb69876f5006106d9a7c626d218a6fc763f483ada6122adb9d3ee978613afad69c2f8e39aecd83b204326
+DIST lxqt-admin-0.9.0.tar.xz 24072 SHA256 3845fb710e4615b0c1e377cb4662ab212fe897f4cb50178330d218348dad4345 SHA512 f5c74388982adfa2b95e873389d74f4ba76e6329ea5af21283f2770fae05fce8009c0851f5f8313e2173dd9ab20d634e07142e3df852b34c16f3a1e296ee637f WHIRLPOOL eefac6ef825e38bc2e50568fc1fcc004df399c2b5275235474d6373aca7607541bb553db230ff9ae182131c9b47f5a0185be46e2223d5111db7a0fb68b6146f3
diff --git a/lxqt-base/lxqt-admin/lxqt-admin-0.8.0.ebuild b/lxqt-base/lxqt-admin/lxqt-admin-0.8.0.ebuild
new file mode 100644
index 000000000000..5979a84acb9f
--- /dev/null
+++ b/lxqt-base/lxqt-admin/lxqt-admin-0.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt system administration tool"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+DEPEND="dev-libs/glib:2
+ dev-libs/liboobs
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ ~lxqt-base/liblxqt-${PV}
+ >=dev-libs/libqtxdg-1.0.0
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/lxqt-base/lxqt-admin/lxqt-admin-0.9.0.ebuild b/lxqt-base/lxqt-admin/lxqt-admin-0.9.0.ebuild
new file mode 100644
index 000000000000..80fcf7051031
--- /dev/null
+++ b/lxqt-base/lxqt-admin/lxqt-admin-0.9.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt system administration tool"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+DEPEND="dev-libs/glib:2
+ dev-libs/liboobs
+ >=dev-libs/libqtxdg-1.0.0
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ ~lxqt-base/liblxqt-${PV}
+ kde-frameworks/kwindowsystem:5
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}"
diff --git a/lxqt-base/lxqt-admin/metadata.xml b/lxqt-base/lxqt-admin/metadata.xml
new file mode 100644
index 000000000000..d89dead0ed86
--- /dev/null
+++ b/lxqt-base/lxqt-admin/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>lxqt</herd>
+ <maintainer>
+ <email>jauhien@gentoo.org</email>
+ <name>Jauhien Piatlicki</name>
+ </maintainer>
+</pkgmetadata>