summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-09-27 01:21:08 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-09-27 01:21:08 +0200
commit5e85967b69d1d4c5c518771ba1dfd827259d4790 (patch)
tree6359c94be7e312f38e4fe563b9b432c11b2d723b /lxqt-base/lxqt-policykit
parentlxqt-base/lxqt-openssh-askpass: Version bump to 0.11.0 (diff)
downloadgentoo-5e85967b69d1d4c5c518771ba1dfd827259d4790.tar.gz
gentoo-5e85967b69d1d4c5c518771ba1dfd827259d4790.tar.bz2
gentoo-5e85967b69d1d4c5c518771ba1dfd827259d4790.zip
lxqt-base/lxqt-policykit: Version bump to 0.11.0
Package-Manager: portage-2.3.1
Diffstat (limited to 'lxqt-base/lxqt-policykit')
-rw-r--r--lxqt-base/lxqt-policykit/Manifest1
-rw-r--r--lxqt-base/lxqt-policykit/lxqt-policykit-0.11.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-policykit/Manifest b/lxqt-base/lxqt-policykit/Manifest
index 203a2d6f6124..2265fb9f4046 100644
--- a/lxqt-base/lxqt-policykit/Manifest
+++ b/lxqt-base/lxqt-policykit/Manifest
@@ -1 +1,2 @@
DIST lxqt-policykit-0.10.0.tar.xz 14500 SHA256 c8a1843d30697030ecdcf6d328351f954c0349633106d389e2d2e678176c28ce SHA512 f7c7c623fc6bde8555982cee56757166c3ef49a54af2d757b47d4e0a68025b8bd9fba623010d0bd6c67f3b92d3e7d245f066caaed98bbee9eda4b0f76d9f5a48 WHIRLPOOL c586311adcb06ae535390c32395e3819f64e516aca779f3125d6ace5626988c8874d51a53ae869ce927a6f485c865a6d2f3ea5eb3f044f3cf81241a06951f241
+DIST lxqt-policykit-0.11.0.tar.xz 31336 SHA256 d67620385b5ebe3784edc08be7b627fab8748d7cdd870f5cb2405a06f72469fc SHA512 f4c8a154e30df18118444d8caf09bd242aafb17309bba77f1153a6b3db74291d35fe10ffba716293203095bcaa70195414e6b10773f8fe3b48829ab72820e5ae WHIRLPOOL db0b767cdac2f5f1dcec4a5252593d73772d089f449414eba8f7b6e079b96bd25834e4a1a32cb82518b8fca6aa83559b014ce8907f5a84cee0a2545124085623
diff --git a/lxqt-base/lxqt-policykit/lxqt-policykit-0.11.0.ebuild b/lxqt-base/lxqt-policykit/lxqt-policykit-0.11.0.ebuild
new file mode 100644
index 000000000000..54ca16ae3f11
--- /dev/null
+++ b/lxqt-base/lxqt-policykit/lxqt-policykit-0.11.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt PolKit authentication agent"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ ~lxqt-base/liblxqt-${PV}
+ >=dev-libs/libqtxdg-1.0.0
+ sys-auth/polkit-qt[qt5(-)]"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=( -DPULL_TRANSLATIONS=OFF )
+ cmake-utils_src_configure
+}
+
+src_install(){
+ cmake-utils_src_install
+ doman man/*.1
+}