summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2021-04-16 19:04:56 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-04-18 08:00:33 +0300
commit3af546bccff93e5d796999bc965a0d5676da55f7 (patch)
tree3aa7f817c29b9f612e0f112f348495e5ec737aa9 /lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.17.0.ebuild
parentlxqt-base/libsysstat: add version 0.4.5 (diff)
downloadgentoo-3af546bccff93e5d796999bc965a0d5676da55f7.tar.gz
gentoo-3af546bccff93e5d796999bc965a0d5676da55f7.tar.bz2
gentoo-3af546bccff93e5d796999bc965a0d5676da55f7.zip
lxqt-base/lxqt-qtplugin: add version 0.17.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.17.0.ebuild')
-rw-r--r--lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.17.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.17.0.ebuild b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.17.0.ebuild
new file mode 100644
index 000000000000..bde9f9e6a462
--- /dev/null
+++ b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.17.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt system integration plugin for Qt"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.9.0
+"
+DEPEND="
+ dev-libs/libdbusmenu-qt:=[qt5(+)]
+ >=dev-libs/libqtxdg-3.7.0
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ =x11-libs/libfm-qt-$(ver_cut 1-2)*
+"
+RDEPEND="${DEPEND}"