summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-18 22:27:54 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-18 22:30:46 -0400
commitc09c51ffae1795848b25582db6f077fa9b4bc986 (patch)
tree3c0fe1f5ce6a613db111a2de05d23c3c4bca809a /mail-client/balsa/balsa-2.6.2.ebuild
parentx11-libs/gtk+: Version bump to 3.24.28 (diff)
downloadgentoo-c09c51ffae1795848b25582db6f077fa9b4bc986.tar.gz
gentoo-c09c51ffae1795848b25582db6f077fa9b4bc986.tar.bz2
gentoo-c09c51ffae1795848b25582db6f077fa9b4bc986.zip
mail-client/balsa: Version bump to 2.6.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'mail-client/balsa/balsa-2.6.2.ebuild')
-rw-r--r--mail-client/balsa/balsa-2.6.2.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/mail-client/balsa/balsa-2.6.2.ebuild b/mail-client/balsa/balsa-2.6.2.ebuild
new file mode 100644
index 000000000000..1dedf117e67f
--- /dev/null
+++ b/mail-client/balsa/balsa-2.6.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2
+
+DESCRIPTION="Email client for GNOME"
+HOMEPAGE="http://pawsa.fedorapeople.org/balsa/"
+SRC_URI="http://pawsa.fedorapeople.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+IUSE="gnome +gnome-keyring kerberos ldap libressl rubrica sqlite webkit xface"
+
+# TODO: internal spell checking via enchant-2 instead of gtkspell/gspell?
+DEPEND="
+ >=dev-libs/glib-2.48.0:2
+ >=x11-libs/gtk+-3.24.0:3
+ >=dev-libs/gmime-3.2.6:3.0
+ >=net-libs/gnutls-3.0:=
+ dev-libs/fribidi
+ dev-libs/libical:=
+ webkit? (
+ >=net-libs/webkit-gtk-2.28.0:4
+ app-text/html2text
+ )
+ >=app-crypt/gpgme-1.8.0:=
+ sqlite? ( >=dev-db/sqlite-2.8:= )
+ ldap? ( net-nds/openldap )
+ rubrica? ( dev-libs/libxml2:2 )
+ kerberos? ( app-crypt/mit-krb5 )
+ xface? ( >=media-libs/compface-1.5.1:= )
+ gnome? ( x11-libs/gtksourceview:4 )
+ media-libs/libcanberra:=[gtk3]
+ gnome-keyring? ( app-crypt/libsecret )
+ >=app-text/gspell-1.6:0=
+
+ net-mail/mailbase
+ x11-themes/hicolor-icon-theme
+ x11-themes/adwaita-icon-theme
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/gtk-update-icon-cache
+ dev-util/intltool
+ dev-util/itstool
+ virtual/pkgconfig
+ sys-devel/gettext
+ dev-libs/libxml2:2
+"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README TODO docs/*"
+
+src_configure() {
+ local myconf=(
+ $(use_with gnome)
+ $(use_enable sqlite autocrypt)
+ --with-canberra
+ $(use_with xface compface)
+ $(use_with kerberos gss)
+ $(usex webkit --with-html-widget=webkit2 --with-html-widget=no)
+ $(use_with gnome gtksourceview)
+ --with-spell-checker=gspell
+ $(use_with ldap)
+ $(use_with rubrica)
+ --without-osmo
+ $(use_with sqlite)
+ $(use_with gnome-keyring libsecret)
+ --without-gcr # experimental
+ )
+ gnome2_src_configure "${myconf[@]}"
+}