summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-07-16 12:26:43 +0300
committerMart Raudsepp <leio@gentoo.org>2018-07-16 12:36:44 +0300
commitba665337f736c074f036e2405243cd9156ab1254 (patch)
treefa396174d098088c414131d322f385666f7aa466 /mail-client/geary
parentdev-python/pytest: Bump to 3.6.3 (diff)
downloadgentoo-ba665337f736c074f036e2405243cd9156ab1254.tar.gz
gentoo-ba665337f736c074f036e2405243cd9156ab1254.tar.bz2
gentoo-ba665337f736c074f036e2405243cd9156ab1254.zip
mail-client/geary: bump to 0.12.3
* Review deps and fix things up. * Fix licenses. * Remove questionable IUSE=nls, empty string LINGUAS should do what -nls did (albeit not sure about help manual translations) * Remove WITH_UNITY option, unfortunately automagic now, but not worrying about it as I don't think we have the libraries available anywhere. Closes: https://bugs.gentoo.org/652278 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'mail-client/geary')
-rw-r--r--mail-client/geary/Manifest1
-rw-r--r--mail-client/geary/geary-0.12.3.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/mail-client/geary/Manifest b/mail-client/geary/Manifest
index aed6522e175..e56346295e1 100644
--- a/mail-client/geary/Manifest
+++ b/mail-client/geary/Manifest
@@ -1 +1,2 @@
DIST geary-0.12.0.tar.xz 1064064 BLAKE2B c4021a784f7704494dfcf9013e4b108d9f921d553e47f55878de30c9878852ac2c023e679c33660cfe2fb190fac56dea4976eccb15bc1a512914442564a24e48 SHA512 caaf49065181f84234bbdb3dc20808f68cb7339e7ef3e992bd83789d3a474b5f59a210d54db2b4fe5f44539a2d52ad7f328087580748c74a513cca7be31c2e52
+DIST geary-0.12.3.tar.xz 1069444 BLAKE2B 73f4382cd97813fcb3921daeab4338f4797bef2b5dcb1f7df1afeb75be48877109dcb15317f9bbe595326ee38f9ea3359a7d062c39ea3d83e1d36c34b680e707 SHA512 0e22b7ad8b79d17e55f6ab75a13883db04b21b1be9c2b06b08009e48fe433de323e23414ae8e47543bcb7785d6aa90bea582a2e20eaed1ce7bcb02687a69b9b6
diff --git a/mail-client/geary/geary-0.12.3.ebuild b/mail-client/geary/geary-0.12.3.ebuild
new file mode 100644
index 00000000000..6ed3152f6cc
--- /dev/null
+++ b/mail-client/geary/geary-0.12.3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+# Keep cmake-utils at the end
+inherit gnome2 vala cmake-utils
+
+DESCRIPTION="A lightweight, easy-to-use, feature-rich email client"
+HOMEPAGE="https://wiki.gnome.org/Apps/Geary"
+
+LICENSE="LGPL-2.1+ BSD-2 CC-BY-3.0 CC-BY-SA-3.0" # code is LGPL-2.1+, BSD-2 for bundled snowball-stemmer, CC licenses for some icons
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.42:2
+ >=x11-libs/gtk+-3.14.0:3[introspection]
+ >=net-libs/webkit-gtk-2.10.0:4=[introspection]
+ app-text/iso-codes
+ >=dev-db/sqlite-3.12:3
+
+ >=net-libs/libsoup-2.48:2.4[introspection]
+ >=dev-libs/libgee-0.8.5:0.8=[introspection]
+ >=x11-libs/libnotify-0.7.5[introspection]
+ >=media-libs/libcanberra-0.28
+ >=dev-libs/gmime-2.6.17:2.6
+ >=app-crypt/libsecret-0.11[introspection,vala]
+ >=dev-libs/libxml2-2.7.8:2
+ >=app-crypt/gcr-3.10.1:0=[gtk,introspection,vala]
+ >=app-text/enchant-1.6:0
+"
+RDEPEND="${DEPEND}
+ gnome-base/dconf
+ gnome-base/gsettings-desktop-schemas
+" # org.gnome.desktop.interface clock-format global setting usage
+# gnome-doc-utils for xml2po for TRANSLATE_HELP option
+DEPEND="${DEPEND}
+ sys-devel/gettext
+ app-text/gnome-doc-utils
+ dev-util/desktop-file-utils
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751557
+ sed -i -e 's/vapigen --library/${VAPIGEN} --library/' src/CMakeLists.txt || die
+
+ local i
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(cd po ; echo *.po) ; do
+ if ! has ${i%.po} ${LINGUAS} ; then
+ sed -i -e "/^${i%.po}$/d" po/LINGUAS || die
+ fi
+ done
+ fi
+
+ cmake-utils_src_prepare
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DICON_UPDATE=OFF
+ -DDESKTOP_UPDATE=OFF
+ -DDESKTOP_VALIDATE=OFF
+ -DTRANSLATE_HELP=ON
+
+ -DNO_FATAL_WARNINGS=ON
+ -DGSETTINGS_COMPILE=OFF
+ -DVALA_EXECUTABLE="${VALAC}"
+ -DVAPIGEN="${VAPIGEN}"
+ )
+
+ cmake-utils_src_configure
+}