summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2019-04-02 19:08:53 -0400
committerAaron Bauman <bman@gentoo.org>2019-04-04 17:17:25 -0400
commite0f86d4216ce95327de3768a1e066c3ff6195faa (patch)
tree22e67a1ba891d24dcc890c4f37a42edb726762ee /mail-client/roundcube
parentapp-antivirus/clamav: remove unused patches (diff)
downloadgentoo-e0f86d4216ce95327de3768a1e066c3ff6195faa.tar.gz
gentoo-e0f86d4216ce95327de3768a1e066c3ff6195faa.tar.bz2
gentoo-e0f86d4216ce95327de3768a1e066c3ff6195faa.zip
mail-client/roundcube: 1.3.9 version bump
Closes: https://bugs.gentoo.org/682374 Closes: 11573 Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com> Package-Manager: Portage-2.3.62, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11573 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'mail-client/roundcube')
-rw-r--r--mail-client/roundcube/Manifest1
-rw-r--r--mail-client/roundcube/roundcube-1.3.9.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index 3107020d7e00..310d29ed5c40 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -1 +1,2 @@
DIST roundcubemail-1.3.8-complete.tar.gz 5534385 BLAKE2B 2f0cb528d0901d267c74d57baa18d1f057fdd2eb0f872f3cef1053847861998f8c6551fc17506ae365086ed1f86c3ee9e73a96adb2e43c6c32025e7afaf63710 SHA512 34dc9205cd93be6d6551086f4d22654dad7213b4b09000dc4def08357acdc634744ce1f560144a3d3b46e936258e90482e77fc4c691a55c205bcfdfe3745441e
+DIST roundcubemail-1.3.9-complete.tar.gz 5521697 BLAKE2B 4689bb43ff02b99a9b2b06d6370a5dce0ec4eca4e4da2a74e33e77ec74ec14bf22b6bab415c8b5fde9bd76bfaed87f183a8979edb353da3ed947f9bfdb0ecb15 SHA512 42ae9b772272b3e82476beeeb0fc5a909fb07ed0bfbdb655627b1e31da1c292f67f5a305452de31b2d60fe5905bcacabd6874dea394a9b0fd66b7921d73500ac
diff --git a/mail-client/roundcube/roundcube-1.3.9.ebuild b/mail-client/roundcube/roundcube-1.3.9.ebuild
new file mode 100644
index 000000000000..05e90ad0304f
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.3.9.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="https://roundcube.net"
+SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${PV}/${MY_P}-complete.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="change-password enigma ldap managesieve mysql postgres sqlite ssl spell"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+# :TODO: Support "endriod/qrcode: ~1.6.5" dep (ebuild needed)
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-5.4.0[filter,gd,iconv,json,ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml]
+ >=dev-php/PEAR-Auth_SASL-1.1.0
+ >=dev-php/PEAR-Mail_Mime-1.10.0
+ >=dev-php/PEAR-Mail_mimeDecode-1.5.5
+ >=dev-php/PEAR-Net_IDNA2-0.2.0
+ >=dev-php/PEAR-Net_SMTP-1.7.1
+ virtual/httpd-php
+ change-password? (
+ >=dev-php/PEAR-Net_Socket-1.2.1
+ dev-lang/php[sockets]
+ )
+ enigma? (
+ >=dev-php/PEAR-Crypt_GPG-1.6.0
+ app-crypt/gnupg
+ )
+ ldap? (
+ >=dev-php/PEAR-Net_LDAP2-2.2.0
+ dev-php/PEAR-Net_LDAP3
+ )
+ managesieve? ( >=dev-php/PEAR-Net_Sieve-1.4.0 )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ spell? ( dev-lang/php[curl,spell] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ # Redundant. (Bug #644896)
+ rm -r vendor/pear || die
+ # Remove references to PEAR. (Bug #650910)
+ cp "${FILESDIR}"/roundcube-1.3.7-pear-removed-installed.json \
+ vendor/composer/installed.json \
+ || die
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG INSTALL README.md UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE.txt"
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "You can review the post-upgrade instructions at:"
+ elog "${EROOT%/}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
+ fi
+}