summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2016-10-30 14:07:33 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2016-10-30 14:07:33 -0400
commit0c2c01336c3216405377f628e88aa8f995f69c55 (patch)
treeac8aaf3899ea4eb39bb6c39a416d1337b4f7d2f0 /mail-client
parentdev-util/cmake: Drop qt4 (diff)
downloadgentoo-0c2c01336c3216405377f628e88aa8f995f69c55.tar.gz
gentoo-0c2c01336c3216405377f628e88aa8f995f69c55.tar.bz2
gentoo-0c2c01336c3216405377f628e88aa8f995f69c55.zip
mail-client/roundcube: Version Bump to 1.2.2
Version bump fixes bug 596100. Thanks Philippe Chaintreuil and Mattias Merilai. Bug: 596100 Package-Manager: portage-2.2.28
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/roundcube/Manifest1
-rw-r--r--mail-client/roundcube/roundcube-1.2.2.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index f99a4d05a1e3..d3dd92e0a2c3 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -1,2 +1,3 @@
DIST roundcubemail-1.2.0.tar.gz 3453543 SHA256 e3b89c2772c2c5990da9bca640bc342f486edf356016cf717e6a1083c822b523 SHA512 3d97e816560830437902ede352e8be81cd93050975934b9dfc86ccf745234119bdf63d5f882fa0d1cc445575c1ea05906a87ae81befdb0bbb38002433e4de199 WHIRLPOOL f9b14ffb2520cd7eda798eb96ec8547af9f5b8d288605d5d777d126cddb3f531f53887ae9bd9b16be7bf194e87165ff48722885328c6dab0d1c1a0ee589817c4
DIST roundcubemail-1.2.1.tar.gz 3559023 SHA256 05c0b17c8951db1d220f2f2186e6981545789da0d084a543e28a7d2511db8302 SHA512 7044e4308fff85a23826e4f4652df7e825d713b977696c0d29d563f419cc4e060ef202f824463823c3f348c7e9f4ce8c58d073c960b371c0b9ca3bd77c5453ca WHIRLPOOL 79a47d9bd65578c0177ffa9438d8a9b305e2d725536209955b04fbfc42a31ef3060d351b638dba72ede3fd8b1ef42a9af34493f80ff393a91b8ab31634bf318a
+DIST roundcubemail-1.2.2.tar.gz 3562148 SHA256 6c647ed28ea0ae1b730a1784018b63884e65ed6036208e9c3a6ee62123fe856d SHA512 f5482ad424ecdfa275015c51162c465eadb3888f929a86fcd4ca52a6f880ea48c748cc3ecbbe9dd4f5a4fdc823599a93e965855e362958ff46e829e145c7d04b WHIRLPOOL 74c760bcd8f6dc9b1d60ffea84ad66c74a66ef7a5c3164b51ae329ab3d502731799a6dedd069ea3a76a26492213829fd58d43c4f7e38cd843d4ecb35c04c7cfd
diff --git a/mail-client/roundcube/roundcube-1.2.2.ebuild b/mail-client/roundcube/roundcube-1.2.2.ebuild
new file mode 100644
index 000000000000..2976d26befc5
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.2.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_P=${MY_PN}-${PV/_/-}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="http://roundcube.net"
+SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${PV/_/-}/${MY_P}.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~x86"
+
+IUSE="enigma ldap managesieve mysql postgres sqlite ssl spell"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-5.3.7[crypt,filter,gd,iconv,json,ldap?,pdo,postgres?,session,sockets,sqlite?,ssl?,unicode,xml]
+ >=dev-php/PEAR-Auth_SASL-1.0.6
+ >=dev-php/PEAR-Mail_Mime-1.8.9
+ >=dev-php/PEAR-Mail_mimeDecode-1.5.5
+ >=dev-php/PEAR-Net_IDNA2-0.1.1
+ >=dev-php/PEAR-Net_SMTP-1.6.2
+ virtual/httpd-php
+ enigma? ( >=dev-php/PEAR-Crypt_GPG-1.4.0 app-crypt/gnupg )
+ ldap? ( >=dev-php/PEAR-Net_LDAP2-2.0.12 dev-php/PEAR-Net_LDAP3 )
+ managesieve? ( >=dev-php/PEAR-Net_Sieve-1.3.2 )
+ mysql? ( || ( dev-lang/php[mysql] dev-lang/php[mysqli] ) )
+ spell? ( dev-lang/php[curl,spell] )
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README.md UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE.txt"
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ ewarn
+ ewarn "When upgrading from <= 0.9, note that the old configuration files"
+ ewarn "named main.inc.php and db.inc.php are deprecated and should be"
+ ewarn "replaced with one single config.inc.php file."
+ ewarn
+ ewarn "Run the ./bin/update.sh script to convert those"
+ ewarn "or manually merge the files."
+ ewarn
+ ewarn "The new config.inc.php should only contain options that"
+ ewarn "differ from the ones listed in defaults.inc.php."
+ ewarn
+}