summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2017-12-13 08:49:11 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2017-12-13 08:50:04 -0700
commit68bd2d23c82a811bf9d1161bfd8690a2b532cad7 (patch)
tree3de4a1bb8cdcfd6495dbff026d4ab5be5f35548c /mail-client
parentdev-python/pyblake2: 1.1.0 stable on amd64, bug 640898 (diff)
downloadgentoo-68bd2d23c82a811bf9d1161bfd8690a2b532cad7.tar.gz
gentoo-68bd2d23c82a811bf9d1161bfd8690a2b532cad7.tar.bz2
gentoo-68bd2d23c82a811bf9d1161bfd8690a2b532cad7.zip
mail-client/neomutt: Switch build system
Upstream changed the build system from autotools to autosetup [1]. The new build system requires Tcl at configure time and this change adds this dependency. The configuration option syntax for `--with` flags without arguments has changed to `--enable` flags. This change updates the relevant flags. [1] https://msteveb.github.io/autosetup/ Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/neomutt/neomutt-9999.ebuild37
1 files changed, 14 insertions, 23 deletions
diff --git a/mail-client/neomutt/neomutt-9999.ebuild b/mail-client/neomutt/neomutt-9999.ebuild
index 406bc5c0cc73..8496d18ad8c9 100644
--- a/mail-client/neomutt/neomutt-9999.ebuild
+++ b/mail-client/neomutt/neomutt-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit autotools eutils flag-o-matic
+inherit eutils flag-o-matic
if [[ ${PV} =~ 9999$ ]]; then
inherit git-r3
@@ -47,6 +47,7 @@ CDEPEND="
)
"
DEPEND="${CDEPEND}
+ dev-lang/tcl
net-mail/mailbase
doc? (
dev-libs/libxml2
@@ -60,11 +61,6 @@ RDEPEND="${CDEPEND}
S="${WORKDIR}/${PN}-${P}"
-src_prepare() {
- eapply_user
- eautoreconf
-}
-
src_configure() {
local myconf=(
"$(use_enable doc)"
@@ -76,26 +72,21 @@ src_configure() {
"$(use_enable pgp_classic pgp)"
"$(use_enable smime)"
"$(use_enable smime_classic smime)"
- "$(use_with berkdb bdb)"
- "$(use_with gdbm)"
- "$(use_with idn)"
- "$(use_with kerberos gss)"
- "$(use_with kyotocabinet)"
- "$(use_with lmdb)"
- "$(use_with qdbm)"
- "$(use_with sasl)"
- "$(use_with tokyocabinet)"
- "--with-$(usex slang slang curses)"
+ "$(use_enable berkdb bdb)"
+ "$(use_enable gdbm)"
+ "$(use_enable idn)"
+ "$(use_enable kerberos gss)"
+ "$(use_enable kyotocabinet)"
+ "$(use_enable lmdb)"
+ "$(use_enable qdbm)"
+ "$(use_enable sasl)"
+ "$(use_enable tokyocabinet)"
+ "--with-ui=$(usex slang slang ncurses)"
"--sysconfdir=${EPREFIX}/etc/${PN}"
- "--with-docdir=${EPREFIX}/usr/share/doc/${PF}"
+ "$(use_enable ssl)"
+ "$(use_enable gnutls)"
)
- if use gnutls; then
- myconf+=( "--with-gnutls" )
- elif use ssl; then
- myconf+=( "--with-ssl" )
- fi
-
econf "${myconf[@]}"
}