summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-18 19:19:57 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-18 19:52:19 +0100
commita268409347cf355057da6a0ca047e9a21a5a7f89 (patch)
tree85ce4ec51f93e99eb5bfe09a6a00c5665fb5ccd7 /mail-filter/tmda
parentmedia-gfx/xsane: Don't try to build unavailable linguas, bug #609672 by Chris... (diff)
downloadgentoo-a268409347cf355057da6a0ca047e9a21a5a7f89.tar.gz
gentoo-a268409347cf355057da6a0ca047e9a21a5a7f89.tar.bz2
gentoo-a268409347cf355057da6a0ca047e9a21a5a7f89.zip
mail-filter/tmda: python-single-r1, EAPI=6
Diffstat (limited to 'mail-filter/tmda')
-rw-r--r--mail-filter/tmda/files/tmda-1.0-non-interactive-tty.patch4
-rw-r--r--mail-filter/tmda/tmda-1.1.12-r1.ebuild54
-rw-r--r--mail-filter/tmda/tmda-1.1.12.ebuild73
3 files changed, 56 insertions, 75 deletions
diff --git a/mail-filter/tmda/files/tmda-1.0-non-interactive-tty.patch b/mail-filter/tmda/files/tmda-1.0-non-interactive-tty.patch
index 3900c43dc1a4..75440493811b 100644
--- a/mail-filter/tmda/files/tmda-1.0-non-interactive-tty.patch
+++ b/mail-filter/tmda/files/tmda-1.0-non-interactive-tty.patch
@@ -1,5 +1,5 @@
---- TMDA/Pending.py.bak.20041011 2004-10-11 15:50:13.014474866 -0400
-+++ TMDA/Pending.py 2004-10-11 16:06:02.640603837 -0400
+--- a/TMDA/Pending.py 2004-10-11 15:50:13.014474866 -0400
++++ b/TMDA/Pending.py 2004-10-11 16:06:02.640603837 -0400
@@ -64,6 +64,7 @@
self.verbose = verbose
self.younger = younger
diff --git a/mail-filter/tmda/tmda-1.1.12-r1.ebuild b/mail-filter/tmda/tmda-1.1.12-r1.ebuild
new file mode 100644
index 000000000000..a6d669d69a1e
--- /dev/null
+++ b/mail-filter/tmda/tmda-1.1.12-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Python-based SPAM reduction system"
+HOMEPAGE="http://www.tmda.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc ~sparc x86"
+IUSE=""
+
+DEPEND="virtual/mta"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # Do not open /dev/tty when in batch mode. (bug #67150) -ticho
+ "${FILESDIR}/tmda-1.0-non-interactive-tty.patch"
+)
+
+src_install() {
+ # Executables
+ python_doscript bin/tmda-*
+
+ # The Python TMDA module
+ python_domodule TMDA
+
+ # The templates
+ insinto /etc/tmda
+ doins templates/*.txt
+
+ # Documentation
+ dodoc ChangeLog CODENAMES CRYPTO NEWS README THANKS UPGRADE
+ dodoc -r doc/html
+
+ # Contributed binaries and stuff
+ cd contrib || die
+
+ exeinto /usr/$(get_libdir)/tmda/contrib
+ doexe collectaddys def2html printcdb printdbm \
+ sendit.sh smtp-check-sender update-internaldomains vadduser-tmda \
+ vmailmgr-vdir.sh vpopmail-vdir.sh wrapfd3.sh
+
+ insinto /usr/$(get_libdir)/tmda/contrib
+ doins ChangeLog tmda.el tmda.spec \
+ tofmipd.init tofmipd.sysconfig vtmdarc
+ doins -r dot-tmda
+}
diff --git a/mail-filter/tmda/tmda-1.1.12.ebuild b/mail-filter/tmda/tmda-1.1.12.ebuild
deleted file mode 100644
index cb02daef384c..000000000000
--- a/mail-filter/tmda/tmda-1.1.12.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-PYTHON_DEPEND="2"
-
-inherit eutils multilib python
-
-DESCRIPTION="Python-based SPAM reduction system"
-HOMEPAGE="http://www.tmda.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc ~sparc x86"
-IUSE=""
-
-DEPEND="virtual/mta"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- # Do not open /dev/tty when in batch mode. (bug #67150) -ticho
- epatch "${FILESDIR}/tmda-1.0-non-interactive-tty.patch"
-
- python_convert_shebangs -r $(python_get_version) bin
-}
-
-src_install() {
- # Executables
- dobin bin/tmda-* || die "dobin failed"
-
- # The Python TMDA module
- insinto $(python_get_sitedir)
- doins -r TMDA || die "doins failed"
-
- # The templates
- insinto /etc/tmda
- doins templates/*.txt || die "doins failed"
-
- # Documentation
- dodoc ChangeLog CODENAMES CRYPTO NEWS README THANKS UPGRADE || die "dodoc failed"
- dohtml -r doc/html/* || die "dohtml failed"
-
- # Contributed binaries and stuff
- pushd contrib > /dev/null
-
- exeinto /usr/$(get_libdir)/tmda/contrib
- doexe collectaddys def2html printcdb printdbm \
- sendit.sh smtp-check-sender update-internaldomains vadduser-tmda \
- vmailmgr-vdir.sh vpopmail-vdir.sh wrapfd3.sh || die "doexe failed"
-
- insinto /usr/$(get_libdir)/tmda/contrib
- doins ChangeLog tmda.el tmda.spec \
- tofmipd.init tofmipd.sysconfig vtmdarc || die "doins failed"
-
- insinto /usr/$(get_libdir)/tmda/contrib/dot-tmda
- doins dot-tmda/* || die "doins failed"
- popd > /dev/null
-}
-
-pkg_postinst() {
- python_mod_optimize TMDA
-}
-
-pkg_postrm() {
- python_mod_cleanup TMDA
-}