summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2018-02-21 13:44:13 +0100
committerMarc Schiffbauer <mschiff@gentoo.org>2018-02-21 13:44:13 +0100
commit18a7beafaacbdb463f369e80443ef5a11dc970e2 (patch)
tree090293c08d96edf0d511ba4a57530fe0dcda1530 /mail-filter
parentmedia-sound/audacity: Fixed compilation with USE="-portmixer" (diff)
downloadgentoo-18a7beafaacbdb463f369e80443ef5a11dc970e2.tar.gz
gentoo-18a7beafaacbdb463f369e80443ef5a11dc970e2.tar.bz2
gentoo-18a7beafaacbdb463f369e80443ef5a11dc970e2.zip
mail-filter/sigh: add new version
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/sigh/Manifest1
-rw-r--r--mail-filter/sigh/sigh-1607.1.6.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/mail-filter/sigh/Manifest b/mail-filter/sigh/Manifest
index e6e7e222e842..d3aee440160f 100644
--- a/mail-filter/sigh/Manifest
+++ b/mail-filter/sigh/Manifest
@@ -1 +1,2 @@
DIST sigh-1607.1.2.tar.gz 57662 BLAKE2B 288430b3016483340f7bb6c69060f6c2f38efee525b45d505e965c12e84c66d241d0a90c8a3f55e0b9bf801d8686ee1d2fa5eb03afad4795df620e594468afd9 SHA512 410883b55072b6476fc454440cf5f0e048587853a5095fddd7870b0efb5eca82e257f34ddef821f1a1968e1859207e7972e645922675fddaa2bf05b314bf5f60
+DIST sigh-1607.1.6.tar.gz 58258 BLAKE2B 6d2743c4a850af4f28ba0f2b7a0d6fdef5b699f9521e0631b9bc534be872af4cfccd10de7648080389046faf3f34ba58e3ce68aa318d76ed8e1af5f495f47f70 SHA512 640fa35ea89d7aab956e597ef089a8b7f57af2a7e3de7087e6bd01b60715cc33263cd4fd84a8826ae37387ec802d4bb78c5fe9c83e5d404029d69de010b1ce6b
diff --git a/mail-filter/sigh/sigh-1607.1.6.ebuild b/mail-filter/sigh/sigh-1607.1.6.ebuild
new file mode 100644
index 000000000000..b0d0ac055922
--- /dev/null
+++ b/mail-filter/sigh/sigh-1607.1.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils user
+
+DESCRIPTION="S/MIME signing milter"
+HOMEPAGE="https://signing-milter.org/"
+SRC_URI="https://github.com/croessner/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="mail-filter/libmilter
+ dev-libs/boost
+ dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+
+DOCS=( README README.build AUTHORS LICENSE )
+CMAKE_IN_SOURCE_BUILD=1
+
+pkg_setup() {
+ enewgroup sigh
+ enewuser sigh -1 -1 /var/lib/sigh sigh
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dodoc "${DOCS[@]}"
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+}