summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-09-14 11:43:18 -0400
committerEttore Di Giacinto <mudler@gentoo.org>2016-11-21 12:00:49 +0100
commitdbe6362846102be480e7a5b5ba6ca458e56b89b4 (patch)
tree3cb814df2be7cca9425219f534e6d690f8bebd8d /mate-extra/mate-indicator-applet
parentmate-base/mate-control-center: apply appindicator patch to 1.14.1, #593678 (diff)
downloadgentoo-dbe6362846102be480e7a5b5ba6ca458e56b89b4.tar.gz
gentoo-dbe6362846102be480e7a5b5ba6ca458e56b89b4.tar.bz2
gentoo-dbe6362846102be480e7a5b5ba6ca458e56b89b4.zip
mate-extra/mate-indicator-applet: Fix configure.ac for indicator-ng #593680
Package-Manager: portage-2.3.0
Diffstat (limited to 'mate-extra/mate-indicator-applet')
-rw-r--r--mate-extra/mate-indicator-applet/files/mate-indicator-applet-1.14.1-indicator-ng-configure-fix.patch30
-rw-r--r--mate-extra/mate-indicator-applet/mate-indicator-applet-1.14.1-r1.ebuild (renamed from mate-extra/mate-indicator-applet/mate-indicator-applet-1.14.1.ebuild)2
2 files changed, 32 insertions, 0 deletions
diff --git a/mate-extra/mate-indicator-applet/files/mate-indicator-applet-1.14.1-indicator-ng-configure-fix.patch b/mate-extra/mate-indicator-applet/files/mate-indicator-applet-1.14.1-indicator-ng-configure-fix.patch
new file mode 100644
index 00000000000..b9ae4fc8fec
--- /dev/null
+++ b/mate-extra/mate-indicator-applet/files/mate-indicator-applet-1.14.1-indicator-ng-configure-fix.patch
@@ -0,0 +1,30 @@
+From 06f6db28648cdeff02cc07f9a7f1410b228450a4 Mon Sep 17 00:00:00 2001
+From: monsta <monsta@inbox.ru>
+Date: Wed, 14 Sep 2016 18:20:25 +0300
+Subject: [PATCH] check for libindicator 12.10.2 for new style indicators
+ support
+
+fixes build on Gentoo which has 12.10.1 - turned out this version
+had no indicator-ng yet.
+
+note that (as of now) 12.10.2 isn't officially released upstream,
+and Ubuntu has post-12.10.1 repo snapshot packaged and labeled as
+12.10.2. however, that snapshot already has 12.10.2 version in .pc
+file, so the build works with it.
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 5e9c505..9b4dafc 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -46,7 +46,7 @@ case "$with_gtk" in
+ esac
+
+ INDICATOR_REQUIRED_VERSION=0.3.90
+-INDICATOR_NG_VERSION=12.10
++INDICATOR_NG_VERSION=12.10.2
+ INDICATOR_PKG=indicator$INDICATOR_API_VERSION-0.4
+
+ PKG_CHECK_MODULES(APPLET, gtk+-$GTK_API_VERSION >= $GTK_REQUIRED_VERSION
diff --git a/mate-extra/mate-indicator-applet/mate-indicator-applet-1.14.1.ebuild b/mate-extra/mate-indicator-applet/mate-indicator-applet-1.14.1-r1.ebuild
index 00527254932..605c790c1d8 100644
--- a/mate-extra/mate-indicator-applet/mate-indicator-applet-1.14.1.ebuild
+++ b/mate-extra/mate-indicator-applet/mate-indicator-applet-1.14.1-r1.ebuild
@@ -33,6 +33,8 @@ DEPEND="${COMMON_DEPEND}
>=dev-util/intltool-0.35.0
virtual/pkgconfig"
+PATCHES=( "${FILESDIR}/${P}-indicator-ng-configure-fix.patch" )
+
src_configure() {
mate_src_configure \
--with-gtk=$(usex gtk3 3.0 2.0)