summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-09-21 13:18:12 +0200
committerSebastian Pipping <sping@gentoo.org>2018-09-21 13:21:16 +0200
commit76860aa860c8656ca8d14b81b6327d4116324eff (patch)
tree165891cab54044e55eb94febe67b3bdb5546e869 /media-fonts/encodings
parentapp-eselect/eselect-repository: Add ~sparc keyword too (diff)
downloadgentoo-76860aa860c8656ca8d14b81b6327d4116324eff.tar.gz
gentoo-76860aa860c8656ca8d14b81b6327d4116324eff.tar.bz2
gentoo-76860aa860c8656ca8d14b81b6327d4116324eff.zip
media-fonts/encodings: Fix xorg-2_src_install shadowing regression
xorg-2_pkg_post* are called to be future proof, only. Closes: https://bugs.gentoo.org/665008 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'media-fonts/encodings')
-rw-r--r--media-fonts/encodings/encodings-1.0.4-r3.ebuild (renamed from media-fonts/encodings/encodings-1.0.4-r2.ebuild)15
1 files changed, 14 insertions, 1 deletions
diff --git a/media-fonts/encodings/encodings-1.0.4-r2.ebuild b/media-fonts/encodings/encodings-1.0.4-r3.ebuild
index 0d23578cb789..af7bb67275f0 100644
--- a/media-fonts/encodings/encodings-1.0.4-r2.ebuild
+++ b/media-fonts/encodings/encodings-1.0.4-r3.ebuild
@@ -2,7 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit xorg-2 font # since media-fonts/encodings does not match media-fonts/font*
+
+# font eclass is needed since "media-fonts/encodings" does not match
+# check for pattern media-fonts/font* in xorg-2 eclass
+inherit font xorg-2
DESCRIPTION="X.Org font encodings"
@@ -13,3 +16,13 @@ DEPEND="x11-apps/mkfontscale
>=media-fonts/font-util-1.1.1-r1"
ECONF_SOURCE="${S}"
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ font_pkg_postinst
+}
+
+pkg_postrm() {
+ xorg-2_pkg_postrm
+ font_pkg_postrm
+}