summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre059.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre059.ebuild')
-rw-r--r--media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre059.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre059.ebuild b/media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre059.ebuild
new file mode 100644
index 000000000000..c650d97b2012
--- /dev/null
+++ b/media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre059.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit font
+
+MY_P="mplus-${PV/0_pre/TESTFLIGHT-}"
+
+DESCRIPTION="M+ Japanese outline fonts"
+HOMEPAGE="http://mplus-fonts.osdn.jp/ http://ossipedia.ipa.go.jp/ipafont/"
+SRC_URI="mirror://sourceforge.jp/mplus-fonts/62344/${MY_P}.tar.xz"
+
+LICENSE="mplus-fonts ipafont? ( IPAfont )"
+SLOT="0"
+KEYWORDS="amd64 hppa ia64 ppc x86 ~ppc-macos ~x86-macos"
+IUSE="ipafont"
+RESTRICT="binchecks strip"
+
+DEPEND="ipafont? (
+ media-gfx/fontforge
+ media-fonts/ja-ipafonts
+ )"
+RDEPEND=""
+S="${WORKDIR}/${MY_P}"
+
+FONT_SUFFIX="ttf"
+FONT_S="${S}"
+DOCS="README_J README_E"
+
+IPAFONT_DIR="${EPREFIX}/usr/share/fonts/ja-ipafonts"
+
+src_prepare() {
+ if use ipafont; then
+ cp -p "${IPAFONT_DIR}"/ipag.ttf "${S}" || die
+ fi
+}
+
+src_compile() {
+ if use ipafont; then
+ fontforge -script m++ipa.pe || die
+ rm -f ipag.ttf
+ fi
+}