summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-08-14 02:05:33 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-09-15 10:05:41 +0300
commitdd330c19c9a9f3477c3c2f7c38ee36efc248770a (patch)
treeaa2a2788cb23bcf5f027264d6c53623991063f94 /media-fonts/source-code-pro/source-code-pro-2.038.ebuild
parentdev-ml/bos: Stabilize 0.2.1 arm64, #867118 (diff)
downloadgentoo-dd330c19c9a9f3477c3c2f7c38ee36efc248770a.tar.gz
gentoo-dd330c19c9a9f3477c3c2f7c38ee36efc248770a.tar.bz2
gentoo-dd330c19c9a9f3477c3c2f7c38ee36efc248770a.zip
media-fonts/source-code-pro: new package, add 2.038
media-fonts/source-pro installs 3 font families. A while ago the serif and sans-serif fonts were renamed (and will be renamed again) while the monospace font kept the same name. Furthermore, the fonts now have the major version in their name. The fonts will be split into their own packages and the old package will be masked since it isn't bump-able. Bug: https://bugs.gentoo.org/865103 Upstream-announcement: https://github.com/adobe-fonts/source-serif/issues/77 Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-fonts/source-code-pro/source-code-pro-2.038.ebuild')
-rw-r--r--media-fonts/source-code-pro/source-code-pro-2.038.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-fonts/source-code-pro/source-code-pro-2.038.ebuild b/media-fonts/source-code-pro/source-code-pro-2.038.ebuild
new file mode 100644
index 000000000000..572e940715eb
--- /dev/null
+++ b/media-fonts/source-code-pro/source-code-pro-2.038.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit font
+
+REALV="2.038R-ro/1.058R-it/1.018R-VAR"
+
+DESCRIPTION="Monospaced font family for user interface and coding environments"
+HOMEPAGE="https://adobe-fonts.github.io/source-code-pro/"
+SRC_URI="https://github.com/adobe-fonts/source-code-pro/archive/${REALV}.tar.gz -> source-code-pro-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${REALV//\//-}"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RESTRICT="binchecks strip"
+
+RDEPEND="
+ media-libs/fontconfig
+ !media-fonts/source-pro
+"
+
+FONT_CONF=( "${FILESDIR}"/63-${PN}.conf )
+FONT_SUFFIX="otf"
+
+src_prepare() {
+ default
+ mv OTF/*.otf . || die
+}