summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-01-24 19:40:36 +0100
committerPacho Ramos <pacho@gentoo.org>2021-01-24 19:42:04 +0100
commitf45daca86639478b38d3d28f069f7423115fc5c0 (patch)
treebb822d17c09356b5db40068f0fc1dc581a04946b /media-fonts
parentRevert "sys-libs/db: remove old" (diff)
downloadgentoo-f45daca86639478b38d3d28f069f7423115fc5c0.tar.gz
gentoo-f45daca86639478b38d3d28f069f7423115fc5c0.tar.bz2
gentoo-f45daca86639478b38d3d28f069f7423115fc5c0.zip
media-fonts/noto: New snapshot
In sync with newer snapshot in Arch Linux Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-fonts')
-rw-r--r--media-fonts/noto/Manifest1
-rw-r--r--media-fonts/noto/noto-20201226.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/media-fonts/noto/Manifest b/media-fonts/noto/Manifest
index 38abdcf1b741..d8625f4f001b 100644
--- a/media-fonts/noto/Manifest
+++ b/media-fonts/noto/Manifest
@@ -1,3 +1,4 @@
DIST noto-20190524.tar.gz 740252290 BLAKE2B e169ee60c9a83c13656ebd5dbce32aad183bbebc057035c69723788725a1c14a016c37bea7ccf30fc9d776e421515c2fa03f929b5f7bf95d9e3abb1abbeccbbf SHA512 668f7d015da420b3c32f8c0313037bab731bd915875f476beb47e6c3e8d33a30cd608d2f351194607afbf28f8f3efc1eb5f8470c03fd88a83df33b478fa78147
DIST noto-20200308.tar.gz 853685953 BLAKE2B 1f25bf1b763161fc246b0a1ed532d4755e4ef441055d92a8a17a05331bbbe47b4f604492e0403088d5aac9a86e42b27354eb7d4c9bc6286853ce1562b7940344 SHA512 9afec0c150beeb2bb27af58b9118da4bf86a21f25b573be3a01186c0295b9d5f51918d9237fafc76a0388c87a2b8fd780ba450fb8b4c3e65addad729e8f56a9f
DIST noto-20200521.tar.gz 861394318 BLAKE2B e30f7ec58130786414f2dd33acaf9c75f403718612270e346fe51df0cb74088ddc34b699d4af9a494446940aa58a4c2cd043f46208aa7a3004a194703efb464a SHA512 d1090eae56c74237da4e35989d3518dfcb163deee1eb4df64a6be0ccb7e6f2a2207f0602ee5f0156efa2bdb3d105073d2e9a65c8841dbab34207c89c05aeb8bc
+DIST noto-20201226.tar.gz 903613276 BLAKE2B b6ae0357a854b775ca43768609775624370d2f13ae65d05e699105cfacff4bb919ca19f757d4f2fbfde2d24fdfe6c5d6d3b5993a071b0d081948ef8ed6c5eb76 SHA512 240ae214729388e7000a4e12a1fc81b0b562ca6f3fcb4fcdef66a27c1b193825fbf2d0fd4cc8fbae4cd17f57e21fd1589150cb02b7b618d670742692b748f9ff
diff --git a/media-fonts/noto/noto-20201226.ebuild b/media-fonts/noto/noto-20201226.ebuild
new file mode 100644
index 000000000000..439c26108925
--- /dev/null
+++ b/media-fonts/noto/noto-20201226.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit font
+
+DESCRIPTION="Google's font family that aims to support all the world's languages"
+HOMEPAGE="https://www.google.com/get/noto/ https://github.com/googlefonts/noto-fonts"
+
+COMMIT="2b1fbc36600ccd8becb9f894922f644bff2cbc9b"
+SRC_URI="https://github.com/googlei18n/noto-fonts/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+# Extra allows to optionally reduce disk usage even returning to tofu
+# issue as described in https://www.google.com/get/noto/
+IUSE="cjk +extra"
+
+RDEPEND="cjk? ( media-fonts/noto-cjk )"
+DEPEND=""
+
+RESTRICT="binchecks strip"
+
+S="${WORKDIR}/${PN}-fonts-${COMMIT}"
+
+FONT_SUFFIX="ttf"
+FONT_CONF=(
+ # From ArchLinux
+ "${FILESDIR}/66-noto-serif.conf"
+ "${FILESDIR}/66-noto-mono.conf"
+ "${FILESDIR}/66-noto-sans.conf"
+)
+
+src_install() {
+ mkdir install-unhinted install-hinted || die
+ mv unhinted/ttf/Noto*/*.tt[fc] install-unhinted/. || die
+ mv hinted/ttf/Noto*/*.tt[fc] install-hinted/. || die
+
+ FONT_S="${S}/install-unhinted/" font_src_install
+ FONT_S="${S}/install-hinted/" font_src_install
+
+ # Allow to drop some fonts optionally for people that want to save
+ # disk space. Following ArchLinux options.
+ use extra || rm -rf "${ED}"/usr/share/fonts/noto/Noto*{Condensed,SemiBold,Extra}*.ttf
+}