summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-12 12:01:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-12 12:03:34 +0200
commit1ecda4f6fe77c57f8fbedd6abde2fea46a8933e0 (patch)
treea207737bf76e5bc51ed49fe8cbe2b4a2dccdb48c /media-gfx/alembic/files
parentkde-plasma: Add missing patches (diff)
downloadgentoo-1ecda4f6fe77c57f8fbedd6abde2fea46a8933e0.tar.gz
gentoo-1ecda4f6fe77c57f8fbedd6abde2fea46a8933e0.tar.bz2
gentoo-1ecda4f6fe77c57f8fbedd6abde2fea46a8933e0.zip
media-gfx/alembic: Drop 1.7.4
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/alembic/files')
-rw-r--r--media-gfx/alembic/files/alembic-CMakeLists-fix_lib.patch132
-rw-r--r--media-gfx/alembic/files/alembic-fix-importerror.patch17
2 files changed, 0 insertions, 149 deletions
diff --git a/media-gfx/alembic/files/alembic-CMakeLists-fix_lib.patch b/media-gfx/alembic/files/alembic-CMakeLists-fix_lib.patch
deleted file mode 100644
index c653927ecbe1..000000000000
--- a/media-gfx/alembic/files/alembic-CMakeLists-fix_lib.patch
+++ /dev/null
@@ -1,132 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index d84f002..a35b662 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -79,12 +79,12 @@ OPTION(ALEMBIC_LIB_USES_TR1
-
- # Set static/dynamic build options
- SET(LIB_TYPE STATIC)
--SET(RUNTIME_INSTALL_DIR lib)
--SET(LIBRARY_INSTALL_DIR lib)
--SET(ARCHIVE_INSTALL_DIR lib)
-+SET(RUNTIME_INSTALL_DIR lib64)
-+SET(LIBRARY_INSTALL_DIR lib64)
-+SET(ARCHIVE_INSTALL_DIR lib64)
- IF (ALEMBIC_SHARED_LIBS)
- SET(LIB_TYPE SHARED)
-- SET(ARCHIVE_INSTALL_DIR lib)
-+ SET(ARCHIVE_INSTALL_DIR lib64)
- IF (WIN32)
- ADD_DEFINITIONS(-DALEMBIC_DLL)
- ENDIF()
-diff --git a/bin/AbcConvert/CMakeLists.txt b/bin/AbcConvert/CMakeLists.txt
-index 3725ed7..edea767 100644
---- a/bin/AbcConvert/CMakeLists.txt
-+++ b/bin/AbcConvert/CMakeLists.txt
-@@ -38,6 +38,6 @@ TARGET_LINK_LIBRARIES(abcconvert Alembic)
-
- set_target_properties(abcconvert PROPERTIES
- INSTALL_RPATH_USE_LINK_PATH TRUE
-- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
-+ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib64)
-
- INSTALL(TARGETS abcconvert DESTINATION bin)
-diff --git a/bin/AbcDiff/CMakeLists.txt b/bin/AbcDiff/CMakeLists.txt
-index e2fd355..2234650 100644
---- a/bin/AbcDiff/CMakeLists.txt
-+++ b/bin/AbcDiff/CMakeLists.txt
-@@ -38,6 +38,6 @@ TARGET_LINK_LIBRARIES(abcdiff Alembic)
-
- set_target_properties(abcdiff PROPERTIES
- INSTALL_RPATH_USE_LINK_PATH TRUE
-- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
-+ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib64)
-
- INSTALL(TARGETS abcdiff DESTINATION bin)
-diff --git a/bin/AbcEcho/CMakeLists.txt b/bin/AbcEcho/CMakeLists.txt
-index 396226e..116c122 100644
---- a/bin/AbcEcho/CMakeLists.txt
-+++ b/bin/AbcEcho/CMakeLists.txt
-@@ -41,6 +41,6 @@ TARGET_LINK_LIBRARIES(abcechobounds Alembic)
-
- set_target_properties(abcecho abcechobounds PROPERTIES
- INSTALL_RPATH_USE_LINK_PATH TRUE
-- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
-+ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib64)
-
- INSTALL(TARGETS abcecho abcechobounds DESTINATION bin)
-diff --git a/bin/AbcLs/CMakeLists.txt b/bin/AbcLs/CMakeLists.txt
-index 1dbeb9d..7b721d0 100644
---- a/bin/AbcLs/CMakeLists.txt
-+++ b/bin/AbcLs/CMakeLists.txt
-@@ -39,6 +39,6 @@ TARGET_LINK_LIBRARIES(abcls Alembic)
-
- set_target_properties(abcls PROPERTIES
- INSTALL_RPATH_USE_LINK_PATH TRUE
-- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
-+ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib64)
-
- INSTALL(TARGETS abcls DESTINATION bin)
-diff --git a/bin/AbcStitcher/CMakeLists.txt b/bin/AbcStitcher/CMakeLists.txt
-index 3106bf2..0c8a205 100644
---- a/bin/AbcStitcher/CMakeLists.txt
-+++ b/bin/AbcStitcher/CMakeLists.txt
-@@ -38,6 +38,6 @@ TARGET_LINK_LIBRARIES(abcstitcher Alembic)
-
- set_target_properties(abcstitcher PROPERTIES
- INSTALL_RPATH_USE_LINK_PATH TRUE
-- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
-+ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib64)
-
- INSTALL(TARGETS abcstitcher DESTINATION bin)
-diff --git a/bin/AbcTree/CMakeLists.txt b/bin/AbcTree/CMakeLists.txt
-index 3c41004..de7c7fc 100644
---- a/bin/AbcTree/CMakeLists.txt
-+++ b/bin/AbcTree/CMakeLists.txt
-@@ -38,6 +38,6 @@ TARGET_LINK_LIBRARIES(abctree Alembic)
-
- set_target_properties(abctree PROPERTIES
- INSTALL_RPATH_USE_LINK_PATH TRUE
-- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
-+ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib64)
-
- INSTALL(TARGETS abctree DESTINATION bin)
-diff --git a/lib/Alembic/CMakeLists.txt b/lib/Alembic/CMakeLists.txt
-index 3e16518..b07cb7d 100644
---- a/lib/Alembic/CMakeLists.txt
-+++ b/lib/Alembic/CMakeLists.txt
-@@ -86,9 +86,9 @@ ENDIF()
-
- INSTALL(TARGETS Alembic
- EXPORT AlembicTargets
-- LIBRARY DESTINATION lib
-- ARCHIVE DESTINATION lib
-- RUNTIME DESTINATION lib)
-+ LIBRARY DESTINATION lib64
-+ ARCHIVE DESTINATION lib64
-+ RUNTIME DESTINATION lib64)
-
- #-******************************************************************************
- # PACKAGE EXPORTS
-diff --git a/python/PyAlembic/CMakeLists.txt b/python/PyAlembic/CMakeLists.txt
-index 06daf30..254ca2b 100644
---- a/python/PyAlembic/CMakeLists.txt
-+++ b/python/PyAlembic/CMakeLists.txt
-@@ -128,7 +128,7 @@ IF (Boost_PYTHON_LIBRARY AND ALEMBIC_PYTHON_LIBRARY)
- )
-
- INSTALL (TARGETS alembic
-- DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
-+ DESTINATION lib64/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
- )
-
- IF (USE_TESTS)
-@@ -137,7 +137,7 @@ IF (Boost_PYTHON_LIBRARY AND ALEMBIC_PYTHON_LIBRARY)
-
- set_target_properties(alembic PROPERTIES
- INSTALL_RPATH_USE_LINK_PATH TRUE
-- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
-+ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib64)
- ELSE()
- MESSAGE(FATAL_ERROR "Unable to find Python libs")
- ENDIF()
diff --git a/media-gfx/alembic/files/alembic-fix-importerror.patch b/media-gfx/alembic/files/alembic-fix-importerror.patch
deleted file mode 100644
index 8a86f08c7334..000000000000
--- a/media-gfx/alembic/files/alembic-fix-importerror.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/python/PyAlembic/CMakeLists.txt b/python/PyAlembic/CMakeLists.txt
-index 254ca2b..c8c915a 100644
---- a/python/PyAlembic/CMakeLists.txt
-+++ b/python/PyAlembic/CMakeLists.txt
-@@ -45,6 +45,12 @@ IF (Boost_PYTHON_LIBRARY AND ALEMBIC_PYTHON_LIBRARY)
- ADD_DEFINITIONS(-Wno-unused-local-typedefs)
- ENDIF()
-
-+ # fix for ImportError: dynamic module does not define init function (initalembic)
-+ # see: https://github.com/alembic/alembic/issues/142
-+ IF (CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
-+ SET (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility=default")
-+ ENDIF()
-+
- SET(CPP_FILES
- PyAbcCoreLayer.cpp
- PyAbcGeomTypes.cpp