summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2018-09-28 16:37:33 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-03 17:57:39 +0200
commit162768ac2cb3e927725d077a815b2f8de34f6ae4 (patch)
treebfa71e0db7d25797c562aab4324b9c35a0e3a3aa /media-gfx/alembic
parentmedia-libs/raptor: Better configure (diff)
downloadgentoo-162768ac2cb3e927725d077a815b2f8de34f6ae4.tar.gz
gentoo-162768ac2cb3e927725d077a815b2f8de34f6ae4.tar.bz2
gentoo-162768ac2cb3e927725d077a815b2f8de34f6ae4.zip
media-gfx/alembic: bump to version 1.7.9
add experimental support for arnold, maya and renderman plugins fix import error in python Bug: https://bugs.gentoo.org/667230 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Package-Manager: Portage-2.3.49, Repoman-2.3.10 Closes: https://github.com/gentoo/gentoo/pull/10003 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/alembic')
-rw-r--r--media-gfx/alembic/Manifest1
-rw-r--r--media-gfx/alembic/alembic-1.7.9.ebuild107
-rw-r--r--media-gfx/alembic/files/alembic-1.7.9-CMakeLists-fix_lib.patch189
-rw-r--r--media-gfx/alembic/files/alembic-1.7.9-find-pyilmbase-python-module.patch13
-rw-r--r--media-gfx/alembic/files/alembic-1.7.9-fix-python-import.patch30
-rw-r--r--media-gfx/alembic/files/alembic-1.7.9-prman.patch26
-rw-r--r--media-gfx/alembic/metadata.xml18
7 files changed, 383 insertions, 1 deletions
diff --git a/media-gfx/alembic/Manifest b/media-gfx/alembic/Manifest
index 84e5a72ffb7e..9e761d9c16c3 100644
--- a/media-gfx/alembic/Manifest
+++ b/media-gfx/alembic/Manifest
@@ -1 +1,2 @@
DIST alembic-1.7.4.tar.gz 805503 BLAKE2B b8a8b986d0323dbe3748e1dde5436d66e08620a28852c3331ee612d43a414e381a1cdbbb63200b8f146ce94ebb0e3d0ae6f70f33575bd9ff25e9121f2cd73d1a SHA512 8e752d6d85bea3b6a53582d35a589fc40824456098d950974effe0a6a0e359fec1e056af1ea1379f7e23b7ffed2c05c7f5269fa4b64757631b7d57fb60ee98b0
+DIST alembic-1.7.9.tar.gz 813379 BLAKE2B 599edeb5ad805656755b3e150fba56182d1d60673951b0c1702b3e3e82d9499ec4fcb938303103c27f84458f61ab8de4b872eaa322380ae7713e3b4cd3831af7 SHA512 8025c20525ffbd5bdc9dd5a33ad8238e49f063d244ab9d112e7d1ddb7ee7cf9b36ceb74cb45d658ce22d3033552c89bddf6b818cf466ea46aa1a70a41fdeddb2
diff --git a/media-gfx/alembic/alembic-1.7.9.ebuild b/media-gfx/alembic/alembic-1.7.9.ebuild
new file mode 100644
index 000000000000..638b12a639b9
--- /dev/null
+++ b/media-gfx/alembic/alembic-1.7.9.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="Open framework for storing and sharing scene data"
+HOMEPAGE="https://www.alembic.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+
+SLOT="0"
+# TODO: ~x86 currently depends on new =dev-python/pyilmbase-2.3.0 which has
+# ~x86 keyword. As soon as it's updated in the tree, the keyword can be
+# added here.
+KEYWORDS="~amd64"
+IUSE="arnold +boost doc examples hdf5 maya prman python test zlib"
+
+# pyalembic python bindings need boost
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ hdf5? ( zlib )
+ python? ( boost )
+"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=media-libs/openexr-2.2.0-r2:=
+ boost? ( >=dev-libs/boost-1.65.0:=[python,${PYTHON_USEDEP}] )
+ hdf5? ( >=sci-libs/hdf5-1.8.18[zlib(+)] )
+ python? ( >=dev-python/pyilmbase-2.2.0[${PYTHON_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.11-r1 )
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-util/cmake-3.9.6
+ doc? ( >=app-doc/doxygen-1.8.13-r1 )
+"
+
+DOCS=( "ACKNOWLEDGEMENTS.txt" "FEEDBACK.txt" "NEWS.txt" "README.txt" )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-FindIlmBase-pkgconfig.patch"
+ "${FILESDIR}/${P}-CMakeLists-fix_lib.patch"
+ "${FILESDIR}/${P}-prman.patch"
+ "${FILESDIR}/${P}-fix-python-import.patch"
+ "${FILESDIR}/${P}-find-pyilmbase-python-module.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DALEMBIC_SHARED_LIBS=ON
+ # The CMakeLists.txt file needs C++11 or C++-0x if none of them
+ # is defined
+ -DALEMBIC_LIB_USES_BOOST=$(usex boost)
+ -DALEMBIC_LIB_USES_TR1=$(usex !boost)
+ -DUSE_ARNOLD=$(usex arnold)
+ -DUSE_BINARIES=ON
+ -DUSE_EXAMPLES=$(usex examples)
+ -DUSE_HDF5=$(usex hdf5)
+ -DUSE_MAYA=$(usex maya)
+ -DUSE_PRMAN=$(usex prman)
+ -DUSE_PYALEMBIC=$(usex python)
+ -DUSE_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ doxygen -u Doxyfile || die
+ doxygen Doxyfile || die
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ if use arnold; then
+ einfo "NOTE: The arnold plugin is highly experimental and hasn't been"
+ einfo "tested, due to missing license. If you have trouble compiling"
+ einfo "or running it, please file a bug report for the package at"
+ einfo "Gentoo's bugzilla."
+ fi
+ if use maya; then
+ einfo "NOTE: The maya plugin is highly experimental and hasn't been"
+ einfo "tested, due to missing license. If you have trouble compiling"
+ einfo "or running it, please file a bug report for the package at"
+ einfo "Gentoo's bugzilla."
+ fi
+ if use prman; then
+ einfo "NOTE: The renderman plugin is still experimental and has not"
+ einfo "been tested much. If you have trouble running it, please file"
+ einfo "a bug report for the package at Gentoo's bugzilla."
+ einfo "If you're looking for an ebuild for renderman, you may want to"
+ einfo "try the waebbl overlay: 'eselect repository enable waebbl'"
+ einfo "followed by 'emerge renderman'"
+ fi
+}
diff --git a/media-gfx/alembic/files/alembic-1.7.9-CMakeLists-fix_lib.patch b/media-gfx/alembic/files/alembic-1.7.9-CMakeLists-fix_lib.patch
new file mode 100644
index 000000000000..06ebf60b0d67
--- /dev/null
+++ b/media-gfx/alembic/files/alembic-1.7.9-CMakeLists-fix_lib.patch
@@ -0,0 +1,189 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 298f4be..18b3ff5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -80,12 +80,12 @@ OPTION(ALEMBIC_LIB_USES_TR1
+
+ # Set static/dynamic build options
+ SET(LIB_TYPE STATIC)
+-SET(RUNTIME_INSTALL_DIR lib)
+-SET(LIBRARY_INSTALL_DIR lib)
+-SET(ARCHIVE_INSTALL_DIR lib)
++SET(RUNTIME_INSTALL_DIR lib${LIB_SUFFIX})
++SET(LIBRARY_INSTALL_DIR lib${LIB_SUFFIX})
++SET(ARCHIVE_INSTALL_DIR lib${LIB_SUFFIX})
+ IF (ALEMBIC_SHARED_LIBS)
+ SET(LIB_TYPE SHARED)
+- SET(ARCHIVE_INSTALL_DIR lib)
++ SET(ARCHIVE_INSTALL_DIR lib${LIB_SUFFIX})
+ IF (WIN32)
+ ADD_DEFINITIONS(-DALEMBIC_DLL)
+ ENDIF()
+diff --git a/arnold/Procedural/CMakeLists.txt b/arnold/Procedural/CMakeLists.txt
+index 69e00da..47ccf66 100644
+--- a/arnold/Procedural/CMakeLists.txt
++++ b/arnold/Procedural/CMakeLists.txt
+@@ -60,7 +60,7 @@ TARGET_LINK_LIBRARIES( AlembicArnoldProcedural Alembic::Alembic)
+
+ set_target_properties(AlembicArnoldProcedural PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL ( TARGETS
+ AlembicArnoldProcedural
+diff --git a/bin/AbcConvert/CMakeLists.txt b/bin/AbcConvert/CMakeLists.txt
+index 451409c..c882971 100644
+--- a/bin/AbcConvert/CMakeLists.txt
++++ b/bin/AbcConvert/CMakeLists.txt
+@@ -38,6 +38,6 @@ TARGET_LINK_LIBRARIES(abcconvert Alembic::Alembic)
+
+ set_target_properties(abcconvert PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL(TARGETS abcconvert DESTINATION bin)
+diff --git a/bin/AbcDiff/CMakeLists.txt b/bin/AbcDiff/CMakeLists.txt
+index 511864a..bed92b2 100644
+--- a/bin/AbcDiff/CMakeLists.txt
++++ b/bin/AbcDiff/CMakeLists.txt
+@@ -38,6 +38,6 @@ TARGET_LINK_LIBRARIES(abcdiff Alembic::Alembic)
+
+ set_target_properties(abcdiff PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL(TARGETS abcdiff DESTINATION bin)
+diff --git a/bin/AbcEcho/CMakeLists.txt b/bin/AbcEcho/CMakeLists.txt
+index be5f5c1..eca449a 100644
+--- a/bin/AbcEcho/CMakeLists.txt
++++ b/bin/AbcEcho/CMakeLists.txt
+@@ -41,6 +41,6 @@ TARGET_LINK_LIBRARIES(abcechobounds Alembic::Alembic)
+
+ set_target_properties(abcecho abcechobounds PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL(TARGETS abcecho abcechobounds DESTINATION bin)
+diff --git a/bin/AbcLs/CMakeLists.txt b/bin/AbcLs/CMakeLists.txt
+index 815f84f..92f83c4 100644
+--- a/bin/AbcLs/CMakeLists.txt
++++ b/bin/AbcLs/CMakeLists.txt
+@@ -39,6 +39,6 @@ TARGET_LINK_LIBRARIES(abcls Alembic::Alembic)
+
+ set_target_properties(abcls PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL(TARGETS abcls DESTINATION bin)
+diff --git a/bin/AbcStitcher/CMakeLists.txt b/bin/AbcStitcher/CMakeLists.txt
+index a963420..a84e00b 100644
+--- a/bin/AbcStitcher/CMakeLists.txt
++++ b/bin/AbcStitcher/CMakeLists.txt
+@@ -38,6 +38,6 @@ TARGET_LINK_LIBRARIES(abcstitcher Alembic::Alembic)
+
+ set_target_properties(abcstitcher PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL(TARGETS abcstitcher DESTINATION bin)
+diff --git a/bin/AbcTree/CMakeLists.txt b/bin/AbcTree/CMakeLists.txt
+index b4f65f1..74225ac 100644
+--- a/bin/AbcTree/CMakeLists.txt
++++ b/bin/AbcTree/CMakeLists.txt
+@@ -38,6 +38,6 @@ TARGET_LINK_LIBRARIES(abctree Alembic::Alembic)
+
+ set_target_properties(abctree PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL(TARGETS abctree DESTINATION bin)
+diff --git a/lib/Alembic/CMakeLists.txt b/lib/Alembic/CMakeLists.txt
+index fb3def8..d5bbcec 100644
+--- a/lib/Alembic/CMakeLists.txt
++++ b/lib/Alembic/CMakeLists.txt
+@@ -84,7 +84,7 @@ IF ( ${ALEMBIC_LIB_USES_TR1} AND CMAKE_COMPILER_IS_GNUCXX AND
+ TARGET_LINK_LIBRARIES( Alembic atomic )
+ ENDIF()
+
+-SET( ALEMBIC_LIB_INSTALL_DIR lib CACHE PATH "Where to install the Alembic libs")
++SET( ALEMBIC_LIB_INSTALL_DIR lib${LIB_SUFFIX} CACHE PATH "Where to install the Alembic libs")
+ INSTALL(TARGETS Alembic
+ EXPORT AlembicTargets
+ LIBRARY DESTINATION ${ALEMBIC_LIB_INSTALL_DIR}
+@@ -117,7 +117,7 @@ EXPORT(TARGETS
+ Alembic::
+ )
+
+-SET(ConfigPackageLocation lib/cmake/Alembic CACHE PATH
++SET(ConfigPackageLocation lib${LIB_SUFFIX}/cmake/Alembic CACHE PATH
+ "Where to install the Alembic's cmake files")
+
+ INSTALL(FILES
+diff --git a/maya/AbcExport/CMakeLists.txt b/maya/AbcExport/CMakeLists.txt
+index 50d2fd2..f8bc850 100644
+--- a/maya/AbcExport/CMakeLists.txt
++++ b/maya/AbcExport/CMakeLists.txt
+@@ -77,7 +77,7 @@ TARGET_LINK_LIBRARIES(AbcExport
+
+ set_target_properties(AbcExport PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL(TARGETS AbcExport
+ DESTINATION ${ALEMBIC_MAYA_PLUGINS_INSTALL_DIR})
+diff --git a/maya/AbcImport/CMakeLists.txt b/maya/AbcImport/CMakeLists.txt
+index 6826183..e71e612 100644
+--- a/maya/AbcImport/CMakeLists.txt
++++ b/maya/AbcImport/CMakeLists.txt
+@@ -81,7 +81,7 @@ TARGET_LINK_LIBRARIES(AbcImport
+
+ set_target_properties(AbcImport PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL(TARGETS AbcImport
+ DESTINATION ${ALEMBIC_MAYA_PLUGINS_INSTALL_DIR})
+diff --git a/prman/Procedural/CMakeLists.txt b/prman/Procedural/CMakeLists.txt
+index 6b46e91..3635bcc 100644
+--- a/prman/Procedural/CMakeLists.txt
++++ b/prman/Procedural/CMakeLists.txt
+@@ -60,7 +60,7 @@ TARGET_LINK_LIBRARIES(AlembicRiProcedural Alembic::Alembic)
+
+ set_target_properties(AlembicRiProcedural PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL(TARGETS
+ AlembicRiProcedural
+diff --git a/python/PyAlembic/CMakeLists.txt b/python/PyAlembic/CMakeLists.txt
+index 91c45c4..c87eec6 100644
+--- a/python/PyAlembic/CMakeLists.txt
++++ b/python/PyAlembic/CMakeLists.txt
+@@ -128,7 +128,7 @@ IF (Boost_PYTHON_LIBRARY AND ALEMBIC_PYTHON_LIBRARY)
+ )
+
+ SET( ALEMBIC_PYTHON_INSTALL_DIR
+- lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
++ lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
+ CACHE PATH
+ "Alembic's python bindings install directory"
+ )
+@@ -143,7 +143,7 @@ IF (Boost_PYTHON_LIBRARY AND ALEMBIC_PYTHON_LIBRARY)
+
+ set_target_properties(alembic PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+ ELSE()
+ MESSAGE(FATAL_ERROR "Unable to find Python libs")
+ ENDIF()
diff --git a/media-gfx/alembic/files/alembic-1.7.9-find-pyilmbase-python-module.patch b/media-gfx/alembic/files/alembic-1.7.9-find-pyilmbase-python-module.patch
new file mode 100644
index 000000000000..4acdc5d7d885
--- /dev/null
+++ b/media-gfx/alembic/files/alembic-1.7.9-find-pyilmbase-python-module.patch
@@ -0,0 +1,13 @@
+diff --git a/cmake/Modules/FindPyIlmBase.cmake b/cmake/Modules/FindPyIlmBase.cmake
+index 5cb9108..c3f80a2 100644
+--- a/cmake/Modules/FindPyIlmBase.cmake
++++ b/cmake/Modules/FindPyIlmBase.cmake
+@@ -44,7 +44,7 @@ ELSE()
+ SET(ALEMBIC_PYILMBASE_ROOT NOTFOUND)
+ ELSE()
+ # TODO: set to default install path when shipping out
+- SET(ALEMBIC_PYILMBASE_ROOT "/usr/local/pyilmbase/")
++ SET(ALEMBIC_PYILMBASE_ROOT "/usr")
+ ENDIF()
+ ELSE()
+ IF (${WINDOWS})
diff --git a/media-gfx/alembic/files/alembic-1.7.9-fix-python-import.patch b/media-gfx/alembic/files/alembic-1.7.9-fix-python-import.patch
new file mode 100644
index 000000000000..ca8bedef57ac
--- /dev/null
+++ b/media-gfx/alembic/files/alembic-1.7.9-fix-python-import.patch
@@ -0,0 +1,30 @@
+diff --git a/cmake/Modules/FindPyIlmBase.cmake b/cmake/Modules/FindPyIlmBase.cmake
+index c677549..5cb9108 100644
+--- a/cmake/Modules/FindPyIlmBase.cmake
++++ b/cmake/Modules/FindPyIlmBase.cmake
+@@ -60,11 +60,11 @@ ELSE()
+
+ SET(LIBRARY_PATHS
+ ${ALEMBIC_PYILMBASE_ROOT}/lib
+- ${ALEMBIC_PYILMBASE_MODULE_DIRECTORY}
++# ${ALEMBIC_PYILMBASE_MODULE_DIRECTORY} # this is defined nowhere
+ ~/Library/Frameworks
+ /Library/Frameworks
+- /usr/local/lib
+- /usr/lib
++ /usr/local/lib${LIB_SUFFIX}
++ /usr/lib${LIB_SUFFIX}
+ /sw/lib
+ /opt/local/lib
+ /opt/csw/lib
+@@ -118,8 +118,8 @@ ELSE()
+ FIND_PATH(ALEMBIC_PYIMATH_MODULE_DIRECTORY imathmodule.so
+ PATHS
+ ${LIBRARY_PATHS}
+- /usr/local/lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
+- ${ALEMBIC_PYILMBASE_ROOT}/lib64/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
++ /usr/local/lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
++ ${ALEMBIC_PYILMBASE_ROOT}/lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
+ DOC "The imathmodule.so module directory"
+ )
+
diff --git a/media-gfx/alembic/files/alembic-1.7.9-prman.patch b/media-gfx/alembic/files/alembic-1.7.9-prman.patch
new file mode 100644
index 000000000000..cfd299c79bb0
--- /dev/null
+++ b/media-gfx/alembic/files/alembic-1.7.9-prman.patch
@@ -0,0 +1,26 @@
+diff --git a/cmake/AlembicPRMan.cmake b/cmake/AlembicPRMan.cmake
+index e02b237..fdbf26c 100644
+--- a/cmake/AlembicPRMan.cmake
++++ b/cmake/AlembicPRMan.cmake
+@@ -66,8 +66,8 @@ ELSE()
+ ENDIF()
+
+ # Prefer PRMAN_ROOT set from the environment over the CMakeCache'd variable
+-IF(NOT $ENV{PRMAN_ROOT}x STREQUAL "x")
+- SET( ALEMBIC_PRMAN_ROOT $ENV{PRMAN_ROOT})
++IF(NOT $ENV{RMANTREE}x STREQUAL "x")
++ SET( ALEMBIC_PRMAN_ROOT $ENV{RMANTREE})
+ ENDIF()
+
+
+diff --git a/prman/Procedural/CMakeLists.txt b/prman/Procedural/CMakeLists.txt
+index 6b46e91..0cb2aa6 100644
+--- a/prman/Procedural/CMakeLists.txt
++++ b/prman/Procedural/CMakeLists.txt
+@@ -65,5 +65,5 @@ set_target_properties(AlembicRiProcedural PROPERTIES
+ INSTALL(TARGETS
+ AlembicRiProcedural
+ DESTINATION
+- prman/procedurals
++ $ENV{RMANTREE}/lib/plugins
+ )
diff --git a/media-gfx/alembic/metadata.xml b/media-gfx/alembic/metadata.xml
index 3d75399517fe..30e01e315c7e 100644
--- a/media-gfx/alembic/metadata.xml
+++ b/media-gfx/alembic/metadata.xml
@@ -14,9 +14,25 @@
developed by Sony Pictures Imageworks Inc. and Lucasfilm Ltd.
</longdescription>
<use>
+ <flag name="arnold">
+ Add support for arnold renderer (experimental)
+ </flag>
<flag name="boost">Use <pkg>dev-libs/boost</pkg> library</flag>
+ <flag name="examples">Install alembic examples</flag>
<flag name="hdf5">Add support <pkg>sci-libs/hdf5</pkg></flag>
- <flag name="pyalembic">Build pyalembic python bindings (needs <pkg>dev-python/pyilmbase</pkg>)</flag>
+ <flag name="maya">
+ Compile Alembic plugin for Maya (experimental)
+ </flag>
+ <flag name="prman">
+ Compile Alembic plugin for Renderman (experimental)
+ </flag>
+ <flag name="pyalembic">
+ <!-- renamed to python in 1.7.9 -->
+ Build pyalembic python bindings (needs <pkg>dev-python/pyilmbase</pkg>)
+ </flag>
+ <flag name="python">
+ Build pyalembic python bindings (needs <pkg>dev-python/pyilmbase</pkg>)
+ </flag>
<flag name="test">Build and run the test-suite</flag>
<flag name="zlib">Use <pkg>sys-libs/zlib</pkg> for compressions</flag>
</use>