summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-07-07 05:23:50 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-07-07 05:35:44 -0400
commit133c932e20dcc4690a9c42539071849742875905 (patch)
tree9a6778f011c5fdfd05d28655af0f281f24bd4d5f /media-gfx/cairosvg/cairosvg-2.0.3.ebuild
parentdev-util/debhelper: Old. (diff)
downloadgentoo-133c932e20dcc4690a9c42539071849742875905.tar.gz
gentoo-133c932e20dcc4690a9c42539071849742875905.tar.bz2
gentoo-133c932e20dcc4690a9c42539071849742875905.zip
media-gfx/cairosvg: Version Bump
1.0.22: Last version to support Python2. Shortened description (repoman complaint. 2.0.3: The latest and greatest. Bumped EAPI to 6, dropped Python 2.7 and added Python 3.6 to PYTHON_COMPAT, shortened description (repoman complaint), dropped dev-python/pycairo dependency, and added dev-python/pillow dependency. Bug: 623980 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'media-gfx/cairosvg/cairosvg-2.0.3.ebuild')
-rw-r--r--media-gfx/cairosvg/cairosvg-2.0.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-gfx/cairosvg/cairosvg-2.0.3.ebuild b/media-gfx/cairosvg/cairosvg-2.0.3.ebuild
new file mode 100644
index 000000000000..8931a2878267
--- /dev/null
+++ b/media-gfx/cairosvg/cairosvg-2.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="CairoSVG"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="CLI and library to export SVG to PDF, PostScript, and PNG"
+HOMEPAGE="http://cairosvg.org/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/cairocffi[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/tinycss[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( NEWS.rst README.rst TODO.rst )