summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2021-12-28 09:40:19 +0100
committerHanno Böck <hanno@gentoo.org>2021-12-28 09:40:19 +0100
commit32ad4a993f771e9057ef5055f2ab189d57007ebd (patch)
tree60717bf3856ce429ea20040608e110cf0fc748af /media-gfx/cropgui/cropgui-0.6.ebuild
parentmedia-sound/paprefs: bump to 1.2 (diff)
downloadgentoo-32ad4a993f771e9057ef5055f2ab189d57007ebd.tar.gz
gentoo-32ad4a993f771e9057ef5055f2ab189d57007ebd.tar.bz2
gentoo-32ad4a993f771e9057ef5055f2ab189d57007ebd.zip
media-gfx/cropgui: Version bump
Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-3.0.30, Repoman-3.0.3
Diffstat (limited to 'media-gfx/cropgui/cropgui-0.6.ebuild')
-rw-r--r--media-gfx/cropgui/cropgui-0.6.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-gfx/cropgui/cropgui-0.6.ebuild b/media-gfx/cropgui/cropgui-0.6.ebuild
new file mode 100644
index 000000000000..d0e7fdc45109
--- /dev/null
+++ b/media-gfx/cropgui/cropgui-0.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit eutils python-r1 desktop xdg-utils
+
+DESCRIPTION="GUI for lossless cropping of jpeg images"
+HOMEPAGE="https://emergent.unpythonic.net/01248401946"
+SRC_URI="https://github.com/jepler/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]"
+
+install_cropgui_wrapper() {
+ python_domodule cropgtk.py cropgui_common.py filechooser.py cropgui.glade
+ make_wrapper "${PN}.tmp" "${PYTHON} $(python_get_sitedir)/${PN}/cropgtk.py"
+ python_newexe "${ED}/usr/bin/${PN}.tmp" "${PN}"
+ rm "${ED}/usr/bin/${PN}.tmp" || die
+}
+
+src_install() {
+ python_moduleinto "${PN}"
+ python_foreach_impl install_cropgui_wrapper
+
+ domenu "${PN}.desktop"
+ doicon "${PN}.png"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}