summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-12 22:54:56 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-12 23:06:13 +0100
commit273151668540b3fe89620f1fe4bb9d648f89dadb (patch)
tree9b5d90ac9e2becd8fb37b35dcc981ac7b76c192e /media-gfx/exiv2
parentkde-misc/kmarkdownwebview: 0.5.4 version bump (diff)
downloadgentoo-273151668540b3fe89620f1fe4bb9d648f89dadb.tar.gz
gentoo-273151668540b3fe89620f1fe4bb9d648f89dadb.tar.bz2
gentoo-273151668540b3fe89620f1fe4bb9d648f89dadb.zip
media-gfx/exiv2: Fix pkgconfig
Closes: https://bugs.gentoo.org/675240 Thanks-to: Mike Auty <ikelos@gentoo.org> Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/exiv2')
-rw-r--r--media-gfx/exiv2/exiv2-0.27.0-r2.ebuild109
-rw-r--r--media-gfx/exiv2/files/exiv2-0.27.0-fix-pkgconfig.patch24
2 files changed, 133 insertions, 0 deletions
diff --git a/media-gfx/exiv2/exiv2-0.27.0-r2.ebuild b/media-gfx/exiv2/exiv2-0.27.0-r2.ebuild
new file mode 100644
index 000000000000..4b30b442529c
--- /dev/null
+++ b/media-gfx/exiv2/exiv2-0.27.0-r2.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Exiv2/exiv2.git"
+ inherit git-r3
+else
+ SRC_URI="http://exiv2.dyndns.org/builds/${P}a-Source.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+fi
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit cmake-multilib python-any-r1
+
+DESCRIPTION="EXIF, IPTC and XMP metadata C++ library and command line utility"
+HOMEPAGE="http://www.exiv2.org/"
+
+LICENSE="GPL-2"
+SLOT="0/27"
+IUSE="doc examples nls +png webready +xmp"
+
+RDEPEND="
+ >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+ nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
+ png? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+ webready? (
+ net-libs/libssh[${MULTILIB_USEDEP}]
+ net-misc/curl[${MULTILIB_USEDEP}]
+ )
+ xmp? ( dev-libs/expat[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ dev-libs/libxslt
+ media-gfx/graphviz
+ virtual/pkgconfig
+ )
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( README.md doc/ChangeLog doc/cmd.txt )
+
+S="${S}-Source"
+
+PATCHES=(
+ # pending upstream
+ "${FILESDIR}"/${P}-png-broken-icc-profile.patch
+ # bug 675240
+ "${FILESDIR}"/${P}-fix-pkgconfig.patch
+)
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # FIXME @upstream:
+ einfo "Converting doc/cmd.txt to UTF-8"
+ iconv -f LATIN1 -t UTF-8 doc/cmd.txt > doc/cmd.txt.tmp || die
+ mv -f doc/cmd.txt.tmp doc/cmd.txt || die
+
+ if use doc; then
+ einfo "Updating doxygen config"
+ doxygen &>/dev/null -u config/Doxyfile || die
+ fi
+
+ cmake-utils_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DEXIV2_BUILD_SAMPLES=NO
+ -DEXIV2_BUILD_PO=$(usex nls)
+ -DEXIV2_ENABLE_NLS=$(usex nls)
+ -DEXIV2_ENABLE_PNG=$(usex png)
+ -DEXIV2_ENABLE_CURL=$(usex webready)
+ -DEXIV2_ENABLE_SSH=$(usex webready)
+ -DEXIV2_ENABLE_WEBREADY=$(usex webready)
+ -DEXIV2_ENABLE_XMP=$(usex xmp)
+ $(multilib_is_native_abi || echo -DEXIV2_BUILD_EXIV2_COMMAND=NO)
+ )
+
+ cmake-utils_src_configure
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+
+ if multilib_is_native_abi; then
+ use doc && emake -j1 doc
+ fi
+}
+
+multilib_src_install_all() {
+ use xmp && DOCS+=( doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt} )
+ use doc && HTML_DOCS=( "${S}"/doc/html/. )
+
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+
+ if use examples; then
+ docinto examples
+ dodoc samples/*.cpp
+ fi
+}
diff --git a/media-gfx/exiv2/files/exiv2-0.27.0-fix-pkgconfig.patch b/media-gfx/exiv2/files/exiv2-0.27.0-fix-pkgconfig.patch
new file mode 100644
index 000000000000..5fc430e915d2
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.27.0-fix-pkgconfig.patch
@@ -0,0 +1,24 @@
+From e706cca19027dbdf53aeac2041ecce9ccb313c17 Mon Sep 17 00:00:00 2001
+From: Luis Diaz Mas <piponazo@gmail.com>
+Date: Sat, 12 Jan 2019 13:39:12 +0100
+Subject: [PATCH] Fixes in .pc file for being compatible with more
+ distributions
+
+---
+ cmake/exiv2.pc.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/cmake/exiv2.pc.in b/cmake/exiv2.pc.in
+index e477696d5..9018472be 100644
+--- a/cmake/exiv2.pc.in
++++ b/cmake/exiv2.pc.in
+@@ -1,7 +1,7 @@
+ prefix=@CMAKE_INSTALL_PREFIX@
+ exec_prefix=${prefix}
+-libdir=${prefix}/lib
+-includedir=${prefix}/include
++libdir=${prefix}/@CMAKE_INSTALL_LIBDIR@
++includedir=${prefix}/@CMAKE_INSTALL_INCLUDEDIR@
+
+ Name: exiv2
+ Description: @PROJECT_DESCRIPTION@