summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 17:43:50 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:11:58 +0100
commiteeaf407d6f45b66e0c8cd8a1de4c6ff1af2a5dbb (patch)
tree3a85b07614e8d577f1b77752df60a69a678d757f /media-gfx/fondu
parentmedia-gfx/png2ico: port to EAPI 7 (diff)
downloadgentoo-eeaf407d6f45b66e0c8cd8a1de4c6ff1af2a5dbb.tar.gz
gentoo-eeaf407d6f45b66e0c8cd8a1de4c6ff1af2a5dbb.tar.bz2
gentoo-eeaf407d6f45b66e0c8cd8a1de4c6ff1af2a5dbb.zip
media-gfx/fondu: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/fondu')
-rw-r--r--media-gfx/fondu/files/fondu-20060102-build-fix.patch10
-rw-r--r--media-gfx/fondu/fondu-20060102-r1.ebuild13
2 files changed, 11 insertions, 12 deletions
diff --git a/media-gfx/fondu/files/fondu-20060102-build-fix.patch b/media-gfx/fondu/files/fondu-20060102-build-fix.patch
index d84d0b7bde4e..6a96c2d7c5da 100644
--- a/media-gfx/fondu/files/fondu-20060102-build-fix.patch
+++ b/media-gfx/fondu/files/fondu-20060102-build-fix.patch
@@ -10,9 +10,8 @@ frommacbinary.c:58: warning: too few arguments for format
Upstream: https://sourceforge.net/tracker/?func=detail&aid=2875547&group_id=39411&atid=425133
Author: Peter Volkov <pva@gentoo.org>
-=== modified file 'fondu.c'
---- fondu.c 2009-10-09 07:24:15 +0000
-+++ fondu.c 2009-10-09 07:25:49 +0000
+--- a/fondu.c
++++ b/fondu.c
@@ -473,7 +473,7 @@
}
if ( styleoff!=0 ) {
@@ -55,9 +54,8 @@ Author: Peter Volkov <pva@gentoo.org>
pt += strings[ 0 ][0];
if ( format!=0 && format!=-1 )
-=== modified file 'frommacbinary.c'
---- frommacbinary.c 2009-10-09 07:24:15 +0000
-+++ frommacbinary.c 2009-10-09 07:27:54 +0000
+--- a/frommacbinary.c
++++ b/frommacbinary.c
@@ -55,7 +55,7 @@
/* frombin filenames */
diff --git a/media-gfx/fondu/fondu-20060102-r1.ebuild b/media-gfx/fondu/fondu-20060102-r1.ebuild
index 1144108f1f35..fd4359d3d3cd 100644
--- a/media-gfx/fondu/fondu-20060102-r1.ebuild
+++ b/media-gfx/fondu/fondu-20060102-r1.ebuild
@@ -1,29 +1,30 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-
-inherit epatch
+EAPI=7
MY_PV=${PV:2:6}
DESCRIPTION="Utilities for converting between and manipulating mac fonts and unix fonts"
HOMEPAGE="http://fondu.sourceforge.net/"
SRC_URI="http://fondu.sourceforge.net/${PN}_src-${MY_PV}.tgz"
+S="${WORKDIR}"/${PN}-${MY_PV}
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE=""
-S=${WORKDIR}/${PN}-${MY_PV}
+PATCHES=(
+ "${FILESDIR}"/${P}-build-fix.patch
+)
src_prepare() {
+ default
+
sed -e 's:^CFLAGS =:CFLAGS +=:' \
-e 's:$(CFLAGS) -o:$(CFLAGS) $(LDFLAGS) -o:' \
-e 's:wilprefix:prefix:' \
-i Makefile.in || die "failed to sed"
- epatch "${FILESDIR}/${P}-build-fix.patch"
}
src_install() {