summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-02 23:35:56 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-02 23:36:38 +0100
commit088d47495b72cf9d001f170887ad1e574b01da97 (patch)
tree15d9c4d2c05c50030b82671ac5f61699dd894351 /media-gfx/gmic
parentapp-text/liblangtag: Move test dep to DEPEND where it belongs (diff)
downloadgentoo-088d47495b72cf9d001f170887ad1e574b01da97.tar.gz
gentoo-088d47495b72cf9d001f170887ad1e574b01da97.tar.bz2
gentoo-088d47495b72cf9d001f170887ad1e574b01da97.zip
media-gfx/gmic: Revert back to cmake-utils.eclass
Sorry for breaking. It is weird, but not for me to figure out. Bug: https://bugs.gentoo.org/704524 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/gmic')
-rw-r--r--media-gfx/gmic/gmic-2.7.0.ebuild28
-rw-r--r--media-gfx/gmic/gmic-2.7.1.ebuild28
-rw-r--r--media-gfx/gmic/gmic-2.7.2.ebuild28
3 files changed, 45 insertions, 39 deletions
diff --git a/media-gfx/gmic/gmic-2.7.0.ebuild b/media-gfx/gmic/gmic-2.7.0.ebuild
index a96eb924674f..1edb9254ff06 100644
--- a/media-gfx/gmic/gmic-2.7.0.ebuild
+++ b/media-gfx/gmic/gmic-2.7.0.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_BUILD_TYPE=Release
-inherit cmake bash-completion-r1
+CMAKE_MIN_VERSION=3.9
+
+inherit cmake-utils bash-completion-r1
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/dtschump/gmic.git"
@@ -79,14 +81,14 @@ pkg_pretend() {
src_prepare() {
local PATCHES=( "${FILESDIR}"/${PN}-2.4.3-curl.patch )
- cmake_src_prepare
+ cmake-utils_src_prepare
sed -i '/CMAKE_CXX_FLAGS/s/-g //' CMakeLists.txt || die
if use gimp || use krita || use qt5; then
sed -i '/CMAKE_CXX_FLAGS_RELEASE/d' gmic-qt/CMakeLists.txt || die
local S="${S}/gmic-qt"
PATCHES=( "${FILESDIR}"/${PN}-2.6.7-qt-cmake.patch )
- cmake_src_prepare
+ cmake-utils_src_prepare
fi
}
@@ -113,7 +115,7 @@ src_configure() {
-DENABLE_DYNAMIC_LINKING=ON
)
- cmake_src_configure
+ cmake-utils_src_configure
# configure gmic-qt frontends
local CMAKE_USE_DIR="${S}/gmic-qt"
@@ -126,32 +128,32 @@ src_configure() {
if use gimp; then
mycmakeargs+=( -DGMIC_QT_HOST=gimp )
- BUILD_DIR="${BUILD_DIR}"/gimp cmake_src_configure
+ BUILD_DIR="${BUILD_DIR}"/gimp cmake-utils_src_configure
fi
if use krita; then
mycmakeargs+=( -DGMIC_QT_HOST=krita )
- BUILD_DIR="${BUILD_DIR}"/krita cmake_src_configure
+ BUILD_DIR="${BUILD_DIR}"/krita cmake-utils_src_configure
fi
if use qt5; then
mycmakeargs+=( -DGMIC_QT_HOST=none )
- BUILD_DIR="${BUILD_DIR}"/qt5 cmake_src_configure
+ BUILD_DIR="${BUILD_DIR}"/qt5 cmake-utils_src_configure
fi
}
src_compile() {
- cmake_src_compile
+ cmake-utils_src_compile
# build gmic-qt frontends
local S="${S}/gmic-qt"
- use gimp && { BUILD_DIR="${BUILD_DIR}"/gimp cmake_src_compile || die "failed building gimp plugin" ; }
- use krita && { BUILD_DIR="${BUILD_DIR}"/krita cmake_src_compile || die "failed building krita plugin" ; }
- use qt5 && { BUILD_DIR="${BUILD_DIR}"/qt5 cmake_src_compile || die "failed building qt5 GUI" ; }
+ use gimp && { BUILD_DIR="${BUILD_DIR}"/gimp cmake-utils_src_compile || die "failed building gimp plugin" ; }
+ use krita && { BUILD_DIR="${BUILD_DIR}"/krita cmake-utils_src_compile || die "failed building krita plugin" ; }
+ use qt5 && { BUILD_DIR="${BUILD_DIR}"/qt5 cmake-utils_src_compile || die "failed building qt5 GUI" ; }
}
src_install() {
- cmake_src_install
+ cmake-utils_src_install
dodoc README
use cli && newbashcomp "${BUILD_DIR}"/resources/gmic_bashcompletion.sh ${PN}
diff --git a/media-gfx/gmic/gmic-2.7.1.ebuild b/media-gfx/gmic/gmic-2.7.1.ebuild
index 81708eba2f72..2a575ef1eb65 100644
--- a/media-gfx/gmic/gmic-2.7.1.ebuild
+++ b/media-gfx/gmic/gmic-2.7.1.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_BUILD_TYPE=Release
-inherit cmake bash-completion-r1
+CMAKE_MIN_VERSION=3.9
+
+inherit cmake-utils bash-completion-r1
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/dtschump/gmic.git"
@@ -79,14 +81,14 @@ pkg_pretend() {
src_prepare() {
local PATCHES=( "${FILESDIR}"/${PN}-2.4.3-curl.patch )
- cmake_src_prepare
+ cmake-utils_src_prepare
sed -i '/CMAKE_CXX_FLAGS/s/-g //' CMakeLists.txt || die
if use gimp || use krita || use qt5; then
sed -i '/CMAKE_CXX_FLAGS_RELEASE/d' gmic-qt/CMakeLists.txt || die
local S="${S}/gmic-qt"
PATCHES=( "${FILESDIR}"/${PN}-2.7.1-qt-cmake.patch )
- cmake_src_prepare
+ cmake-utils_src_prepare
fi
}
@@ -113,7 +115,7 @@ src_configure() {
-DENABLE_DYNAMIC_LINKING=ON
)
- cmake_src_configure
+ cmake-utils_src_configure
# configure gmic-qt frontends
local CMAKE_USE_DIR="${S}/gmic-qt"
@@ -126,32 +128,32 @@ src_configure() {
if use gimp; then
mycmakeargs+=( -DGMIC_QT_HOST=gimp )
- BUILD_DIR="${BUILD_DIR}"/gimp cmake_src_configure
+ BUILD_DIR="${BUILD_DIR}"/gimp cmake-utils_src_configure
fi
if use krita; then
mycmakeargs+=( -DGMIC_QT_HOST=krita )
- BUILD_DIR="${BUILD_DIR}"/krita cmake_src_configure
+ BUILD_DIR="${BUILD_DIR}"/krita cmake-utils_src_configure
fi
if use qt5; then
mycmakeargs+=( -DGMIC_QT_HOST=none )
- BUILD_DIR="${BUILD_DIR}"/qt5 cmake_src_configure
+ BUILD_DIR="${BUILD_DIR}"/qt5 cmake-utils_src_configure
fi
}
src_compile() {
- cmake_src_compile
+ cmake-utils_src_compile
# build gmic-qt frontends
local S="${S}/gmic-qt"
- use gimp && { BUILD_DIR="${BUILD_DIR}"/gimp cmake_src_compile || die "failed building gimp plugin" ; }
- use krita && { BUILD_DIR="${BUILD_DIR}"/krita cmake_src_compile || die "failed building krita plugin" ; }
- use qt5 && { BUILD_DIR="${BUILD_DIR}"/qt5 cmake_src_compile || die "failed building qt5 GUI" ; }
+ use gimp && { BUILD_DIR="${BUILD_DIR}"/gimp cmake-utils_src_compile || die "failed building gimp plugin" ; }
+ use krita && { BUILD_DIR="${BUILD_DIR}"/krita cmake-utils_src_compile || die "failed building krita plugin" ; }
+ use qt5 && { BUILD_DIR="${BUILD_DIR}"/qt5 cmake-utils_src_compile || die "failed building qt5 GUI" ; }
}
src_install() {
- cmake_src_install
+ cmake-utils_src_install
dodoc README
use cli && newbashcomp "${BUILD_DIR}"/resources/gmic_bashcompletion.sh ${PN}
diff --git a/media-gfx/gmic/gmic-2.7.2.ebuild b/media-gfx/gmic/gmic-2.7.2.ebuild
index 81708eba2f72..2a575ef1eb65 100644
--- a/media-gfx/gmic/gmic-2.7.2.ebuild
+++ b/media-gfx/gmic/gmic-2.7.2.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_BUILD_TYPE=Release
-inherit cmake bash-completion-r1
+CMAKE_MIN_VERSION=3.9
+
+inherit cmake-utils bash-completion-r1
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/dtschump/gmic.git"
@@ -79,14 +81,14 @@ pkg_pretend() {
src_prepare() {
local PATCHES=( "${FILESDIR}"/${PN}-2.4.3-curl.patch )
- cmake_src_prepare
+ cmake-utils_src_prepare
sed -i '/CMAKE_CXX_FLAGS/s/-g //' CMakeLists.txt || die
if use gimp || use krita || use qt5; then
sed -i '/CMAKE_CXX_FLAGS_RELEASE/d' gmic-qt/CMakeLists.txt || die
local S="${S}/gmic-qt"
PATCHES=( "${FILESDIR}"/${PN}-2.7.1-qt-cmake.patch )
- cmake_src_prepare
+ cmake-utils_src_prepare
fi
}
@@ -113,7 +115,7 @@ src_configure() {
-DENABLE_DYNAMIC_LINKING=ON
)
- cmake_src_configure
+ cmake-utils_src_configure
# configure gmic-qt frontends
local CMAKE_USE_DIR="${S}/gmic-qt"
@@ -126,32 +128,32 @@ src_configure() {
if use gimp; then
mycmakeargs+=( -DGMIC_QT_HOST=gimp )
- BUILD_DIR="${BUILD_DIR}"/gimp cmake_src_configure
+ BUILD_DIR="${BUILD_DIR}"/gimp cmake-utils_src_configure
fi
if use krita; then
mycmakeargs+=( -DGMIC_QT_HOST=krita )
- BUILD_DIR="${BUILD_DIR}"/krita cmake_src_configure
+ BUILD_DIR="${BUILD_DIR}"/krita cmake-utils_src_configure
fi
if use qt5; then
mycmakeargs+=( -DGMIC_QT_HOST=none )
- BUILD_DIR="${BUILD_DIR}"/qt5 cmake_src_configure
+ BUILD_DIR="${BUILD_DIR}"/qt5 cmake-utils_src_configure
fi
}
src_compile() {
- cmake_src_compile
+ cmake-utils_src_compile
# build gmic-qt frontends
local S="${S}/gmic-qt"
- use gimp && { BUILD_DIR="${BUILD_DIR}"/gimp cmake_src_compile || die "failed building gimp plugin" ; }
- use krita && { BUILD_DIR="${BUILD_DIR}"/krita cmake_src_compile || die "failed building krita plugin" ; }
- use qt5 && { BUILD_DIR="${BUILD_DIR}"/qt5 cmake_src_compile || die "failed building qt5 GUI" ; }
+ use gimp && { BUILD_DIR="${BUILD_DIR}"/gimp cmake-utils_src_compile || die "failed building gimp plugin" ; }
+ use krita && { BUILD_DIR="${BUILD_DIR}"/krita cmake-utils_src_compile || die "failed building krita plugin" ; }
+ use qt5 && { BUILD_DIR="${BUILD_DIR}"/qt5 cmake-utils_src_compile || die "failed building qt5 GUI" ; }
}
src_install() {
- cmake_src_install
+ cmake-utils_src_install
dodoc README
use cli && newbashcomp "${BUILD_DIR}"/resources/gmic_bashcompletion.sh ${PN}