summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiogo Pereira <sir.suriv@gmail.com>2020-04-22 00:21:21 +0100
committerMichał Górny <mgorny@gentoo.org>2020-04-23 08:00:56 +0200
commit3eaae3a768cbe49e018aa61ef4148a0251d0c8ca (patch)
treec2998ab575f19d3c1bf6fd91e34fedd6e86dffb4 /media-gfx/img2pdf
parentmedia-gfx/img2pdf: drop 0.3.1 (diff)
downloadgentoo-3eaae3a768cbe49e018aa61ef4148a0251d0c8ca.tar.gz
gentoo-3eaae3a768cbe49e018aa61ef4148a0251d0c8ca.tar.bz2
gentoo-3eaae3a768cbe49e018aa61ef4148a0251d0c8ca.zip
media-gfx/img2pdf: bump to 0.3.4
- Support Python 3.7 and 3.8 - Fix DISTUTILS_USE_SETUPTOOLS QA notice - Use distutils_enable_tests Closes: https://bugs.gentoo.org/711596 Closes: https://bugs.gentoo.org/718332 Signed-off-by: Diogo Pereira <sir.suriv@gmail.com> Package-Manager: Portage-2.3.89, Repoman-2.3.20 Closes: https://github.com/gentoo/gentoo/pull/15459 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-gfx/img2pdf')
-rw-r--r--media-gfx/img2pdf/Manifest1
-rw-r--r--media-gfx/img2pdf/img2pdf-0.3.4.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/media-gfx/img2pdf/Manifest b/media-gfx/img2pdf/Manifest
index 094f67e0c2d2..a13f819f5f27 100644
--- a/media-gfx/img2pdf/Manifest
+++ b/media-gfx/img2pdf/Manifest
@@ -1 +1,2 @@
DIST img2pdf-0.3.3.tar.gz 80523 BLAKE2B 39e372f1ab82d9f521cf2c512b173680afe6463dd041283b336af49c41b12d12261fe5947ad9f03d489b7898d3c8d161faedb2b3366cb75bd1bc0666f905f60c SHA512 234e0031d75727d2f5d2b82603bb447d9101ace81e604b6d5eb358d0b4681e209dbd737775b90b44096cf84239aac9e87e2369e0c6112a17f24ccbf10a20cdd5
+DIST img2pdf-0.3.4.tar.gz 83729 BLAKE2B c595ca7eebfcb91cfe076822836ce07ec0036a510645aae54e495798765df91cddf5de292245c623b2e23918d7862271cdca5d7b8dd76573dc40d8ba7807865a SHA512 0e81e3ee06c62f0ee732b87776f6bc2d066ebce6c23dbcb85b2497518ba43fa3813b3e15f0c476c1203ae6d2b1f4f3e2f1b70215033dddb889fafd75b3671420
diff --git a/media-gfx/img2pdf/img2pdf-0.3.4.ebuild b/media-gfx/img2pdf/img2pdf-0.3.4.ebuild
new file mode 100644
index 000000000000..d6e18fd6a2fa
--- /dev/null
+++ b/media-gfx/img2pdf/img2pdf-0.3.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Losslessly convert raster images to PDF"
+HOMEPAGE="https://gitlab.mister-muffin.de/josch/img2pdf"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? (
+ dev-python/pdfrw[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff,zlib]
+ )"
+RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py