summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-11-06 22:07:18 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-11-06 22:07:37 +0100
commitc54596c57dbf28c6338e16fc9c2273f0600fa47a (patch)
tree88c97e3b44253dbe5c8274a932306851cecde721 /media-gfx/inkscape
parentnet-im/mattermost-desktop-bin: fix unneeded eroor (diff)
downloadgentoo-c54596c57dbf28c6338e16fc9c2273f0600fa47a.tar.gz
gentoo-c54596c57dbf28c6338e16fc9c2273f0600fa47a.tar.bz2
gentoo-c54596c57dbf28c6338e16fc9c2273f0600fa47a.zip
media-gfx/inkscape-1.0_beta1: bump (bug #696794)
dropped arm due to missing arm on dev-libs/gdl:3 Bug: https://bugs.gentoo.org/696794 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-gfx/inkscape')
-rw-r--r--media-gfx/inkscape/Manifest1
-rw-r--r--media-gfx/inkscape/files/inkscape-1.0_beta1-detect-imagemagick.patch13
-rw-r--r--media-gfx/inkscape/files/inkscape-1.0_beta1-do-not-compress-man.patch13
-rw-r--r--media-gfx/inkscape/inkscape-1.0_beta1.ebuild168
-rw-r--r--media-gfx/inkscape/metadata.xml1
5 files changed, 196 insertions, 0 deletions
diff --git a/media-gfx/inkscape/Manifest b/media-gfx/inkscape/Manifest
index 3169bf7e90ed..983a7b023120 100644
--- a/media-gfx/inkscape/Manifest
+++ b/media-gfx/inkscape/Manifest
@@ -1 +1,2 @@
DIST inkscape-0.92.4.tar.bz2 31929728 BLAKE2B 892bf4ed913019b27a9b8897e3ae32c44152163ded0eb345d59915ffdc9818d29f210de3294ef1b05601141185b5e3b10779778551b860f31e7df5c659492c77 SHA512 b9034605a79cd8aea808edf42e284819951ae1ea67778f0922f4c10224e94aca6c844acbc2294625773f0a7047d4e32ccdada876238a792a2c17db172c88e120
+DIST inkscape-1.0beta1.tar.bz2 31096177 BLAKE2B 72769d0e15f20fcc5cdf81987896e7d354c2c71fc31feaa18dfff12df2791d2ed85be4451e76e8191c5f469b2e70fd03f4888270e67628c50978a3fd30c41264 SHA512 35b3ba46d76b55eb268209631ea652b3512d3aaf07f577543081c311acff13b0a667ecf069e9f1c2f47dc16525df952cfb9ca29e9a3078f9096ee7865b917245
diff --git a/media-gfx/inkscape/files/inkscape-1.0_beta1-detect-imagemagick.patch b/media-gfx/inkscape/files/inkscape-1.0_beta1-detect-imagemagick.patch
new file mode 100644
index 000000000000..ee4becfd1090
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-1.0_beta1-detect-imagemagick.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeScripts/DefineDependsandFlags.cmake b/CMakeScripts/DefineDependsandFlags.cmake
+index 91f93e7..95b2af2 100644
+--- a/CMakeScripts/DefineDependsandFlags.cmake
++++ b/CMakeScripts/DefineDependsandFlags.cmake
+@@ -330,7 +330,7 @@ list(APPEND INKSCAPE_LIBS ${ZLIB_LIBRARIES})
+
+ if(WITH_IMAGE_MAGICK)
+ # we want "<" but pkg_check_modules only offers "<=" for some reason; let's hope nobody actually has 7.0.0
+- pkg_check_modules(MAGICK ImageMagick++<=7)
++ pkg_check_modules(MAGICK Magick++<=7)
+ if(MAGICK_FOUND)
+ set(WITH_GRAPHICS_MAGICK OFF) # prefer ImageMagick for now and disable GraphicsMagick if found
+ else()
diff --git a/media-gfx/inkscape/files/inkscape-1.0_beta1-do-not-compress-man.patch b/media-gfx/inkscape/files/inkscape-1.0_beta1-do-not-compress-man.patch
new file mode 100644
index 000000000000..c9d395e807e2
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-1.0_beta1-do-not-compress-man.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeScripts/Pod2man.cmake b/CMakeScripts/Pod2man.cmake
+index eda6292..b94d5af 100644
+--- a/CMakeScripts/Pod2man.cmake
++++ b/CMakeScripts/Pod2man.cmake
+@@ -14,6 +14,8 @@ if(NOT GZIP)
+ message(STATUS "Could not find gzip - man pages uncompressed")
+ endif()
+
++set(GZIP "")
++
+ macro(pod2man PODFILE_FULL RELEASE SECTION CENTER)
+ get_filename_component(PODFILE ${PODFILE_FULL} NAME)
+ string(REPLACE "." ";" PODFILE_LIST ${PODFILE})
diff --git a/media-gfx/inkscape/inkscape-1.0_beta1.ebuild b/media-gfx/inkscape/inkscape-1.0_beta1.ebuild
new file mode 100644
index 000000000000..a22ce6458cc0
--- /dev/null
+++ b/media-gfx/inkscape/inkscape-1.0_beta1.ebuild
@@ -0,0 +1,168 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE="xml"
+
+inherit cmake-utils flag-o-matic xdg-utils xdg toolchain-funcs python-single-r1
+
+MY_P="${P/_/}"
+
+DESCRIPTION="SVG based generic vector-drawing program"
+HOMEPAGE="https://inkscape.org/"
+SRC_URI="https://inkscape.org/gallery/item/14917/${MY_P}.tar.bz2"
+#SRC_URI="https://inkscape.global.ssl.fastly.net/media/resources/file/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="cdr dia dbus exif gnome graphicsmagick +imagemagick openmp postscript inkjar jpeg svg2 jemalloc"
+IUSE+=" lcms nls spell static-libs visio wpg"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE} ^^ ( imagemagick graphicsmagick )"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=app-text/poppler-0.57.0:=[cairo]
+ >=dev-cpp/glibmm-2.54.1
+ >=dev-cpp/cairomm-1.12
+ >=dev-libs/boehm-gc-7.1:=
+ >=dev-libs/glib-2.41
+ >=dev-libs/libsigc++-2.8
+ >=dev-libs/libxml2-2.7.4
+ >=dev-libs/libxslt-1.1.25
+ dev-libs/popt
+ dev-python/lxml[${PYTHON_USEDEP}]
+ media-gfx/potrace
+ media-gfx/scour[${PYTHON_USEDEP}]
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/libpng:0=
+ sci-libs/gsl:=
+ x11-libs/libX11
+ >=x11-libs/pango-1.37.2
+ cdr? (
+ app-text/libwpg:0.3
+ dev-libs/librevenge
+ media-libs/libcdr
+ )
+ dbus? ( dev-libs/dbus-glib )
+ exif? ( media-libs/libexif )
+ gnome? ( >=gnome-base/gnome-vfs-2.0 )
+ imagemagick? ( <media-gfx/imagemagick-7:=[cxx] )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ spell? (
+ app-text/aspell
+ app-text/gtkspell:3
+ )
+ visio? (
+ app-text/libwpg:0.3
+ dev-libs/librevenge
+ media-libs/libvisio
+ )
+ wpg? (
+ app-text/libwpg:0.3
+ dev-libs/librevenge
+ )
+ x11-libs/gtk+:3
+ dev-libs/gdl:3
+ dev-cpp/gtkmm:3.0
+ >=dev-cpp/pangomm-2.40
+ jemalloc? ( dev-libs/jemalloc )
+ net-libs/libsoup
+ dev-libs/double-conversion
+"
+
+# These only use executables provided by these packages
+# See share/extensions for more details. inkscape can tell you to
+# install these so we could of course just not depend on those and rely
+# on that.
+RDEPEND="${COMMON_DEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dia? ( app-office/dia )
+ postscript? ( app-text/ghostscript-gpl )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/boost-1.65
+ dev-util/glib-utils
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-detect-imagemagick.patch
+ "${FILESDIR}"/${P}-do-not-compress-man.patch
+)
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}
+
+src_prepare() {
+ einfo "Fixing doc directory path..."
+ sed -i "s%doc/inkscape%doc/${P}%g" CMakeScripts/ConfigCPack.cmake || die "Failed to fix doc directory path"
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ # aliasing unsafe wrt #310393
+ append-flags -fno-strict-aliasing
+
+mycmakeargs=(
+ -DWITH_DBUS="$(usex dbus ON OFF)" # Compile with support for DBus interface
+ -DENABLE_LCMS="$(usex lcms ON OFF)" # Compile with LCMS support
+ -DWITH_SVG2="$(usex svg2 ON OFF)" # Compile with support for new SVG2 features
+# -DWITH_LPETOOL # Compile with LPE Tool and experimental LPEs enabled
+ -DWITH_OPENMP="$(usex openmp ON OFF)" # Compile with OpenMP support
+# -DWITH_PROFILING # Turn on profiling
+ -DBUILD_SHARED_LIBS="$(usex !static-libs ON OFF)" # Compile libraries as shared and not static
+ -DENABLE_POPPLER=ON # Compile with support of libpoppler
+ -DENABLE_POPPLER_CAIRO=ON # Compile with support of libpoppler-cairo for rendering PDF preview (depends on ENABLE_POPPLER)
+ -DWITH_IMAGE_MAGICK="$(usex imagemagick ON OFF)" # Compile with support of ImageMagick for raster extensions and image import resolution (requires ImageMagick 6; set to OFF if you prefer GraphicsMagick)
+ -DWITH_GRAPHICS_MAGICK="$(usex graphicsmagick ON OFF)" # Compile with support of GraphicsMagick for raster extensions and image import resolution
+ -DWITH_LIBCDR="$(usex cdr ON OFF)" # Compile with support of libcdr for CorelDRAW Diagrams
+ -DWITH_LIBVISIO="$(usex visio ON OFF)" # Compile with support of libvisio for Microsoft Visio Diagrams
+ -DWITH_LIBWPG="$(usex wpg ON OFF)" # Compile with support of libwpg for WordPerfect Graphics
+ -DWITH_NLS="$(usex nls ON OFF)" # Compile with Native Language Support (using gettext)
+ -DWITH_JEMALLOC="$(usex jemalloc ON OFF)" # Compile with JEMALLOC support
+)
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name "*.la" -delete || die
+
+ # No extensions are present in beta1
+ if [ -n $(find "${ED%/}"/usr/share/${PN}/extensions -mindepth 1) ]; then
+ python_optimize "${ED%/}"/usr/share/${PN}/extensions
+ fi
+
+ cmake-utils_src_install
+}
+
+pkg_preinst() {
+ xdg_icon_savelist
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/media-gfx/inkscape/metadata.xml b/media-gfx/inkscape/metadata.xml
index 80bd107567a8..b7fc6b5e4782 100644
--- a/media-gfx/inkscape/metadata.xml
+++ b/media-gfx/inkscape/metadata.xml
@@ -10,6 +10,7 @@
<flag name="dia">pull in <pkg>app-office/dia</pkg> for dia import extension</flag>
<flag name="inkjar">Enable support for OpenOffice.org SVG jar files</flag>
<flag name="latex">pull in dependencies for LaTeX formulas</flag>
+ <flag name="svg2">Enable support for new SVG2 features</flag>
<flag name="visio">Enable support for Microsoft Visio Diagrams</flag>
<flag name="wpg">Enable support for WordPerfect Graphics</flag>
</use>