summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-10 19:56:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-10 20:14:46 +0200
commitba2af85078920c0523791faca18cb299626799af (patch)
treea5880a64eee60101599402fdcf2fa959e0fdeb4b /media-gfx/krita
parentprofiles/arch/riscv: remove media-libs/allegro[openal] USE mask (diff)
downloadgentoo-ba2af85078920c0523791faca18cb299626799af.tar.gz
gentoo-ba2af85078920c0523791faca18cb299626799af.tar.bz2
gentoo-ba2af85078920c0523791faca18cb299626799af.zip
media-gfx/krita: 4.4.7 version bump
See also: https://krita.org/en/item/krita-4-4-7-released/ Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/krita')
-rw-r--r--media-gfx/krita/Manifest1
-rw-r--r--media-gfx/krita/files/krita-4.4.5-pykrita-crash-on-exit.patch49
-rw-r--r--media-gfx/krita/files/krita-4.4.7-pykrita-crash-on-exit.patch41
-rw-r--r--media-gfx/krita/krita-4.4.5-r1.ebuild1
-rw-r--r--media-gfx/krita/krita-4.4.7.ebuild129
5 files changed, 185 insertions, 36 deletions
diff --git a/media-gfx/krita/Manifest b/media-gfx/krita/Manifest
index 25e381810199..15f1fd23ee2b 100644
--- a/media-gfx/krita/Manifest
+++ b/media-gfx/krita/Manifest
@@ -1,2 +1,3 @@
DIST krita-4.2.9-patchset.tar.xz 7928 BLAKE2B 57256884edafd528cfca529e020a226613a37682df445ece24d434e816f218d822c03d668a13806f775d02757bafd9627ed8073406e5506023767d06c78c30de SHA512 36ec902afec082fcf18c0e523a83a08aa54d54bd5393691b0f17dcab0969e69973d8e842fac44fcf66232f369b36f97937f67b5c0b0bdcff019cc1d323b3bf59
DIST krita-4.4.5.tar.gz 254879190 BLAKE2B 6eb12bba3ff2a5a6400eb7719faa3ffa1a4b1863e177aad0a737e13ce59dc53feb27083ccbeea51db6d69322871cc159eda5dff67e4daf1e7b4806edeb49adfc SHA512 9926e1cae7db2b89b8cd5f1e45631ff8cbf63cdbd367fc2f4b901a3f1d708dabaa6ac293a8f53b9ca67d7afc263ff51fe6f6b6a9a70017ee23fbf8aa2732abc4
+DIST krita-4.4.7.tar.gz 254871508 BLAKE2B c7e964ddec3fdf16db0644f6d61daa278b0fed2969bbcad99ca476240196ff4da3371af718049482ffe09e314bc96d40f28929fccb8cf0d3a9c98d7f20658695 SHA512 b1fbab9f69e700a1e9e562adfa1776c2de481a5dd92cee2a0ea533a0233a7277b512823023736784c41b387210a35c07cc23b3e2b3a89ed9cb60d440cc5906d5
diff --git a/media-gfx/krita/files/krita-4.4.5-pykrita-crash-on-exit.patch b/media-gfx/krita/files/krita-4.4.5-pykrita-crash-on-exit.patch
index 1939c962815e..12ebb2fa95a7 100644
--- a/media-gfx/krita/files/krita-4.4.5-pykrita-crash-on-exit.patch
+++ b/media-gfx/krita/files/krita-4.4.5-pykrita-crash-on-exit.patch
@@ -1,42 +1,18 @@
-From a0c29913114164ff3f2ba4e255ccee1c52cb3e86 Mon Sep 17 00:00:00 2001
-From: Alvin Wong <alvin@alvinhc.com>
-Date: Sat, 19 Jun 2021 16:29:45 +0800
-Subject: [PATCH] Fix PyKrita cleanup using qApp::aboutToQuit to prevent crash
+From 86a38621fbbf96edf489a0efd2b9c24c123e2051 Mon Sep 17 00:00:00 2001
+From: Dmitry Kazakov <dimula73@gmail.com>
+Date: Tue, 3 Aug 2021 11:57:33 +0300
+Subject: [PATCH] Disable finalizing of the PyQt to prevent crash on exit
-Suspecting that we can't have Python clean up its QObject's inside
-QCoreApplication's destructor, but must be done before it.
-
-BUG: 417465
-
-* asturm 2021-06-20: mangled w/ a6296beb25c98d9a4b5a136e0088959bf51d550a
+CCBUG:417465
---
- plugins/extensions/pykrita/plugin/plugin.cpp | 15 ++++++++++-----
- 1 file changed, 10 insertions(+), 5 deletions(-)
+ plugins/extensions/pykrita/plugin/plugin.cpp | 9 ++++-----
+ 1 file changed, 4 insertions(+), 5 deletions(-)
diff --git a/plugins/extensions/pykrita/plugin/plugin.cpp b/plugins/extensions/pykrita/plugin/plugin.cpp
-index ef0e27eb65..66f552b007 100644
+index 028798e2f4..cc06c07fbe 100644
--- a/plugins/extensions/pykrita/plugin/plugin.cpp
+++ b/plugins/extensions/pykrita/plugin/plugin.cpp
-@@ -13,6 +13,8 @@
- #include <kis_preference_set_registry.h>
- #include "pyqtpluginsettings.h"
-
-+#include <QCoreApplication>
-+
- #include <Krita.h>
-
- K_PLUGIN_FACTORY_WITH_JSON(KritaPyQtPluginFactory, "kritapykrita.json", registerPlugin<KritaPyQtPlugin>();)
-@@ -74,15 +76,18 @@ KritaPyQtPlugin::KritaPyQtPlugin(QObject *parent, const QVariantList &)
- Q_FOREACH (Extension *extension, Krita::instance()->extensions()) {
- extension->setup();
- }
-+
-+ // This ensures that QObject's owned by Python are destructed before
-+ // the destructor of QCoreApplication is called, in order to prevent
-+ // a crash on exit.
-+ // See https://bugs.kde.org/show_bug.cgi?id=417465
-+ connect(QCoreApplication::instance(), &QCoreApplication::aboutToQuit, this, []() { PyKrita::finalize(); });
- }
+@@ -89,11 +89,10 @@ KritaPyQtPlugin::KritaPyQtPlugin(QObject *parent, const QVariantList &)
KritaPyQtPlugin::~KritaPyQtPlugin()
{
@@ -45,11 +21,12 @@ index ef0e27eb65..66f552b007 100644
-#if QT_VERSION < QT_VERSION_CHECK(5,14,0)
- PyKrita::finalize();
-#endif
-+ // Don't call PyKrita::finalize here, because that can result in a crash
-+ // deep inside Qt.
++ /// XXX: Don't call PyKrita::finalize here, because that can result in a crash
++ /// deep inside Qt. See https://bugs.kde.org/show_bug.cgi?id=417465
++
++ // PyKrita::finalize();
}
#include "plugin.moc"
--
GitLab
-
diff --git a/media-gfx/krita/files/krita-4.4.7-pykrita-crash-on-exit.patch b/media-gfx/krita/files/krita-4.4.7-pykrita-crash-on-exit.patch
new file mode 100644
index 000000000000..f896a3920efc
--- /dev/null
+++ b/media-gfx/krita/files/krita-4.4.7-pykrita-crash-on-exit.patch
@@ -0,0 +1,41 @@
+From a0c29913114164ff3f2ba4e255ccee1c52cb3e86 Mon Sep 17 00:00:00 2001
+From: Alvin Wong <alvin@alvinhc.com>
+Date: Sat, 19 Jun 2021 16:29:45 +0800
+Subject: [PATCH] Fix PyKrita cleanup using qApp::aboutToQuit to prevent crash
+
+Suspecting that we can't have Python clean up its QObject's inside
+QCoreApplication's destructor, but must be done before it.
+
+BUG: 417465
+---
+ plugins/extensions/pykrita/plugin/plugin.cpp | 15 ++++++++++-----
+ 1 file changed, 10 insertions(+), 5 deletions(-)
+
+diff --git a/plugins/extensions/pykrita/plugin/plugin.cpp b/plugins/extensions/pykrita/plugin/plugin.cpp
+index ef0e27eb65..66f552b007 100644
+--- a/plugins/extensions/pykrita/plugin/plugin.cpp
++++ b/plugins/extensions/pykrita/plugin/plugin.cpp
+@@ -13,6 +13,8 @@
+ #include <kis_preference_set_registry.h>
+ #include "pyqtpluginsettings.h"
+
++#include <QCoreApplication>
++
+ #include <Krita.h>
+
+ K_PLUGIN_FACTORY_WITH_JSON(KritaPyQtPluginFactory, "kritapykrita.json", registerPlugin<KritaPyQtPlugin>();)
+@@ -74,6 +76,12 @@ KritaPyQtPlugin::KritaPyQtPlugin(QObject *parent, const QVariantList &)
+ Q_FOREACH (Extension *extension, Krita::instance()->extensions()) {
+ extension->setup();
+ }
++
++ // This ensures that QObject's owned by Python are destructed before
++ // the destructor of QCoreApplication is called, in order to prevent
++ // a crash on exit.
++ // See https://bugs.kde.org/show_bug.cgi?id=417465
++ connect(QCoreApplication::instance(), &QCoreApplication::aboutToQuit, this, []() { PyKrita::finalize(); });
+ }
+
+ KritaPyQtPlugin::~KritaPyQtPlugin()
+--
+GitLab
diff --git a/media-gfx/krita/krita-4.4.5-r1.ebuild b/media-gfx/krita/krita-4.4.5-r1.ebuild
index fe539d739267..5c4bd6209e5d 100644
--- a/media-gfx/krita/krita-4.4.5-r1.ebuild
+++ b/media-gfx/krita/krita-4.4.5-r1.ebuild
@@ -92,6 +92,7 @@ PATCHES=(
"${WORKDIR}"/${PN}-4.2.9-patchset/${PN}-4.2.9-ecm-findopenexr.patch
"${FILESDIR}"/${PN}-4.4.2-quazip1.patch
"${FILESDIR}"/${P}-pykrita-crash-on-exit.patch # KDE-Bug #417465
+ "${FILESDIR}"/${PN}-4.4.7-pykrita-crash-on-exit.patch # git master
)
pkg_setup() {
diff --git a/media-gfx/krita/krita-4.4.7.ebuild b/media-gfx/krita/krita-4.4.7.ebuild
new file mode 100644
index 000000000000..c80ed32f9980
--- /dev/null
+++ b/media-gfx/krita/krita-4.4.7.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+PYTHON_COMPAT=( python3_{8,9,10} )
+KFMIN=5.74.0
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org python-single-r1
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.gz
+ https://dev.gentoo.org/~asturm/distfiles/${PN}-4.2.9-patchset.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Free digital painting application. Digital Painting, Creative Freedom!"
+HOMEPAGE="https://apps.kde.org/krita/ https://krita.org/en/"
+
+LICENSE="GPL-3"
+SLOT="5"
+IUSE="color-management fftw gif +gsl heif +jpeg openexr pdf qtmedia +raw tiff vc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# bug 630508
+RESTRICT+=" test"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/boost:=
+ dev-libs/quazip:0=
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/sip:=[${PYTHON_USEDEP}]
+ ')
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[-gles2-only]
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ media-gfx/exiv2:=
+ media-libs/lcms
+ media-libs/libpng:0=
+ sys-libs/zlib
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXi
+ color-management? ( =media-libs/opencolorio-1* )
+ fftw? ( sci-libs/fftw:3.0= )
+ gif? ( media-libs/giflib )
+ gsl? ( sci-libs/gsl:= )
+ jpeg? ( virtual/jpeg:0 )
+ heif? ( media-libs/libheif:= )
+ openexr? (
+ media-libs/ilmbase:=
+ <media-libs/openexr-3.0.0:0=
+ )
+ pdf? ( app-text/poppler[qt5] )
+ qtmedia? ( >=dev-qt/qtmultimedia-${QTMIN}:5 )
+ raw? ( media-libs/libraw:= )
+ tiff? ( media-libs/tiff:0 )
+"
+DEPEND="${RDEPEND}
+ vc? ( >=dev-libs/vc-1.1.0 )
+"
+BDEPEND="
+ dev-cpp/eigen:3
+ dev-lang/perl
+ sys-devel/gettext
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.1-tests-optional.patch
+ "${WORKDIR}"/${PN}-4.2.9-patchset/${PN}-4.2.9-ecm-findopenexr.patch
+ "${FILESDIR}"/${PN}-4.4.2-quazip1.patch
+ "${FILESDIR}"/${P}-pykrita-crash-on-exit.patch # KDE-Bug #417465, git master
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ ecm_pkg_setup
+}
+
+src_prepare() {
+ ecm_src_prepare
+ sed -e "/CMAKE_CXX_STANDARD/s/11/14/" -i CMakeLists.txt || die
+}
+
+src_configure() {
+ # Prevent sandbox violation from FindPyQt5.py module
+ # See Gentoo-bug 655918
+ addpredict /dev/dri
+
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_KSeExpr=ON # not packaged
+ $(cmake_use_find_package color-management OCIO)
+ $(cmake_use_find_package fftw FFTW3)
+ $(cmake_use_find_package gif GIF)
+ $(cmake_use_find_package gsl GSL)
+ $(cmake_use_find_package heif HEIF)
+ $(cmake_use_find_package jpeg JPEG)
+ $(cmake_use_find_package openexr OpenEXR)
+ $(cmake_use_find_package pdf Poppler)
+ $(cmake_use_find_package qtmedia Qt5Multimedia)
+ $(cmake_use_find_package raw LibRaw)
+ $(cmake_use_find_package tiff TIFF)
+ $(cmake_use_find_package vc Vc)
+ )
+
+ ecm_src_configure
+}