summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-31 11:06:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-31 11:45:23 +0200
commitf3086ea525167697941c8a3edc8f0c0480679e6c (patch)
treed0253290b4a7306c2b50db90cd46adeb576a8439 /media-gfx/krita
parentnet-libs/miniupnpc: s390 stable wrt bug #690886 (diff)
downloadgentoo-f3086ea525167697941c8a3edc8f0c0480679e6c.tar.gz
gentoo-f3086ea525167697941c8a3edc8f0c0480679e6c.tar.bz2
gentoo-f3086ea525167697941c8a3edc8f0c0480679e6c.zip
media-gfx/krita: 4.2.4 version bump
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/krita')
-rw-r--r--media-gfx/krita/Manifest1
-rw-r--r--media-gfx/krita/files/krita-4.2.4-tests-optional.patch399
-rw-r--r--media-gfx/krita/krita-4.2.4.ebuild117
3 files changed, 517 insertions, 0 deletions
diff --git a/media-gfx/krita/Manifest b/media-gfx/krita/Manifest
index 2f9aa5dd8df2..8865613c448c 100644
--- a/media-gfx/krita/Manifest
+++ b/media-gfx/krita/Manifest
@@ -1,2 +1,3 @@
DIST krita-4.1.8.tar.gz 244065767 BLAKE2B ba2cbb6d1575cec189e8f10461b720a081f185e1e078fc1e8194c9e6d455dade45f35f1ae5a891717918b3c03863a2a7f3f819753a106ede5695003cfa260157 SHA512 d027444415bffbd6abd29ca69598fdb1e6a652fd4f1944092ff12016a57ff2ee3bab209c93e065905ec9bfea395e50f833915bb924b97a2c119d101057cba6c9
DIST krita-4.2.3.tar.gz 246136588 BLAKE2B 1d7a371f7aeb8cf3747adcd4ab681b0ecf849e64ace16b456e9c2b8ed5fd958be895fd64c623931e47ae81bdf35b3e54161ecb204501f48c97b35ac2dcb8ac59 SHA512 6493740183b360a939d85cc7bc646cb173dc923a3dc63966d0f178bf308675ffead01d3bfefeeffb376f5efd7d90ee7f271b3ff412787123113dd125cc022ab5
+DIST krita-4.2.4.tar.gz 246227960 BLAKE2B 94513a835526ee79c0747ed8c6004666b549d7070c02ad82800555282f319e5aa4dc1f35dafc6b4179284b244c8c80367b453548f5c8cd585154259a0512222a SHA512 c778653f8e72724d16322405fffdff5b82418c5a19021ccbada6a15389afd58f9d9017bc562eb5d91b0d4e10587bca1e616fc7ecc9ec7dbf82fae5247b81ea5e
diff --git a/media-gfx/krita/files/krita-4.2.4-tests-optional.patch b/media-gfx/krita/files/krita-4.2.4-tests-optional.patch
new file mode 100644
index 000000000000..2f13c999b67e
--- /dev/null
+++ b/media-gfx/krita/files/krita-4.2.4-tests-optional.patch
@@ -0,0 +1,399 @@
+--- a/plugins/filters/CMakeLists.txt 2019-07-31 11:22:19.572862843 +0200
++++ b/plugins/filters/CMakeLists.txt 2019-07-31 11:22:19.576862870 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+ add_subdirectory( blur )
+ add_subdirectory( colors )
+ add_subdirectory( colorsfilters )
+--- a/plugins/filters/unsharp/CMakeLists.txt 2019-07-31 11:22:19.582862912 +0200
++++ b/plugins/filters/unsharp/CMakeLists.txt 2019-07-31 11:22:19.587862947 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ set(kritaunsharpfilter_SOURCES
+ unsharp.cpp
+--- a/plugins/paintops/defaultpaintops/CMakeLists.txt 2019-07-31 11:22:19.592862983 +0200
++++ b/plugins/paintops/defaultpaintops/CMakeLists.txt 2019-07-31 11:22:19.595863003 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(brush/tests)
++endif()
+
+ include_directories(brush
+ duplicate
+--- a/plugins/paintops/libpaintop/CMakeLists.txt 2019-07-31 11:22:19.600863038 +0200
++++ b/plugins/paintops/libpaintop/CMakeLists.txt 2019-07-31 11:22:19.603863060 +0200
+@@ -104,4 +104,6 @@
+ install(TARGETS kritalibpaintop ${INSTALL_TARGETS_DEFAULT_ARGS})
+
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/plugins/dockers/lut/CMakeLists.txt 2019-07-31 11:22:19.608863094 +0200
++++ b/plugins/dockers/lut/CMakeLists.txt 2019-07-31 11:22:19.613863129 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ include_directories(SYSTEM
+ ${OCIO_INCLUDE_DIR}
+--- a/plugins/dockers/animation/CMakeLists.txt 2019-07-31 11:22:19.619863171 +0200
++++ b/plugins/dockers/animation/CMakeLists.txt 2019-07-31 11:22:19.624863206 +0200
+@@ -1,5 +1,7 @@
+ if (NOT WIN32 AND NOT APPLE)
+- add_subdirectory(tests)
++ if(BUILD_TESTING)
++add_subdirectory(tests)
++endif()
+ endif()
+
+ set(KRITA_ANIMATIONDOCKER_SOURCES
+--- a/plugins/extensions/qmic/CMakeLists.txt 2019-07-31 11:22:19.630863248 +0200
++++ b/plugins/extensions/qmic/CMakeLists.txt 2019-07-31 11:22:19.635863283 +0200
+@@ -20,4 +20,6 @@
+ target_link_libraries(kritaqmic kritaui)
+ install(TARGETS kritaqmic DESTINATION ${KRITA_PLUGIN_INSTALL_DIR})
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/plugins/tools/basictools/CMakeLists.txt 2019-07-31 11:22:19.641863325 +0200
++++ b/plugins/tools/basictools/CMakeLists.txt 2019-07-31 11:22:19.645863353 +0200
+@@ -1,5 +1,7 @@
+ if (NOT APPLE)
+- add_subdirectory(tests)
++ if(BUILD_TESTING)
++add_subdirectory(tests)
++endif()
+ endif ()
+
+ set(kritadefaulttools_SOURCES
+--- a/plugins/tools/tool_transform2/CMakeLists.txt 2019-07-31 11:22:19.650863388 +0200
++++ b/plugins/tools/tool_transform2/CMakeLists.txt 2019-07-31 11:22:19.653863409 +0200
+@@ -1,5 +1,7 @@
+ if (NOT WIN32 AND NOT APPLE)
+- add_subdirectory(tests)
++ if(BUILD_TESTING)
++add_subdirectory(tests)
++endif()
+ endif()
+
+ set(kritatooltransform_SOURCES
+--- a/plugins/impex/svg/CMakeLists.txt 2019-07-31 11:22:19.658863444 +0200
++++ b/plugins/impex/svg/CMakeLists.txt 2019-07-31 11:22:19.662863472 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritasvgimport_SOURCES
+ kis_svg_import.cc
+--- a/plugins/impex/brush/CMakeLists.txt 2019-07-31 11:22:19.668863514 +0200
++++ b/plugins/impex/brush/CMakeLists.txt 2019-07-31 11:22:19.672863542 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritabrushexport_PART_SRCS
+ kis_brush_export.cpp
+--- a/plugins/impex/psd/CMakeLists.txt 2019-07-31 11:22:19.678863584 +0200
++++ b/plugins/impex/psd/CMakeLists.txt 2019-07-31 11:22:19.684863626 +0200
+@@ -1,5 +1,7 @@
+ if (NOT MSVC AND NOT APPLE)
+- add_subdirectory(tests)
++ if(BUILD_TESTING)
++add_subdirectory(tests)
++endif()
+ endif()
+
+ configure_file(config_psd.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config_psd.h)
+--- a/plugins/impex/tga/CMakeLists.txt 2019-07-31 11:22:19.690863668 +0200
++++ b/plugins/impex/tga/CMakeLists.txt 2019-07-31 11:22:19.695863703 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritatgaexport_SOURCES
+ kis_tga_export.cpp
+--- a/plugins/impex/libkra/CMakeLists.txt 2019-07-31 11:22:19.700863738 +0200
++++ b/plugins/impex/libkra/CMakeLists.txt 2019-07-31 11:22:19.704863766 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritalibkra_LIB_SRCS
+ kis_colorize_dom_utils.cpp
+--- a/plugins/impex/jpeg/CMakeLists.txt 2019-07-31 11:22:19.709863801 +0200
++++ b/plugins/impex/jpeg/CMakeLists.txt 2019-07-31 11:22:19.713863829 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(ICCJPEG_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/lcms")
+
+--- a/plugins/impex/gif/CMakeLists.txt 2019-07-31 11:22:19.720863878 +0200
++++ b/plugins/impex/gif/CMakeLists.txt 2019-07-31 11:22:19.726863920 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritagifexport_SOURCES
+ kis_gif_export.cpp
+--- a/plugins/impex/exr/CMakeLists.txt 2019-07-31 11:22:19.732863962 +0200
++++ b/plugins/impex/exr/CMakeLists.txt 2019-07-31 11:22:19.736863990 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ include_directories(SYSTEM ${OPENEXR_INCLUDE_DIR} )
+
+--- a/plugins/impex/xcf/CMakeLists.txt 2019-07-31 11:22:19.740864018 +0200
++++ b/plugins/impex/xcf/CMakeLists.txt 2019-07-31 11:22:19.744864046 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(XCFTOOLS_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/xcftools")
+
+--- a/plugins/impex/tiff/CMakeLists.txt 2019-07-31 11:22:19.750864088 +0200
++++ b/plugins/impex/tiff/CMakeLists.txt 2019-07-31 11:22:19.755864123 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(libkritatiffconverter_LIB_SRCS
+ kis_tiff_converter.cc
+--- a/plugins/impex/ora/CMakeLists.txt 2019-07-31 11:22:19.762864172 +0200
++++ b/plugins/impex/ora/CMakeLists.txt 2019-07-31 11:22:19.767864207 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(libkritaconverter_LIB_SRCS
+ ora_converter.cpp
+--- a/plugins/impex/heif/CMakeLists.txt 2019-07-31 11:22:19.774864256 +0200
++++ b/plugins/impex/heif/CMakeLists.txt 2019-07-31 11:22:19.778864284 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${HEIF_CFLAGS}")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${HEIF_CFLAGS}")
+--- a/plugins/impex/pdf/CMakeLists.txt 2019-07-31 11:22:19.783864319 +0200
++++ b/plugins/impex/pdf/CMakeLists.txt 2019-07-31 11:22:19.788864354 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritapdfimport_SOURCES kis_pdf_import.cpp kis_pdf_import_widget.cpp )
+
+--- a/plugins/impex/csv/CMakeLists.txt 2019-07-31 11:22:19.796864410 +0200
++++ b/plugins/impex/csv/CMakeLists.txt 2019-07-31 11:22:19.803864459 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ # import
+
+--- a/plugins/impex/heightmap/CMakeLists.txt 2019-07-31 11:22:19.810864508 +0200
++++ b/plugins/impex/heightmap/CMakeLists.txt 2019-07-31 11:22:19.819864571 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ include_directories( ${CMAKE_CURRENT_SOURCE_DIR} )
+
+--- a/plugins/impex/raw/CMakeLists.txt 2019-07-31 11:22:19.826864620 +0200
++++ b/plugins/impex/raw/CMakeLists.txt 2019-07-31 11:22:19.830864648 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ if(OPENEXR_FOUND)
+ include_directories(${OPENEXR_INCLUDE_DIR})
+--- a/plugins/impex/qimageio/CMakeLists.txt 2019-07-31 11:22:19.837864697 +0200
++++ b/plugins/impex/qimageio/CMakeLists.txt 2019-07-31 11:22:19.844864746 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritaqimageioexport_SOURCES
+ kis_qimageio_export.cpp
+--- a/plugins/impex/qml/CMakeLists.txt 2019-07-31 11:22:19.851864795 +0200
++++ b/plugins/impex/qml/CMakeLists.txt 2019-07-31 11:22:19.856864830 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritaqmlexport_SOURCES
+ qml_converter.cc
+--- a/plugins/impex/png/CMakeLists.txt 2019-07-31 11:22:19.862864872 +0200
++++ b/plugins/impex/png/CMakeLists.txt 2019-07-31 11:22:19.867864907 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritapngimport_SOURCES
+ kis_png_import.cc
+--- a/plugins/color/lcms2engine/CMakeLists.txt 2019-07-31 11:22:19.872864942 +0200
++++ b/plugins/color/lcms2engine/CMakeLists.txt 2019-07-31 11:22:19.876864969 +0200
+@@ -1,6 +1,8 @@
+ project( lcmsengine )
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ include_directories(SYSTEM
+ ${LCMS2_INCLUDE_DIR}
+--- a/libs/brush/CMakeLists.txt 2019-07-31 11:22:19.881865005 +0200
++++ b/libs/brush/CMakeLists.txt 2019-07-31 11:22:19.885865033 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ include_directories(SYSTEM
+ ${EIGEN3_INCLUDE_DIR}
+--- a/libs/global/CMakeLists.txt 2019-07-31 11:22:19.890865068 +0200
++++ b/libs/global/CMakeLists.txt 2019-07-31 11:22:19.896865110 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ include(CheckFunctionExists)
+ check_function_exists(backtrace HAVE_BACKTRACE)
+--- a/libs/image/CMakeLists.txt 2019-07-31 11:22:19.902865151 +0200
++++ b/libs/image/CMakeLists.txt 2019-07-31 11:22:19.908865194 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ add_subdirectory( tiles3 )
+
+--- a/libs/image/tiles3/CMakeLists.txt 2019-07-31 11:22:19.913865228 +0200
++++ b/libs/image/tiles3/CMakeLists.txt 2019-07-31 11:22:19.917865256 +0200
+@@ -1 +1,3 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/libs/odf/CMakeLists.txt 2019-07-31 11:22:19.922865291 +0200
++++ b/libs/odf/CMakeLists.txt 2019-07-31 11:22:19.926865319 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ set(kritaodf_LIB_SRCS
+ KoOdf.cpp
+--- a/libs/metadata/CMakeLists.txt 2019-07-31 11:22:19.930865347 +0200
++++ b/libs/metadata/CMakeLists.txt 2019-07-31 11:22:19.934865376 +0200
+@@ -29,4 +29,6 @@
+
+ install(TARGETS kritametadata ${INSTALL_TARGETS_DEFAULT_ARGS})
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/libs/store/CMakeLists.txt 2019-07-31 11:22:19.940865418 +0200
++++ b/libs/store/CMakeLists.txt 2019-07-31 11:22:19.944865445 +0200
+@@ -1,6 +1,8 @@
+ include_directories(${QUAZIP_INCLUDE_DIRS})
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritastore_LIB_SRCS
+ KoDirectoryStore.cpp
+--- a/libs/libkis/CMakeLists.txt 2019-07-31 11:22:19.951865495 +0200
++++ b/libs/libkis/CMakeLists.txt 2019-07-31 11:22:19.958865544 +0200
+@@ -47,4 +47,6 @@
+ install(TARGETS kritalibkis ${INSTALL_TARGETS_DEFAULT_ARGS})
+
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/libs/widgetutils/CMakeLists.txt 2019-07-31 11:22:19.968865614 +0200
++++ b/libs/widgetutils/CMakeLists.txt 2019-07-31 11:22:19.981865705 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ configure_file(xmlgui/config-xmlgui.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-xmlgui.h )
+
+--- a/libs/widgets/CMakeLists.txt 2019-07-31 11:22:19.992865782 +0200
++++ b/libs/widgets/CMakeLists.txt 2019-07-31 11:22:20.000865837 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
+--- a/libs/flake/CMakeLists.txt 2019-07-31 11:22:20.010865908 +0200
++++ b/libs/flake/CMakeLists.txt 2019-07-31 11:22:20.017865956 +0200
+@@ -9,8 +9,12 @@
+ )
+
+ add_subdirectory(styles)
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
++if(BUILD_TESTING)
+ add_subdirectory(resources/tests)
++endif()
+
+ set(kritaflake_SRCS
+ KoGradientHelper.cpp
+--- a/libs/ui/CMakeLists.txt 2019-07-31 11:22:20.029866040 +0200
++++ b/libs/ui/CMakeLists.txt 2019-07-31 11:22:20.039866111 +0200
+@@ -7,7 +7,9 @@
+ ${OCIO_INCLUDE_DIR}
+ )
+
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ if (APPLE)
+ find_library(FOUNDATION_LIBRARY Foundation)
+--- a/libs/pigment/CMakeLists.txt 2019-07-31 11:22:20.050866188 +0200
++++ b/libs/pigment/CMakeLists.txt 2019-07-31 11:22:20.057866236 +0200
+@@ -31,7 +31,9 @@
+ message("${__per_arch_factory_objs}")
+ endif()
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+ add_subdirectory(benchmarks)
+
+ set(kritapigment_SRCS
diff --git a/media-gfx/krita/krita-4.2.4.ebuild b/media-gfx/krita/krita-4.2.4.ebuild
new file mode 100644
index 000000000000..62966b4d812b
--- /dev/null
+++ b/media-gfx/krita/krita-4.2.4.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit kde5 python-single-r1
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Free digital painting application. Digital Painting, Creative Freedom!"
+HOMEPAGE="https://kde.org/applications/graphics/krita/ https://krita.org/"
+LICENSE="GPL-3"
+IUSE="color-management fftw gif +gsl heif +jpeg openexr pdf qtmedia +raw tiff vc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ dev-cpp/eigen:3
+ dev-lang/perl
+ sys-devel/gettext
+"
+COMMON_DEPEND="${PYTHON_DEPS}
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui '-gles2' '' '5=')
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ $(add_qt_dep qtxml)
+ dev-libs/boost:=
+ dev-libs/quazip
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/sip[${PYTHON_USEDEP}]
+ media-gfx/exiv2:=
+ media-libs/lcms
+ media-libs/libpng:0=
+ sys-libs/zlib
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXi
+ color-management? ( media-libs/opencolorio )
+ fftw? ( sci-libs/fftw:3.0= )
+ gif? ( media-libs/giflib )
+ gsl? ( sci-libs/gsl:= )
+ jpeg? ( virtual/jpeg:0 )
+ heif? ( media-libs/libheif:= )
+ openexr? (
+ media-libs/ilmbase:=
+ media-libs/openexr
+ )
+ pdf? ( app-text/poppler[qt5] )
+ qtmedia? ( $(add_qt_dep qtmultimedia) )
+ raw? ( media-libs/libraw:= )
+ tiff? ( media-libs/tiff:0 )
+"
+DEPEND="${COMMON_DEPEND}
+ vc? ( >=dev-libs/vc-1.1.0 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !app-office/calligra:4[calligra_features_krita]
+ !app-office/calligra-l10n:4[calligra_features_krita(+)]
+"
+
+# bug 630508
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}"/${P}-tests-optional.patch )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde5_pkg_setup
+}
+
+src_configure() {
+ # Prevent sandbox violation from FindPyQt5.py module
+ # See Gentoo-bug 655918
+ addpredict /dev/dri
+
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package color-management OCIO)
+ $(cmake-utils_use_find_package fftw FFTW3)
+ $(cmake-utils_use_find_package gif GIF)
+ $(cmake-utils_use_find_package gsl GSL)
+ $(cmake-utils_use_find_package heif HEIF)
+ $(cmake-utils_use_find_package jpeg JPEG)
+ $(cmake-utils_use_find_package openexr OpenEXR)
+ $(cmake-utils_use_find_package pdf Poppler)
+ $(cmake-utils_use_find_package qtmedia Qt5Multimedia)
+ $(cmake-utils_use_find_package raw LibRaw)
+ $(cmake-utils_use_find_package tiff TIFF)
+ $(cmake-utils_use_find_package vc Vc)
+ )
+
+ kde5_src_configure
+}