summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2022-01-23 18:57:28 +0100
committerStephan Hartmann <sultan@gentoo.org>2022-01-23 18:58:01 +0100
commit3edc3889c88ec28a48c6d3a474705dac18f875eb (patch)
tree54c4a520dd4d130baa0fbf747e8dacaa686bc7a9 /media-gfx/nomacs
parentwww-servers/lighttpd: fix configure arguments for 1.4.64 (diff)
downloadgentoo-3edc3889c88ec28a48c6d3a474705dac18f875eb.tar.gz
gentoo-3edc3889c88ec28a48c6d3a474705dac18f875eb.tar.bz2
gentoo-3edc3889c88ec28a48c6d3a474705dac18f875eb.zip
media-gfx/nomacs: fix build error due to missing include
Closes: https://bugs.gentoo.org/775620 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
Diffstat (limited to 'media-gfx/nomacs')
-rw-r--r--media-gfx/nomacs/files/nomacs-3.16.224-DkMath-ostream.patch24
-rw-r--r--media-gfx/nomacs/nomacs-3.16.224-r2.ebuild7
2 files changed, 29 insertions, 2 deletions
diff --git a/media-gfx/nomacs/files/nomacs-3.16.224-DkMath-ostream.patch b/media-gfx/nomacs/files/nomacs-3.16.224-DkMath-ostream.patch
new file mode 100644
index 000000000000..318953f7896a
--- /dev/null
+++ b/media-gfx/nomacs/files/nomacs-3.16.224-DkMath-ostream.patch
@@ -0,0 +1,24 @@
+From aca8443079ff926be873a77e3077b249a12487dd Mon Sep 17 00:00:00 2001
+From: Stephan Hartmann <sultan@gentoo.org>
+Date: Sun, 23 Jan 2022 18:51:56 +0100
+Subject: [PATCH] IWYU: add missing ostream in DkMath
+
+---
+ src/DkCore/DkMath.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/DkCore/DkMath.h b/src/DkCore/DkMath.h
+index c37ef23..2c3a5be 100644
+--- a/src/DkCore/DkMath.h
++++ b/src/DkCore/DkMath.h
+@@ -30,6 +30,7 @@
+ #pragma warning(push, 0) // no warnings from includes - begin
+ #include <cmath>
+ #include <float.h>
++#include <ostream>
+ #include <QDebug>
+ #include <QPointF>
+ #include <QPolygonF>
+--
+2.34.1
+
diff --git a/media-gfx/nomacs/nomacs-3.16.224-r2.ebuild b/media-gfx/nomacs/nomacs-3.16.224-r2.ebuild
index bab73e326784..0102090380d2 100644
--- a/media-gfx/nomacs/nomacs-3.16.224-r2.ebuild
+++ b/media-gfx/nomacs/nomacs-3.16.224-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -48,7 +48,10 @@ S="${WORKDIR}/${P}/ImageLounge"
DOCS=( src/changelog.txt )
-PATCHES=( "${FILESDIR}"/${P}-quazip1.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-quazip1.patch
+ "${FILESDIR}"/${P}-DkMath-ostream.patch
+)
src_prepare() {
if use plugins ; then