summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-12-31 19:36:33 +0100
committerSebastian Pipping <sping@gentoo.org>2017-12-31 19:38:53 +0100
commitd9aaca6c5dba4f10b301c1dc9c7bf2eacc5013cc (patch)
treeaca19b19ae2dacffd16a3e8eb0ba1cbbe1d22a97 /media-gfx/optipng
parentapp-misc/dvtm: Do not strip (bug #565322). Drop obsolete sed scripts. Fix bui... (diff)
downloadgentoo-d9aaca6c5dba4f10b301c1dc9c7bf2eacc5013cc.tar.gz
gentoo-d9aaca6c5dba4f10b301c1dc9c7bf2eacc5013cc.tar.bz2
gentoo-d9aaca6c5dba4f10b301c1dc9c7bf2eacc5013cc.zip
media-gfx/optipng: 0.7.7
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'media-gfx/optipng')
-rw-r--r--media-gfx/optipng/Manifest1
-rw-r--r--media-gfx/optipng/optipng-0.7.7.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/media-gfx/optipng/Manifest b/media-gfx/optipng/Manifest
index 46b54ad34d56..d0cdec1451f0 100644
--- a/media-gfx/optipng/Manifest
+++ b/media-gfx/optipng/Manifest
@@ -1 +1,2 @@
DIST optipng-0.7.6.tar.gz 2202237 BLAKE2B f113027ff12f2fc97bd4dc43b8e62f5af8f86e251b43c0f86ffbd59366b329d1fc2a58103aa349cb18fb0c9d2e5f051517439c02aeb44ee435c6fff0c75efb7a SHA512 d31d7494c23413d87b601a706cc2faf82923156a818da66e0bfad11741aed065db8f1b0c088d2abd66899ac192408c05f594295ded2684c4549c5f03b140a184
+DIST optipng-0.7.7.tar.gz 2329555 BLAKE2B af3e1c806522282ccbf9325c0b49f61a30d24b8e2db2dd8ec316a312d0dea595cbb6e8b5b38ef5ea90f1efe14244b81f85f88e11e7334fdd4b91b43b6dae8e7d SHA512 c33b7650143ab39944d2c066e07e10273c37024c5bfe7c00475bfb513af96afa081ff388164845d426d3bce624c0282dee574fa150e963f18d3683d821030280
diff --git a/media-gfx/optipng/optipng-0.7.7.ebuild b/media-gfx/optipng/optipng-0.7.7.ebuild
new file mode 100644
index 000000000000..3880a888ddf3
--- /dev/null
+++ b/media-gfx/optipng/optipng-0.7.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Compress PNG files without affecting image quality"
+HOMEPAGE="http://optipng.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/zlib
+ media-libs/libpng:0="
+DEPEND="${RDEPEND}
+ sys-apps/findutils"
+
+DOCS=( AUTHORS.txt README.txt )
+
+src_prepare() {
+ rm -R src/{libpng,zlib} || die
+ find . -type d -name build -exec rm -R {} + || die
+
+ # next release is almost a complete rewrite, so plug this compilation
+ # problem in anticipation of the much (c)leaner(?) rewrite
+ sed -i \
+ -e 's/^#if defined AT_FDCWD/#if (defined(AT_FDCWD) \&\& !(defined(__SVR4) \&\& defined(__sun)))/' \
+ src/optipng/ioutil.c || die
+
+ tc-export CC AR RANLIB
+ export LD=$(tc-getCC)
+
+ eapply_user
+}
+
+src_configure() {
+ ./configure \
+ -with-system-libpng \
+ -with-system-zlib \
+ || die "configure failed"
+}
+
+src_compile() {
+ emake -C src/optipng
+}
+
+src_install() {
+ einstalldocs
+
+ dodoc doc/*.txt
+ docinto html
+ dodoc doc/*.html
+ doman src/${PN}/man/${PN}.1
+
+ dobin src/${PN}/${PN}
+}