summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/plantuml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/plantuml')
-rw-r--r--media-gfx/plantuml/Manifest1
-rw-r--r--media-gfx/plantuml/metadata.xml22
-rw-r--r--media-gfx/plantuml/plantuml-7999.ebuild35
3 files changed, 58 insertions, 0 deletions
diff --git a/media-gfx/plantuml/Manifest b/media-gfx/plantuml/Manifest
new file mode 100644
index 000000000000..bb0b9cc3efc2
--- /dev/null
+++ b/media-gfx/plantuml/Manifest
@@ -0,0 +1 @@
+DIST plantuml-7999.tar.gz 977426 SHA256 9d080cb0d888c0889a8a15b7163f478d426082f05e24d70069f7d5aef51db313 SHA512 e54af0ef7cf593939c82d7a2a6260d3d776a98684c1a8553813ea4e7bdfae43a3ece9d2358fe16121b5ff0173ec7eae3270cd5239d8b8b3b51b57605bbc34d46 WHIRLPOOL 89c09036d35467a622b400f1979056f61b9f7c5217f5e93f0b537399e40cd0af3001a9f6240eb880656c3dcd76cc470ea38ccfd7594f7a9106bc29e6e5a15ed8
diff --git a/media-gfx/plantuml/metadata.xml b/media-gfx/plantuml/metadata.xml
new file mode 100644
index 000000000000..cbdad507dd9f
--- /dev/null
+++ b/media-gfx/plantuml/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pva@gentoo.org</email>
+ <name>Peter Volkov</name>
+ </maintainer>
+ <herd>java</herd>
+ <longdescription lang="en">
+ PlantUMLis a component that allows to quickly write: sequence diagram, use
+ case diagram, class diagram, activity diagram, component diagram, state
+ diagram, object diagram and wireframe graphical interface.
+
+ Diagrams are defined in a text file using a simple and intuitive language.
+ This can be used within many other tools. Images can be generated in PNG
+ or SVG format. It is also possible to generate ASCII art diagrams (only for
+ sequence diagrams).
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">plantuml</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-gfx/plantuml/plantuml-7999.ebuild b/media-gfx/plantuml/plantuml-7999.ebuild
new file mode 100644
index 000000000000..8623cdb97282
--- /dev/null
+++ b/media-gfx/plantuml/plantuml-7999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="PlantUML is used to draw UML diagram, using a simple and human readable text description"
+HOMEPAGE="http://plantuml.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=virtual/jdk-1.6
+"
+RDEPEND="
+ >=virtual/jre-1.6
+ >=media-gfx/graphviz-2.26.3
+"
+
+EANT_BUILD_TARGET="dist"
+EANT_GENTOO_CLASSPATH="ant-core"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+ use source && java-pkg_dosrc src/*
+}