summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-15 21:02:04 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-15 21:16:30 +0100
commit54bde0d76f9295685225547a1e05d037fb5543e2 (patch)
tree679fd977da7450c82ea05f681a17c93b6c5005fa /media-gfx/rawtherapee
parentdev-cpp/gstreamermm: Drop old (diff)
downloadgentoo-54bde0d76f9295685225547a1e05d037fb5543e2.tar.gz
gentoo-54bde0d76f9295685225547a1e05d037fb5543e2.tar.bz2
gentoo-54bde0d76f9295685225547a1e05d037fb5543e2.zip
media-gfx/rawtherapee: Fix building with latest glibmm/libsigc++ (#568136)
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-gfx/rawtherapee')
-rw-r--r--media-gfx/rawtherapee/files/rawtherapee-4.2-cxx11.patch27
-rw-r--r--media-gfx/rawtherapee/rawtherapee-4.2.ebuild4
2 files changed, 31 insertions, 0 deletions
diff --git a/media-gfx/rawtherapee/files/rawtherapee-4.2-cxx11.patch b/media-gfx/rawtherapee/files/rawtherapee-4.2-cxx11.patch
new file mode 100644
index 000000000000..48acb5fc6ffd
--- /dev/null
+++ b/media-gfx/rawtherapee/files/rawtherapee-4.2-cxx11.patch
@@ -0,0 +1,27 @@
+From 39ef59ddeb7679c71274b1da3faadd395b650c73 Mon Sep 17 00:00:00 2001
+From: Adam Reichold <adam.reichold@t-online.de>
+Date: Sun, 29 Nov 2015 11:48:30 +0100
+Subject: [PATCH] Build with '-std=c++11' if libsigc++ version 2.5.1 is used as
+ it does require it.
+
+---
+ CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index dd5fcbc..6153484 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -278,10 +278,10 @@ if (OPTION_OMP)
+ endif (OPENMP_FOUND)
+ endif (OPTION_OMP)
+
+-if(USE_EXPERIMENTAL_LANG_VERSIONS)
++if(USE_EXPERIMENTAL_LANG_VERSIONS OR NOT (SIGC_VERSION VERSION_LESS 2.5.1))
+ SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu1x")
+ SET (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=gnu++0x")
+-endif (USE_EXPERIMENTAL_LANG_VERSIONS)
++endif ()
+
+ # find out whether we are building out of source
+ get_filename_component(ABS_SOURCE_DIR "${PROJECT_SOURCE_DIR}" ABSOLUTE)
diff --git a/media-gfx/rawtherapee/rawtherapee-4.2.ebuild b/media-gfx/rawtherapee/rawtherapee-4.2.ebuild
index 6ae07a579609..6702661a6527 100644
--- a/media-gfx/rawtherapee/rawtherapee-4.2.ebuild
+++ b/media-gfx/rawtherapee/rawtherapee-4.2.ebuild
@@ -33,6 +33,10 @@ DEPEND="${RDEPEND}
app-arch/xz-utils
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${P}-cxx11.patch # Upstream patch for fixing bug #568136
+)
+
pkg_pretend() {
if use openmp ; then
tc-has-openmp || die "Please switch to an openmp compatible compiler"