summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/tuxpaint/files/tuxpaint-0.9.20-gentoo.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/tuxpaint/files/tuxpaint-0.9.20-gentoo.patch')
-rw-r--r--media-gfx/tuxpaint/files/tuxpaint-0.9.20-gentoo.patch136
1 files changed, 136 insertions, 0 deletions
diff --git a/media-gfx/tuxpaint/files/tuxpaint-0.9.20-gentoo.patch b/media-gfx/tuxpaint/files/tuxpaint-0.9.20-gentoo.patch
new file mode 100644
index 000000000000..00af3cb2a867
--- /dev/null
+++ b/media-gfx/tuxpaint/files/tuxpaint-0.9.20-gentoo.patch
@@ -0,0 +1,136 @@
+diff -ru tuxpaint-0.9.20.orig/Makefile tuxpaint-0.9.20/Makefile
+--- tuxpaint-0.9.20.orig/Makefile 2008-12-21 15:04:36.000000000 +0100
++++ tuxpaint-0.9.20/Makefile 2008-12-21 15:42:24.000000000 +0100
+@@ -137,9 +137,12 @@
+ # Icons and launchers:
+ ICON_PREFIX:=$(DESTDIR)$(PREFIX)/share/pixmaps
+ X11_ICON_PREFIX:=$(DESTDIR)$(PREFIX)/X11R6/include/X11/pixmaps
+-GNOME_PREFIX:=$(shell gnome-config --prefix 2> /dev/null)
+-KDE_PREFIX:=$(shell kde-config --install apps --expandvars 2> /dev/null)
+-KDE_ICON_PREFIX:=$(shell kde-config --install icon --expandvars 2> /dev/null)
++GNOME_PREFIX:=
++KDE_PREFIX:=
++KDE_ICON_PREFIX:=
++DESKTOP_ICON_PREFIX:=$(PREFIX)/share/icons
++
++ENABLE_GETTEXT:=0
+
+ # Maemo flag
+ MAEMOFLAG:=
+@@ -200,7 +203,7 @@
+
+ #-ffast-math
+ OPTFLAGS:=-O2
+-CFLAGS:=$(CPPFLAGS) $(OPTFLAGS) -W -Wall -fno-common -ffloat-store \
++CFLAGS:=$(CPPFLAGS) -W -Wall -fno-common -ffloat-store \
+ $(call comptest,-fvisibility=hidden,) \
+ -Wcast-align -Wredundant-decls \
+ -Wbad-function-cast -Wwrite-strings \
+@@ -232,7 +235,10 @@
+ # "make" with no arguments builds the program and man page from sources:
+ #
+ .PHONY: all
+-all: tuxpaint translations magic-plugins tp-magic-config
++all: tuxpaint magic-plugins tp-magic-config
++ @if [ -n "$(ENABLE_GETTEXT)" ] && [ $(ENABLE_GETTEXT) -eq 1 ]; then \
++ make translations; \
++ fi
+ @echo
+ @echo "--------------------------------------------------------------"
+ @echo
+@@ -390,7 +396,7 @@
+ windows_ARCH_INSTALL:=
+ osx_ARCH_INSTALL:=
+ beos_ARCH_INSTALL:=
+-linux_ARCH_INSTALL:=install-gnome install-kde install-kde-icons
++linux_ARCH_INSTALL:=install-desktop-data
+ ARCH_INSTALL:=$($(OS)_ARCH_INSTALL)
+
+ # "make install" installs all of the various parts
+@@ -400,10 +406,13 @@
+ install: install-bin install-data install-man install-doc \
+ install-magic-plugins \
+ install-magic-plugin-dev \
+- install-icon install-gettext install-im install-importscript \
++ install-icon install-im install-importscript \
+ install-default-config install-example-stamps \
+ install-example-starters \
+ $(ARCH_INSTALL)
++ @if [ -n "$(ENABLE_GETTEXT)" ] && [ $(ENABLE_GETTEXT) -eq 1 ]; then \
++ make install-gettext ; \
++ fi
+ @echo
+ @echo "--------------------------------------------------------------"
+ @echo
+@@ -581,17 +590,50 @@
+
+ # Install a launcher icon in the Gnome menu
+ .PHONY: install-gnome
+-install-gnome:
++install-desktop-data:
+ @echo
+- @echo "...Installing launcher icon into GNOME..."
+- @if [ "x$(GNOME_PREFIX)" != "x" ]; then \
+- install -d $(DESTDIR)$(GNOME_PREFIX)/share/pixmaps; \
+- cp data/images/icon.png $(DESTDIR)/$(GNOME_PREFIX)/share/pixmaps/tuxpaint.png; \
+- chmod 644 $(DESTDIR)$(GNOME_PREFIX)/share/pixmaps/tuxpaint.png; \
+- install -d $(DESTDIR)$(GNOME_PREFIX)/share/applications; \
+- cp src/tuxpaint.desktop $(DESTDIR)$(GNOME_PREFIX)/share/applications/; \
+- chmod 644 $(DESTDIR)$(GNOME_PREFIX)/share/applications/tuxpaint.desktop; \
+- fi
++ @echo "...Installing launcher entry..."
++ @if [ "x$(PREFIX)" != "x" ]; then \
++ install -d $(PKG_ROOT)$(PREFIX)/share/applications; \
++ cp src/tuxpaint.desktop $(PKG_ROOT)$(PREFIX)/share/applications/; \
++ chmod 644 $(PKG_ROOT)$(PREFIX)/share/applications/tuxpaint.desktop; \
++ install -d $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/scalable/apps/; \
++ install -d $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/192x192/apps/; \
++ install -d $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/128x128/apps/; \
++ install -d $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/96x96/apps/; \
++ install -d $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/64x64/apps/; \
++ install -d $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/48x48/apps/; \
++ install -d $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/32x32/apps/; \
++ install -d $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/22x22/apps/; \
++ install -d $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/16x16/apps/; \
++ cp data/images/tuxpaint-icon.svg \
++ $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/scalable/apps/tuxpaint.svg; \
++ chmod 644 $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/scalable/apps/tuxpaint.svg; \
++ cp data/images/icon192x192.png \
++ $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/192x192/apps/tuxpaint.png; \
++ chmod 644 $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/192x192/apps/tuxpaint.png; \
++ cp data/images/icon128x128.png \
++ $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/128x128/apps/tuxpaint.png; \
++ chmod 644 $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/128x128/apps/tuxpaint.png; \
++ cp data/images/icon96x96.png \
++ $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/96x96/apps/tuxpaint.png; \
++ chmod 644 $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/96x96/apps/tuxpaint.png; \
++ cp data/images/icon64x64.png \
++ $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/64x64/apps/tuxpaint.png; \
++ chmod 644 $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/64x64/apps/tuxpaint.png; \
++ cp data/images/icon48x48.png \
++ $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/48x48/apps/tuxpaint.png; \
++ chmod 644 $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/48x48/apps/tuxpaint.png; \
++ cp data/images/icon32x32.png \
++ $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/32x32/apps/tuxpaint.png; \
++ chmod 644 $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/32x32/apps/tuxpaint.png; \
++ cp data/images/icon22x22.png \
++ $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/22x22/apps/tuxpaint.png; \
++ chmod 644 $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/22x22/apps/tuxpaint.png; \
++ cp data/images/icon16x16.png \
++ $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/16x16/apps/tuxpaint.png; \
++ chmod 644 $(PKG_ROOT)$(DESKTOP_ICON_PREFIX)/hicolor/16x16/apps/tuxpaint.png; \
++ fi
+
+
+ # Install a launcher icon for the Nokia 770.
+@@ -684,9 +726,6 @@
+ @install -d $(ICON_PREFIX)
+ @cp data/images/icon.png $(ICON_PREFIX)/tuxpaint.png
+ @chmod 644 $(ICON_PREFIX)/tuxpaint.png
+- @install -d $(X11_ICON_PREFIX)
+- @cp data/images/icon32x32.xpm $(X11_ICON_PREFIX)/tuxpaint.xpm
+- @chmod 644 $(X11_ICON_PREFIX)/tuxpaint.xpm
+
+
+ # Install the program:
+Only in tuxpaint-0.9.20: Makefile.bak