summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-29 22:40:38 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-29 23:02:02 +0100
commit2ab36b4e15ab63e64b0a4b20f5117455e84e58af (patch)
tree20772a8850553a90f146cf5727053a7d96611e37 /media-gfx
parentmedia-gfx/photoqt: USE exiv2 (local) -> exif (global) (diff)
downloadgentoo-2ab36b4e15ab63e64b0a4b20f5117455e84e58af.tar.gz
gentoo-2ab36b4e15ab63e64b0a4b20f5117455e84e58af.tar.bz2
gentoo-2ab36b4e15ab63e64b0a4b20f5117455e84e58af.zip
media-gfx/photoqt: Fix USE exif
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/photoqt/files/photoqt-1.7.1-cmake.patch13
-rw-r--r--media-gfx/photoqt/photoqt-1.7.1.ebuild2
2 files changed, 15 insertions, 0 deletions
diff --git a/media-gfx/photoqt/files/photoqt-1.7.1-cmake.patch b/media-gfx/photoqt/files/photoqt-1.7.1-cmake.patch
new file mode 100644
index 000000000000..5dfacf435a0e
--- /dev/null
+++ b/media-gfx/photoqt/files/photoqt-1.7.1-cmake.patch
@@ -0,0 +1,13 @@
+--- a/CMake/FindExiv2.cmake 2018-06-03 05:21:04.143148857 +0200
++++ b/CMake/FindExiv2.cmake 2018-12-29 22:35:40.770393025 +0100
+@@ -13,8 +13,8 @@
+ "${EXIV2_LOCATION}"
+ "${EXIV2_LOCATION}/include"
+ /usr/include
+- /usr/include/Exiv2
+- /opt/local/include/Exiv2
++ /usr/include/exiv2
++ /opt/local/include/exiv2
+ )
+
+ IF(EXIV2_INCLUDE_DIR)
diff --git a/media-gfx/photoqt/photoqt-1.7.1.ebuild b/media-gfx/photoqt/photoqt-1.7.1.ebuild
index b37af5d4f16a..a865dab8014b 100644
--- a/media-gfx/photoqt/photoqt-1.7.1.ebuild
+++ b/media-gfx/photoqt/photoqt-1.7.1.ebuild
@@ -41,6 +41,8 @@ DEPEND="${RDEPEND}
kde-frameworks/extra-cmake-modules:5
"
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+
src_configure() {
local mycmakeargs=(
-DDEVIL=$(usex devil)