summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2019-05-15 18:01:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-15 20:27:48 +0200
commit2f39ea71ddb4d2008a1ab414493196d3c94e05b7 (patch)
treec5c64a13664d48a7b5492f64bf6b0ff39192b2d6 /media-gfx
parentdev-lang/elixir: drop old (diff)
downloadgentoo-2f39ea71ddb4d2008a1ab414493196d3c94e05b7.tar.gz
gentoo-2f39ea71ddb4d2008a1ab414493196d3c94e05b7.tar.bz2
gentoo-2f39ea71ddb4d2008a1ab414493196d3c94e05b7.zip
media-gfx/openscad: fix boost-1.70.0 build
Fixes a build issue with >=boost-1.69 Closes: https://bugs.gentoo.org/684038 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12003 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/openscad/files/openscad-2015.03_p3_fix-boost-1.70.0-build.patch13
-rw-r--r--media-gfx/openscad/openscad-2015.03_p3-r1.ebuild5
2 files changed, 17 insertions, 1 deletions
diff --git a/media-gfx/openscad/files/openscad-2015.03_p3_fix-boost-1.70.0-build.patch b/media-gfx/openscad/files/openscad-2015.03_p3_fix-boost-1.70.0-build.patch
new file mode 100644
index 000000000000..7684eba92e82
--- /dev/null
+++ b/media-gfx/openscad/files/openscad-2015.03_p3_fix-boost-1.70.0-build.patch
@@ -0,0 +1,13 @@
+diff --git a/src/CSGTermEvaluator.cc b/src/CSGTermEvaluator.cc
+index 6416f29..b3753cf 100644
+--- a/src/CSGTermEvaluator.cc
++++ b/src/CSGTermEvaluator.cc
+@@ -109,7 +109,7 @@ static shared_ptr<CSGTerm> evaluate_csg_term_from_geometry(const State &state,
+ shared_ptr<const PolySet> ps = dynamic_pointer_cast<const PolySet>(geom);
+ // Since is_convex() doesn't handle non-planar faces, we need to tessellate
+ // also in the indeterminate state so we cannot just use a boolean comparison. See #1061
+- bool convex = ps->convexValue();
++ bool convex{ps->convexValue()};
+ if (ps && !convex) {
+ assert(ps->getDimension() == 3);
+ PolySet *ps_tri = new PolySet(3, ps->convexValue());
diff --git a/media-gfx/openscad/openscad-2015.03_p3-r1.ebuild b/media-gfx/openscad/openscad-2015.03_p3-r1.ebuild
index 1b34fa207c5e..043c1d22a21c 100644
--- a/media-gfx/openscad/openscad-2015.03_p3-r1.ebuild
+++ b/media-gfx/openscad/openscad-2015.03_p3-r1.ebuild
@@ -41,7 +41,10 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${PN}-2015.03_p2_uic_tr_fix.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-2015.03_p2_uic_tr_fix.patch"
+ "${FILESDIR}/${PN}-2015.03_p3_fix-boost-1.70.0-build.patch"
+)
S="${WORKDIR}/${PN}-${MY_PV}"