summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathy Vanvoorden <mathy@vanvoorden.be>2021-06-07 18:02:52 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2021-06-10 19:40:52 +0200
commita32c3cd7e73ebc0f1febc56abdf40944cc9ef506 (patch)
treee3a06e6c18f91e4497af8277c0d56066b86d2bd7 /media-gfx
parentdev-libs/libcharon: Version bump to 4.9.1 (diff)
downloadgentoo-a32c3cd7e73ebc0f1febc56abdf40944cc9ef506.tar.gz
gentoo-a32c3cd7e73ebc0f1febc56abdf40944cc9ef506.tar.bz2
gentoo-a32c3cd7e73ebc0f1febc56abdf40944cc9ef506.zip
media-gfx/cura: Version bump to 4.9.1
Closes: https://bugs.gentoo.org/793803 Closes: https://bugs.gentoo.org/731274 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Mathy Vanvoorden <mathy@vanvoorden.be> Closes: https://github.com/gentoo/gentoo/pull/21150 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/cura/Manifest1
-rw-r--r--media-gfx/cura/cura-4.9.1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-gfx/cura/Manifest b/media-gfx/cura/Manifest
index 5dfea09d774f..f77b0cbd1af8 100644
--- a/media-gfx/cura/Manifest
+++ b/media-gfx/cura/Manifest
@@ -1 +1,2 @@
DIST cura-4.8.0.tar.gz 31930258 BLAKE2B 0a10a03f5fa34ec0279b9476063f71d8ae904e05485b84fac011fa5061812cd74f4be6df7e6d93046365799fc2fb1bcf4d10d89c69d2c8455080f99c12cec153 SHA512 0a34438299908021242e47e74418e56fe61c41cff5c29df938b4705b5d23ceb6e1bd17b9eb8110f8ec75c7a08afe8928857d4f2fd5befa00c187bce717105711
+DIST cura-4.9.1.tar.gz 47870392 BLAKE2B 2471c8461f73ad2343f4c3315994c5f63781ae1e49cb4699cd66e7e77c25a93916931fbaa6598c4144707dbc7778c902dad3a25839c0523aaf51ed39aacd2463 SHA512 436b8e33514de67d6d680fe59ab9599a75a86caa7e63fbcd05297b12a435483ec0c9ca90557fe23f25590a24e533294915fc18a665fd5cdb77fcc3a05a9076bf
diff --git a/media-gfx/cura/cura-4.9.1.ebuild b/media-gfx/cura/cura-4.9.1.ebuild
new file mode 100644
index 000000000000..8c8c80d0005c
--- /dev/null
+++ b/media-gfx/cura/cura-4.9.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7..9})
+inherit cmake desktop python-single-r1 xdg
+
+MY_PN=Cura
+
+DESCRIPTION="A 3D model slicing application for 3D printing"
+HOMEPAGE="https://github.com/Ultimaker/Cura"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug +usb zeroconf"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="sys-devel/gettext"
+RDEPEND="${PYTHON_DEPS}
+ ~dev-libs/libarcus-${PV}:=[python,${PYTHON_SINGLE_USEDEP}]
+ ~dev-libs/libcharon-${PV}[${PYTHON_SINGLE_USEDEP}]
+ ~dev-libs/libsavitar-${PV}:=[python,${PYTHON_SINGLE_USEDEP}]
+ ~dev-python/pynest2d-${PV}[${PYTHON_SINGLE_USEDEP}]
+ ~dev-python/uranium-${PV}[${PYTHON_SINGLE_USEDEP}]
+ ~media-gfx/curaengine-${PV}
+ ~media-gfx/fdm-materials-${PV}
+ dev-qt/qtquickcontrols[widgets]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_MULTI_USEDEP}]
+ dev-python/keyring[${PYTHON_MULTI_USEDEP}]
+ dev-python/mypy[${PYTHON_MULTI_USEDEP}]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQt5[-debug,${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQt5-sip[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-python/sentry-sdk[${PYTHON_MULTI_USEDEP}]
+ sci-libs/shapely[${PYTHON_MULTI_USEDEP}]
+ usb? ( dev-python/pyserial[${PYTHON_MULTI_USEDEP}] )
+ zeroconf? ( dev-python/zeroconf[${PYTHON_MULTI_USEDEP}] )
+ ')"
+DEPEND="${RDEPEND}"
+
+DOCS=(README.md)
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ sed -i -e "s:lib\${LIB_SUFFIX}/python\${Python3_VERSION_MAJOR}.\${Python3_VERSION_MINOR}/site-packages:$(python_get_sitedir):g" CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # trimesh not available in portage
+ local mycmakeargs=(
+ -DCURA_BUILDTYPE="ebuild"
+ -DCURA_VERSION=${PV}
+ -DCURA_NO_INSTALL_PLUGINS="AMFReader;Toolbox;TrimeshReader"
+ -DCURA_DEBUGMODE=$(usex debug)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ doicon icons/*.png
+ python_fix_shebang "${D}/usr/bin/cura"
+ python_optimize "${D}${get_libdir}"
+}